Jump to content
future_ex_kid

DSDT patch for TOSHIBA Satellite L750

230 posts in this topic

Recommended Posts

Advertisement

Yes, downloaded original bios update package from Toshiba, unpacked everything, patched the .fd bios file, and used the toshiba utility to flash it back.

 

I've just installed a fresh 10.8.2. With patched bios I have native speedstep. I patched dsdt by myself (after read your dsdt and google), now my L755 hackintosh status as below:

 

1. Working: Speedstep (SSDT i5 2450M), Lan Ar8151 (kext), Wifi Ar9285 (dsdt and patched IO80211Family.kext ), Conexant cx20585 (patched AppleHDA and dsdt so that Mac recognize as built-in device, speaker and headphone auto switching), VGA GT525M (dsdt and Graphic enable in Chamelon), Battery (smartapplebattery kext), Keyboard and touchpad ([url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]), Webcam (native), USB 3.0 ([url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url])

 

2. Not working: Sleep and wake up, if shutdown laptop when AC is on I need to remove AC and Battery in order to start PC again, HDMI audio, bluetooth.

Share this post


Link to post
Share on other sites

Update. After patch OpenCL my 10.8.2 L755 lappy can sleep and wake up as normal. Able to adjust audio and brightness by Fn key. Only bluetooth still not working.

Share this post


Link to post
Share on other sites

Update. After patch OpenCL my 10.8.2 L755 lappy can sleep and wake up as normal. Able to adjust audio and brightness by Fn key. Only bluetooth still not working.

 

After reading you, i have reinstall my graphic drivers, patched opencl and check again sleep, now all problems are gone, it was a driver issue, thanks. :)

Share this post


Link to post
Share on other sites

Updated from 10.8.2 to 10.8.3, only need to update the newest Cuda driver and roll back AppleHDA kext (No need to patch OpenCL). All working except bluetooth and HDMI audio.

Share this post


Link to post
Share on other sites

I have patched 3.60 bios update, its md5 is 82163435EE5D0346CD5B73CB28B4694D can you tell me if it is correct?. With the patched bios windows and linux runs correctly? I have a triple boot with chimera. What i have to do to change audio kext from vodoo 0.82 to patched aplple HDA? Lotst of questions LOL

Share this post


Link to post
Share on other sites

I have patched 3.60 bios update, its md5 is 82163435EE5D0346CD5B73CB28B4694D can you tell me if it is correct?. With the patched bios windows and linux runs correctly? I have a triple boot with chimera. What i have to do to change audio kext from vodoo 0.82 to patched aplple HDA? Lotst of questions LOL

 

I modified bios ver 3.6. You can download here

Other driver of L755 for windows :

 

After extract everything from downloaded bios, you will have this:

sk1wv360\os2012321a_360\Madrid20R20RG_BIOS_WIN_V360\x64\BIOS.fd

 

 

 

Follow CodeRush instruction you will have a patched bios file (I run this patch in windows, I recommend you run script and flash your bios in windows, too).

 

1. Download tool here , unzip, rename folder to "PMPatch" and place at C:\

2. Copy the original BIOS.fd to "pmpatch" folder (Note: My windows is 64 bit version. If you install x86 then chose BIOS.fd from x86 folder)

3. Open CMD, run this command "cd C:\PMPatch"

4. Patch bios, run command "pmpatch C:\PMPatch/BIOS.fd C:\PMPatch/patchedBIOS.fd"

5. Rename patchedBIOS.fd to BIOS.fd and replace for the original once in "sk1wv360\os2012321a_360\Madrid20R20RG_BIOS_WIN_V360\x64\BIOS.fd" (pls take note x86 or x64)

6. Flash your bios: run InsydeFlashx64.exe in "x64" folder (or InsydeFlash.exe in x86 folder). PLEASE ENSURE that you are on AC and your battery remain more than 50% power. Windows then auto restart. Done.

 

Download and install applehda here for Conexant cx20585 and delete vodoo kext.

 

Edit your dsdt - HDEF deive"

Device (HDEF)

{

Name (_ADR, 0x001B0000)

OperationRegion (HDAR, PCI_Config, 0x4C, 0x10)

Field (HDAR, WordAcc, NoLock, Preserve)

{

DCKA, 1,

Offset (0x01),

DCKM, 1,

, 6,

DCKS, 1,

Offset (0x08),

, 15,

PMES, 1

}

Method (_PRW, 0, NotSerialized)

{

Return (Package (0x02)

{

0x0D,

0x03

})

}

Method (_DSM, 4, NotSerialized)

{

Store (Package (0x10)

{

"AAPL,slot-name",

Buffer (0x09)

{

"Built in"

},

"device-id",

Buffer (0x04)

{

0x69, 0x50, 0xF1, 0x14

},

"layout-id",

Buffer (0x04)

{

0x0C, 0x00, 0x00, 0x00

},

"model",

Buffer (0x1A)

{

"HD Audio Conexant Cx20585"

},

"name",

Buffer (0x11)

{

"Conexant Cx20585"

},

"device_type",

Buffer (0x11)

{

"Audio Controller"

},

"hda-gfx",

Buffer (0x0A)

{

"onboard-1"

},

"PinConfigurations",

Buffer (One)

{

0x00

}

}, Local0)

DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))

Return (Local0)

}

}

 

Or use my latest dsdt here:

 

P/s: disable USB legacy in bios setting for normal using usb 3.0

Share this post


Link to post
Share on other sites

As a side note to the USB 3.0, you can add to your DSDT (USB3.0 section) this patch into the PXSX device and use original Lacie drivers without patching, the code tricks the hardware id to match Lacies ones.

 

Enjoy. :star_sunglasses:

 

Full PXSX code:

 

	    Device (PXSX)
	    {
		    Name (_ADR, Zero)
		    Method (_DSM, 4, NotSerialized)
		    {
			    Store (Package (0x14)
				    {
					    "device-id",
					    Buffer (0x04)
					    {
						    0x94, 0x01, 0x00, 0x00
					    },
					    "vendor-id",
					    Buffer (0x04)
					    {
						    0x33, 0x10, 0x00, 0x00
					    },
					    "name",
					    Buffer (0x0D)
					    {
						    "pci1033,194"
					    },
					    "subsystem-id",
					    Buffer (0x04)
					    {
						    0x50, 0xFC, 0x00, 0x00
					    },
					    "subsystem-vendor-id",
					    Buffer (0x04)
					    {
						    0x9F, 0x05, 0x00, 0x00
					    },
					    "AAPL,clock-id",
					    Buffer (One)
					    {
						    0x02
					    },
					    "AAPL,slot-name",
					    Buffer (0x07)
					    {
						    "Slot-4"
					    },
					    "name",
					    Buffer (0x18)
					    {
						    "Nec XHCI Controller"
					    },
					    "model",
					    Buffer (0x28)
					    {
						    "Nec USB 3.0 xHCI Controller"
					    },
					    "device_type",
					    Buffer (0x0F)
					    {
						    "USB Controller"
					    }
				    }, Local0)
			    DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
			    Return (Local0)
		    }
		    Name (_PRW, Package (0x02)
		    {
			    0x09,
			    0x04
		    })
	    }

Share this post


Link to post
Share on other sites

@ resister: pls detail your sound id, codec..

@ pere: I will try, thank. I use your GT 525M code at your blog and have HDMI but only video, not audio. How about your? Your hdmi audio work? What is your sound card?

Share this post


Link to post
Share on other sites

My soundcards:

 

 

HDEF: 00:1b.0 Audio device [0403]: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller [8086:1c20] (rev 04)

This is the same conexant as you have.

 

 

HDMI audio: 01:00.1 Audio device [0403]: NVIDIA Corporation GF108 High Definition Audio Controller [10de:0bea] (rev a1)

I had add the HDMI code to the PEG0 section and i use voodoohda wich gives me HDMI audio selecting the secong HDMI output in systempreferences>audio.

I suppose you have to patch AppleHDA to include your hdmi audio hardware id.

 

Beginning of PEG0 code:

 Device (PEG0)
 {
	 Name (_ADR, 0x00010000)
	 Device (HDAU)
	 {
		 Name (_ADR, One)
		 Method (_DSM, 4, NotSerialized)
		 {
			 Store (Package (0x02)
				 {
					 "hda-gfx",
					 Buffer (0x0A)
					 {
						 "onboard-1"
					 }
				 }, Local0)
			 DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
			 Return (Local0)
		 }
	 }
 ........... rest of PEG0.

Share this post


Link to post
Share on other sites

@ pere: I tried add code to dsdt but didn't work (no PXHCD installation). For HDA, i don't how to patch hdmi with applehda, will try later :hammer:

 

For native HDMI you can use the EnableHDMIAudio=Yes flag into org.chameleon.boot.plist

 

 

I tried add code to dsdt but didn't work (no PXHCD installation). What do you mean with no PXHCD installation?

 

I simply extract the driver with pacifist and place it inside extra folder.

 

I do use version 1.0.10 as 1.0.11 generates tons of logs.

 

Original 1.0.10 Lacie driver attached.

 

https://dl.dropbox.c...XHCD.1.0.10.zip

 

UPDATE: More info about APpleHDA patching for HDMI audio.

 

http://www.projectosx.com/forum/index.php?s=&showtopic=1429&view=findpost&p=10812

Share this post


Link to post
Share on other sites

my audio card is the same as peres describes. I think tha the 7xx series only changes in the amount of memory, hd capacity, or procesor speed and the other parts are nearly the same specs

Report.htm

Share this post


Link to post
Share on other sites

my audio card is the same as peres describes. I think tha the 7xx series only changes in the amount of memory, hd capacity, or procesor speed and the other parts are nearly the same specs

 

Your lapy is exactly same as mine. All device and id (vendor, codec....) are the same.

Share this post


Link to post
Share on other sites

I cant understand why sound doesnt works. I have erased vodoo kext, copied your latest extra folder in root, user tonys app as you described in captures and instaled hda in S/LE.

 

One thing, what I do before instaling kexts is to make and hd backup using clonezilla, in case I cant enter if booting prrocess breaks, its very simple to use.

Share this post


Link to post
Share on other sites

I cant understand why sound doesnt works. I have erased vodoo kext, copied your latest extra folder in root, user tonys app as you described in captures and instaled hda in S/LE.

 

One thing, what I do before instaling kexts is to make and hd backup using clonezilla, in case I cant enter if booting prrocess breaks, its very simple to use.

 

Post your extra folder and installed kexts.

Share this post


Link to post
Share on other sites

This is what I see in sistem info

 

https://dl.dropbox.com/u/86362288/Captura%20de%20pantalla%202013-03-22%20a%20la%28s%29%2010.00.37.png

https://dl.dropbox.com/u/86362288/Captura%20de%20pantalla%202013-03-22%20a%20la%28s%29%2010.00.46.png

 

This is my extra folder, the one you uploaded,

 

https://dl.dropbox.com/u/86362288/Extra.rar

 

And this are the rare kexts installed in my L/S/Extensions folder

 

https://dl.dropbox.com/u/86362288/Extrange%20kext.jpg

 

As I see thar disable appleeHDA was installed I erased it, removed vodooHDA and installed your AppleHDA but no sound, so I reinstalled vodooHDA 0.28

Share this post


Link to post
Share on other sites

This is what I see in sistem info

 

https://dl.dropbox.c...s) 10.00.37.png

https://dl.dropbox.c...s) 10.00.46.png

 

This is my extra folder, the one you uploaded,

 

https://dl.dropbox.c...62288/Extra.rar

 

And this are the rare kexts installed in my L/S/Extensions folder

 

https://dl.dropbox.c...trange kext.jpg

 

As I see thar disable appleeHDA was installed I erased it, removed vodooHDA and installed your AppleHDA but no sound, so I reinstalled vodooHDA 0.28

 

For sound: you have to remove VoodooHDA and AppleHDADisabler kext, then install AppleHDA again.

For battery: remove voodoobattery, install AppleSmartbattery kext

For native speedstep: flash the patched BIOS, remove NullCPUPowe kext

 

I dont know IOUSBMassstorage use for what? What i did in my lapy are:

 

1. Flash bios

 

2. Install only 4 kext: usb, lan, battery and applehda (in my dropbox folder named "kext")

 

Chamelon setting: https://www.dropbox....elon wizard.png

 

That all.

 

@ pere: with PXHCD kext my usb 3.0 port auto eject external HDD (after 2-5 minutes). Then I have to remove that kext and install IOUBFamily, now i can plug my WD Passport 1TB as long as I want.

Edited by fantomas1

Share this post


Link to post
Share on other sites

Here is my updated extra folder and drivers.

 

You will have to patch CUDA driver and generate your own serial number for SMBIOS.plist (Links included).

 

For USB 3.0 funcionality remember to disable Legacy USB on bios as tranduyquang pointed.

 

I have included patched BIOS.fd file to get proper speedstep, but is better you patch your own updated bios (Link included).

 

DSDT includes:

Speedstep patch.

Nvidia Patch

Generic patches and fixes

Wifi patch

Usb patches

HDMI audio patch

Wake up and sleep.

Native USB 3.0 Lacie driver support (Note that Lacie original driver only support Lacie external drivers).

 

Here is an alternative USB 3.0 driver: http://www.insanelym...-x-with-source/ (You have to delete PXHCD.kext from Extra folder and place this one).

 

SSDT includes correct speedstep settings for Mountain lion, thanks to Revogirl blog, you have to edit the frequency settings if you have a newer CPU.

 

 

 

Download: https://dl.dropbox.c...750 ML 10.8.zip

Share this post


Link to post
Share on other sites

 

You will have to patch CUDA driver and generate your own serial number for SMBIOS.plist (Links included).

 

 

Wake up and sleep. (USB 3 port will not wake after sleep)

Download: https://dl.dropbox.c...750 ML 10.8.zip

 

I think only 10.8.2 need to be patched openCL and installed 304.00.05f02. I install hackintosh for fun so that I've just install a fresh 10.8.3 and it's no need to be patch openCL, only newest CUDA driver (original). For usb, as I said I dont use PXHCD kext because my WD my passport 1Tb auto be ejected after 5-10 minutes. Then I use patched AppleUSBXHCI from here. Now usb 3.0 wake up and work after sleep. Even if you don't eject usb before sleep then when wake up usb 3.0 auto reconnect again but it's a dialog show that "Your usb has not been ejected properly..."

 

P/s: what LegacyInjectorToshiba kext use for?

Share this post


Link to post
Share on other sites

I think only 10.8.2 need to be patched openCL and installed 304.00.05f02. I install hackintosh for fun so that I've just install a fresh 10.8.3 and it's no need to be patch openCL, only newest CUDA driver (original). For usb, as I said I dont use PXHCD kext because my WD my passport 1Tb auto be ejected after 5-10 minutes. Then I use patched AppleUSBXHCI from here. Now usb 3.0 wake up and work after sleep. Even if you don't eject usb before sleep then when wake up usb 3.0 auto reconnect again but it's a dialog show that "Your usb has not been ejected properly..."

 

P/s: what LegacyInjectorToshiba kext use for?

 

The Legacy injector injects SPeedstep Data into Acpi_SMC_PlatformPlugin.kext and Graphics power management into AppleGraphicsPowerManagement.kext

 

 

This Cuda Benchmark failed till i did patch the driver in 10.8.3

 

http://www.insanelym...-07-march-2013/

Share this post


Link to post
Share on other sites

Hello

 

I am an owner of a Toshiba satellite l750-1GN Laptop ( http://www.toshibamea.com/ComputerProduct/4/Satellite_L750-1GN/50058?pageid=4 ) . I have ML installed through Unibe@@t anddd.... it seems that it is working well , i have ethernet and wifi kexts installed , graphics seem to be working BUT i have no sound, HDMI , VGA , USB 3.0 and i need to unplug after i shut down in order to boot up and of course the missing DSDT . The thing is i am a newbie to the hackintosh world ( i am into things for about a week ) and i have no ideas regarding DSDTs and that's why i am asking in this section , it would be too cool if i just had to copy and paste files since you guys have already worked this out.What is of paramount importance is that i am close to a deadline for a presentation at school and i need audio to be working , everything else is secondary .

 

Spkone

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×