Jump to content
InsanelyMac Forum
Sign in to follow this  
ico

HELP with Acer 8940G Mountain Lion Install NEEDED

Recommended Posts

This Mountain Lion just won't boot up into Installion screen. I've gone through the "still waiting for root device" thread to no avail - nothing explained there - is of any help so far. That is why I deided to start a new thread as an Acer 8940G.

 

I've tried USB and HDD plus all the flags -f -x -v npci=0x2000 GraphicsEnabler=No busratio=25 PCIRootUID=0 & 1 myhack, ######, chameleon 2045 - NOTHING NADA Nichewo NICHTS NIENTE Grrrrrrr

 

System Quad Core i7 1.6 Mhz 4gb Ram Gts 250m

 

Any suggestions any help out there?

 

Also I cannot get 10.7.4 to work all Network is gone after installation BCM LAN and Atheros wireless nothing functions PLUS iCloud failure though I tried removing connections and Networkinterfaces plist nothing no registering possible, snow leopard flows like a smoothy though.

 

I thank any of you for their time and advice!!!

post-45898-0-12729600-1345309947_thumb.jpg

Share this post


Link to post
Share on other sites
Advertisement

what method you use for install? you partition is MBR or Guid ? have you set in your bios SATA /ACHI ?

Share this post


Link to post
Share on other sites

Yes I've tried both GUID and MBR also set AHCI and IDE and still same screen. Install method via Restore function etc. ...

 

thank you for your reply!

Share this post


Link to post
Share on other sites

still waiting for root device even with above instructions. does anyone think it might be the system Acer 8940G or do I have to use a specific boot loader plus dsdt.aml?? sorry folks but really frustrating.

+enjoy your days!

Share this post


Link to post
Share on other sites

Man the stupid freaking quizes to post a reply here.

 

I got Mountian lion working on the Acer 8940G. Here is what ya need to do.

 

First look for on google Acer 8940G bios mod you need to get the mod.rar file it contains a custom bios that allow you to edit things in the bios.

Under PCH controls you have to disable all PCI express power management stuff.

Also make sure to set dvd to boot too the iatkos which seems to be the only version that works.

 

It will now allow you to install Mountain lion takes some time but works.

After you reboot it will reset all settings in the bios so youll have to rememeber to set them back to what I said above only this time set HD to boot.

Now it will start loading but the graphics will not work. Reason for this is iatkos sets the Smbios to a MacBook Pro 3,1 it needs to be 8,1 to boot.

Boot iatkos in single user mode and mount the root directory.

cd to extra and then nano smbios.plist

Change the 3,1 to 8,1 save and reboot. Same goto bios make sure settings are correct.

After that it will boot into Mac OSX 10.8.2 but a few things I have not figured out how to get working yet.

The keyboard and touch pad will not work, USB mouse and Keyboard will.

Wireless is a no go but if you use something like a airlink 101 USB adapter it will.

I'll keep trying differnent things to get touch pad working and keyboard but for now I'm very happy it works.

Share this post


Link to post
Share on other sites

Hi There Wolf_Tech,

 

I am speechless! Many thanks for your guidance! I am trying it out just now. really funny since I had completely given up.

 

thanks again mate!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Similar Content

    • By DEL_T
      Hi guys, I tried to install a Hackintosh with High Sierra on my Laptop ACER Aspire V3 772G747a8G75M (Intel Core i7-4702MQ, Board VA73, bios Hyn, 1 SDD with Windows10, 1 HDD for data, onboard HD4600+nvidia 760M ==> attached file with full description).
      I followed several tutorials (https://www.aioboot.com/en/clover-boot-disk/, yours about 772G installation).
      All was good : creation of the USB Stick, downloading HighSierra image on my partition (partition HFS+ created HDD SATA in the second disk).
      No pb encounted during these steps : USB OK, recognized partition, 2 hours download but ok.
      But I'm struck during the final HighSierra setup in the partition : the boot on clover is ok, the OSX progress bar started and stops with a sign of prohibited direction.
      With verbose mode, i can see "still waiting for root device" (difficult to read because pixelized).
      Many search on forums related a USB issue but I don't understand since previous steps were ok (USB install, partition recognition and downloading).
      After many and many search and tries, no way, no boot 8-(
      I tried :
          - all the arguments (cpus=1 npci=x2000 -v -x -f UseKernelCache=No dart=0 nv_disable=1 USBBusFix=Yes busratio=25 PCIRootUID=0) and variation (PCIRootUID=1 and 2, npci=x3000)
          - starting with options, with kext, without kext
          - change usb2 location
          - add kext (I have these ones for the moment in the Other directory : ACPIBatteryManager.kext, AppleALC.kext, ApplePS2SmartTouchPad.kext, BCM5722D.kext, FakePCIID.kext, FakePCIID_Intel_HD_Graphics.kext, FakePCIID_Intel_HDMI_Audio.kext, FakePCIID_XHCIMux.kext, FakeSMC.kext, IntelGraphicsFixup.kext, IntelMausiEthernet.kext, Lilu.kext, NullCPUPowerManagement.kext, Shiki.kext, USB_Injector.kext, USBInjectAll.kext)
          - usbownership flag
          - Fake Id for ATI set to 0x12040000
      Always the same string. Damned !!!!
      I need you guys. Any idea ?
      Is it because my partition is upon the HDD ans not the SSD ? because the partition is not set as active ? pb with kext version ?...
      In attached file : 
      - technical config
      - config.plist
      - Clover's report (F4 key)
      - some harcopies to understand
      sysconfig.HTM
      config.plist
      preboot.log













    • By fusion71au
      AppleAHCIPort.kext v328 from High Sierra PB1_17A291m.
       
      Info.plist has been edited so Bundle version is 999.1.1 ---> give higher priority loading in kernel cache/pre-linked kernel than v329 from later betas/GM. Need to disable SIP (since editing info.plist invalidates Apple's kext signature).
       
      Install in /Library/Extensions (so doesn't get over-written during updates) repair permissions, rebuild caches eg
      sudo chown -R 0:0 /Library/Extensions/AppleAHCIPort.kext && sudo chmod -R 755 /Library/Extensions/AppleAHCIPort.kextsudo touch /System/Library/Extensions && sudo kextcache -u /
      Test kext is loadable...
      sudo kextutil -tn /Library/Extensions/AppleAHCIPort.kext
      Confirm kext is loaded after rebooting the system...
      kextstat | grep AHCIPort
      To use with a USB installer, the kext needs to be included in the prelinkedkernel. Use PLK.tool attached to post#13 to create a new prelinkedkernel with AppleAHCIPort.kext v328, then replace original prelinkedkernel in the installer - post#16.
    • By b31k
      Hello
      My system is
      Asus Z170-P Motherboard
      i5 6600K Processor
      NVIDIA GeForce GTX 1050 Ti 4095 MB
      Be-quiet 500W PSU
      Crucial 16 GB 2400 MHz DDR4

      BIOS:

      xHCI Handoff enable
      Serial Port disable
      SATA AHCI mode
      IOAPIC 24-119 Entries (enable y disable) two mode stuck

      I can not build a robust and stable system, The system Sierra is already installed but when I restart or shut down, I get the error Still waiting for root device error, but after too many reboot ( from 2 times to 9) start correctly or other times leave too minutes, with prohibited symbol and finally starts.
      Once started recognised correctly HDD.
      ​Also I tried with a new  EVO860 nvme SSD , but I have the same problem.
       
       
      I dont know because sometimes yes sometimes no, the system stuck in this error
      ​I add some information files and logs.
       
      sudo touch /System/Library/Extensions && sudo kextcache -u /
      kext-dev-mode allowing invalid signature -67030 0xFFFFFFFFFFFEFA2A for kext HackrNVMeFamily-10_12_6.kext
      kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakeSMC.kext
      kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext BrcmPatchRAM2.kext
      kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext BrcmFirmwareRepo.kext
        thank you.


    • By TheCoolGuy
      So i'm trying to install OSX 10.4 Tiger (patched for intel cpus) on a 9 year old laptop, so far i've burnt a DVD and tried to boot from it, when not starting with -v it loads and then a prohibited sign shows up, and when starting with -v it keeps saying "still waiting for root device", i've tried multipile fixes and none of them work, and im sure there isnt a problem with the computer as it also fails to boot on my core 2 duo machine, so is it possible one of you guys knows how to fix this? Thanks in advance!
    • By Bruno49
      Salve, sono passato da Yosemite ad El Capitan, dopo aver installato quest'ultimo sul PC in firma con il bootloader chameleon, tutto funziona correttamente: scheda grafica, rete ed audio, usb etc.. tutto ok, l'unico problema è che quando avvio il pc senza la USB di installazione, quindi direttamente da HD dove ho installato El Capitan, dopo diverse righe con AppleUSBEHCIPort@fd300000..... il pc si blocca su : still waiting for root device. Quindi sono costretto ad avviare sempre dalla USB.
      Qualcuno può' aiutarmi per piacere? 
×