Jump to content

[Samsung Q45 A005] - DSDT problems


1 post in this topic

Recommended Posts

Hi to all.


Recently I've reinstalled my Samsung Q45 (in signature) with Lion (updated to 10.7.4) and Windows 7, dual boot in the same HDD without any DSDT.aml.

After installing some kext I had keyboard, touchpad and graphics working ok. (With kernel flag arch=i386 full QE/CI support)

All seems to work ok, but if I try to use sleep function I get some problems. My laptop screen goes black but it doesn't stop, if I power off it (pressing power button) and then restart it, the system seems to wait "infinity" after bios standard operations. The only way to get laptop start again was to reset bios removing internal battery for a minute.

Another strange thing, but not connected to the sleep problem, was firewire port. My laptop has a ricoh firewire (lspci command tells "Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 09)") that seems to work under OSX 10.4.1but under Lion the System Information tells "No firewire detected".


I thought that a correct DSDT.aml could solve it, so I tried to extract it from my laptop phoenix bios.

Under windows I installed "Phoenix bios editor" and I opened bios rom file to extract dsdt.dsl, then under Lion I used iaslMe to compile it but I got some errors.

I attach dsl file and iaslMe log in this post.


After this attempt, I found a topic explaining how to make dsdt.aml from command line.

I tried it, but the DSDT seems to be different from the previous. I don't know which is the correct one, but I tried to put this one to extra folder with no result: sleep and firewire continue not working. I think that I need some DSDT patch, but I don't know what I have to change. I also attach the DSDT extracted from the ioreg command line decompiled to dsl.


I hope someone can help me.


Thanks in advance.






Link to comment
Share on other sites


  • Create New...