Jump to content
InsanelyMac Forum

GeForce GTX 560Ti weird behaviour

Recommended Posts

Hi guys!


I'm writing from a ML 10.8 machine, installed on a P5Q-E with an EVGA GeForce GTX 560Ti as main video card.


The whole setup has been pretty flawless and easy, it's running mostly vanilla, with Chameleon 2042 as bootloader, plus few extra kexts: AD2000b, HDAEnabler, HDEFEnalber for audio, NullCPUPowerManagement, FakeSMC and SleepEnabler, and just some bits changed in the vanilla AppleRTC (to avoid the CMOS reset on sleep), AppleYukon2 and GeForceGLDriver.bundle (to enable respectively the internal Ethernet interface and the OpenCL for the GPU (officially available only on GTX 570 and greater)).


As the last thing in the post-installation, I've supplied to chameleon a MacPro 3,1 smbios, plus a patched DSDT (for ACPI shutdown/restart, patch found on olarila and applied to my bios DSDT dump) and SSDT tables dumped in AIDA64, and finally installed the official nVIDIA CUDA package from the nvidia website.


The whole machine is running greatly, bloody fast and extremely snappy performance, with full QE/CI and GPU acceleration with the vanilla GeForce driver. :)


I've also installed the netkas' HWSensors package, enabling some plugins for the FakeSMC kext and the HWMonitor app, just to keep an eye on temperatures and CPU/GPU clocks.


So why have I wrote this whole WOT?


Well, here comes the weird behaviour: after a cold boot or just a reboot, the whole cpu speedstep/gpu power management thing works without a hitch, scaling up or down CPU multiplier and/or GPU clock depending on what's requesting more power.


(a small premise: the GTX 560ti bios has 3 power levels, with 3 different GPU/VRAM/Shaders clocks and voltages, for the GPU they are respectively 50MHz at full idle, 405MHz on medium load and 850MHz at full speed, see attached screenshot for reference).


The GPU as i said before is working correctly, throttling from 50MHz through 405MHz to 850MHz forward and backward depending on how much is the graphics load (e.g. the login cube rotation animation, as well as running a benchmark like Unigine Heaven), but when I leave the machine idling (locking the screen to the login page, shutting down the display and, well, getting away from it), some hours after, when I log back to the desktop, the GPU clock, according to HWMonitor, is locked at full speed (850MHz), and doesn't throttle back to 405 or even 50MHz, regardless of the real GPU load at that moment.


I've tried starting a benchmark and suddenly quit it to see if it would throttle back, I've double checked with Activity Monitor to see if there's a background/resident process (using the GPU) responsible for this strange behaviour, but until now I wasn't able to find anything related, it just locks at full speed after some time idling without activity.


Any thought on what could be the cause of this strange behaviour (and maybe a solution)? apart from this, the machine is running greatly, but this particular thing causes me a lot of annoyance because I don't want to waste extra energy (and then dissipate more heat) when unnecessary.


Could it somehow be related to the Mountain Lion bad battery performances some users are experiencing on their laptops, for instance? (I'm not really sure about that, but if a laptop GPU does the same, well, the energy consumption is greater and then the battery life smaller).


Or could it just be a wrong reading from the GeForceX plugin of the FakeSMC?


Thank you very much :)


//edit: i've attached some screenshots with the clocks table and some measurements made with GPU-Z, I think the middle one (light loal) is the one happening under ML, but I cannot explain to myself why.



Share this post

Link to post
Share on other sites

With some trials and errors, I've been able to track down who causes the problem: the display sleep.


If I disable display sleep completely, the problem disappears, and it's not related to machine sleep (putting the machine in sleep state and resuming afterwards doesn't affect the GPU throttling at all, only the display sleep seems responsible for that).


Anyone knows why the display sleep makes the GPU clock stuck to the higher profile, and maybe a solution to resolve this strange behaviour?


Thanks :)

Share this post

Link to post
Share on other sites

No idea, but it does remind me somewhat of the issue with the 550 ti and garbled graphics after display sleep (no solutions for that either).


Have you tried AppleGraphicsPowerManagement.kext (aka AGPM) edits? You don't mention those. Also, AGPM isn't run if you're using MacPro 3,1 smbios, you need to use 4,1 or 5,1 or one of the iMac smbios. It may be that all you need to do for the 560 is change smbios so AGPM actually runs, although the edits to thresholds might make things run smoother.


rampagedev has the info:



[edit] Also just found this other more comprehensive AGPM edits post on here http://www.insanelymac.com/forum/index.php?showtopic=266036

Share this post

Link to post
Share on other sites

Hello, I've tried changing the smbios, but looks like nothing has changed.


Despite loading AGPM or not, the power management of the GPU works anyway (I suppose is drive by its own BIOS), but as soon as the display goes in sleep mode, when I resume the GPU stucks at the maximum frequency (850MHz).


It only happens after display sleep, if I disable display sleep completely, the power throttling works as expected.

Share this post

Link to post
Share on other sites

Hi, I use a EVGA GTX 650 as graphic card, and have exact same issue. the frequency load at full speed at random time [see my post here]


how did you change the "display sleep" without "

related to machine sleep", I changed it through system preferences, and the "machine sleep" also turns off...


I tried your method(turnoff display sleep), but it won't solve my problem.

Edited by Gringo Vermelho
Massive overquoting deleted, please don't quote entire posts for no reason.

Share this post

Link to post
Share on other sites

I have this problem and have discovered a sort of work around. What I do is turn off automatic display sleep. I set a hot corner to put the display to sleep. When I want to put the display to sleep I move the mouse to the hotcorner, wait a second then click the mouse 3 times. Clicking the mouse will cause the display to wake at the lock screen. The display will go back to sleep shortly only this time it'll stay in the low power state.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.