Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

KVM switch for mac?

1 post in this topic

Recommended Posts

Hey guys, recently purchased a Belkin 4 port KVM... this thing is terrible. Model F1DD104L

Belkin specifically states support for Mac OSX systems, however the current corded Apple aluminium keyboard and optical mouse do not work at all.

Keyboard is not recognised at all by the system... and inputs the character 'z' permanently.

Mouse is jumping all over the place.

Leaving artifacts all over my screen in the dark areas.

Their excuse is the product works with OSX, just not Apple peripherals. Seeking RMA now, what a nightmare!


Looking for anyone who has gone through this before and found a solution that works with switching macs.


I will need DVI-D DUAL LINK as my monitor is the 30" 2560x1600 Apple cinema display.

Plus USB switching.

Audio not as important as I can do this with my amplifier but I guess most KVMs have this included.


Looking at ATEN, Gefen, ServerLink, IOgear etc.


Budget is $300.


Also does anyone know if I will need a DVI booster to get rid of these screen artifacts or will a decent KVM help?





Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By gachogavacho
      Hello everyone!
      I've been using the following hardware for some time now:
      CPU:  i7-3770 (LGA 1155)
      Video:  integrated Intel HD 4000 via HDMI  (About this mac: Reporting Intel HD 4000 1536MB)
      Storage: SSD Samsung 850 Evo 250GB
      Apple native support Wifi card (can't find the model at the moment)
      Presently I have 10.12.6 installed.
      I upgraded months ago to 10.12.3, and at that time, I had an old VGA monitor connected to the DVI input via a VGA to DVI adapter. The computer would start up and the resolution would be fuzzy. Somehow, I discovered if i unplugged the monitor and plugged it in, the resolution would fix. Since we left the computer on always, I didn't think much of it. I had posted about it and tried to see if anyone could give me an idea as to why it was doing it but no real answers came through.
      [sTILL NOT WORKING AT FULL REZ] Now, I discovered recently that Apple has said they don't support 3rd party adapters and VGA, so I upgraded to a new monitor:
      LG 25UM58-P 25-Inch 21:9 UltraWide IPS Monitor 
      [THIS IS FIXED, THANKS!] I also upgraded to 10.12.6 before installing the monitor. The computer starts up using the usb install drive when i select my installation. But the video still looks fuzzy. I'm attaching a picture. https://goo.gl/photos/YsdM7KfE54WRE52D8
      What do you think i'm missing? EFI folder attached.

      edited to include IoReg file. 
      Send me gachovacho's iMac.zip
    • By Callum A
      Just introducing myself to the forum with my setup and system specs
      MSI B150i 
      i7 6700k
      16GB DDR4 Corsair Vengeance
      4 x 512GB Kingston SSDNow drives in RAID 10
      EVGA GTX 960 SSC
      I run Sierra 10.12.2 in a KVM through libvirt and absolutely love it! No hardware compatibility issues whatsoever running it this way, and I only lose about 5% of my CPU performance (at least according to Geekbench). I pass my GPU through to MacOS directly to benefit from all of the awesomeness that comes with a dedicated GPU.
      Feel free to ask any questions! 
    • By Emphasising
      Hey all,
      I recently just finished my first ever Hackintosh build and am extremely happy with it apart from one major issue..
      The specs:
      Intel Core Skylake Processor i5-6500
      Gigabyte H170N-WI-FI Motherboard
      Crucial Ballistix Sport LT 16 GB Kit (8 GB x 2) DDR4 2400
      Corsair 550W CS550M
      Samsung 850 EVO 250 GB
      Broadcom BCM94352Z DW1560 Wireless-AC 867M WiFi Bluetooth 4.0 NGFF M.2 Card (being shipped)
      OSX El Capitan (not sierra)
      NOTE: I'm using integrated GFX as I don't want to spend anymore just yet on a GPU but maybe in the near future!
      I followed ammulder's guide on installing El Capitan and everything is working apart from my Display Ports. I have a HDMI plugged in (top HDMI port on mobo) and works fine it's just when I have my other monitor hooked up using either the other HDMI provided or DVI port I get a complete blank display and my other monitor is still working as normal.
      I tried other guides, few different tweaks and even hotplugging but that doesn't seem to work. I also tried taking the HDMI out of the working port and inserting it into another HDMI or DVI and that doesn't seem to work either.
      Please help me as I would highly appreciate it and would love to be using this amazing build with 2 monitors instead of 1. 
      Regards, Emphasising
    • By hellslinger
      It's been a few years since I've visited or posted here. I've found a lot of great help yet again.
      I'm running Yosemite 10.10.5 on a QEMU/KVM with host PCIe passthrough for a GTX 970. My host machine is running Arch Linux with vfio extensions.
      It took most of the weekend, but I finally got the Nvidia driver working with the card, and full video acceleration is working for video playback and 3D. I installed Torchlight II from a standalone installer and it works just fine.
      For some reason, steam will just not run. It fails with Bus error: 10 . When I boot up in safe mode and try to run it, I can see in dmesg there are a few CODE SIGNING errors related to the steam_osx executable. I've tried replacing the signature with the codesign utility, but then the process seg faults with code 11. 
      If this were on linux, I could see where it is failing with strace and gdb, but since I can't get debug symbols for any of the OS stuff here, I'm wondering what someone more familiar with Mac OS would use?
      More to the solution: Is there a way, like repair permissions, to verify or repair the signing of the OS libs on Mac OS? Assuming the installation media was corrupted, is there a way to recover?
    • By FBarcenas
      I have an Nvidia 750 TI with 1DVI 1VGA and 1 HDMI. I'm running clover and Nvidia Web Drivers. I don't see anything in Clover Configurator that I recognize related to changing the display port.
      Thanks in advance for any help that can be lent.