Jump to content
InsanelyMac Forum
treyhamilton25

How to install iAtkos L2 on Dell Inspiron N7110

Recommended Posts

Dell Inspiron N7110

ACPI x64-based

DDR3 1333 (4GB)

Realtek ALC269

Bios Version A04

Intel Core i3-2310M CPU@2.10GHz (SandyBridge)

Intel HD Graphics 3000

Intel Centrino Wireless N-1030

Realtek RTL8139/810x

 

This is a tutorial on how to install iAtkos L2 on Dell Inspiron N7110.

 

Step 1: Boot up your N7110 with the iAtkos L2 DVD in the drive. It may take a while for it to load up the installation so just give it a little time.

 

Step 2: When the installation come up, select Disk Utilities and partition your hard drive.

a. Select your Hard drive you wish to use and click on partition.

b. Select 1 partition, rename to Mac OSX, make sure Mac Extended Journaled is selected.

c. Click on options under the partition and select MBR. After that hit partition.

 

Step 3: Close out Disk Utilities[/font]

Step 4: Select the Hard drive being used for your installation then click customize.

Step 5: These are the options I chose for installation

 

A: Chimera 2.1

B: Graphics Enabler

C: Built-in Etho

D: PCI Root-1

E: IOPCIFamily

F: Voodoo HDA (whole section)

G: USB 3.0

H: PS/2

I: Laptop Battery

J: AHCI SATA

 

Then click continue, and continue through the installation.

When your installation is finished, just select your installation location and press enter. And it will boot right up.

 

 

 

NOTE: If you have issues with being stuck on Apple Screen and hearing audio, try the following at the boot prompt:

type -s to enter single user mode.

once you're on root type:

 

mount -uw /

cd /System/Library/Extensions

mkdir IntelBack

mv AppleIntelHD* IntelBack/

mv AppleIntelSNB* IntelBack/

exit

 

Now you should be able to setup your new hackintosh. :)

Share this post


Link to post
Share on other sites
Advertisement

I have the same machine as you do but with an i5, BIOS A12, and 8GB of RAM and I cannot get these instructions to work. The touchpad does not work so I plugged in an external mouse. The DVD will not boot (it just freezes when I press any key or F8) when the mouse is plugged in when it starts loading up the bootloader and when I plug the mouse in after the bootloader starts the kernel, the optics come on but then shut off indicating the OS disabled the device.

 

Is there something that I'm missing here? I checked the BIOS for a legacy mode for USB or anything and there is nothing there. I haven't worked with Hackintosh in a long time but wanted to give it a try on my new machine.

 

Were you able to use the touchpad after installation? I can try messing around with USB ports and see if I get a different result and such but I'm not too hopeful and since nobody has managed to make a contiguous DVD (it jumps all over the place trying to find data and wears out the drive faster plus takes forever to boot) I won't mess around with it too much. This machine would be great if I could get OS X on it (well it is already great but it would be even better).

Share this post


Link to post
Share on other sites

Well after some fiddling, I finally got it installed but no matter what I do, I can't seem to get QE/CI on my HD 3000... if I put the kexts back and fix permissions I get stuck on the Apple screen again. Guess this laptop is a no go. Bummer.

Share this post


Link to post
Share on other sites

I'm not sure why it was freezing up on you. I never had that problem. And the touchpad only works after installation and installing a different kext. On the graphics situation, I'm not 100% sure on how to enable them. I've looked around a bit. But was unable to find anything that worked for me. I'm having Internet problems right now that will hopefully be resolved by the evening. I'm using my phone to post this. Once I get back online I'll try and post the touchpad kext. Also, did you replace your wifi card? I had to change mine to atheros because the intel pro/wireless wouldn't work. Lol

Share this post


Link to post
Share on other sites

Well I use an external adapter for wireless that is OS X compatible (I'm too far from the router for the wireless in the laptop to work) so I just installed the Snow Leopard driver off the CD and it works great. I think its interesting that in verbose mode, it picks up the ALPS Glide but doesn't activate it. I would definitely appreciate that kext.

 

I extracted the DSDT and put it in Chimera which now takes me to a black screen when the desktop launches (when the Intel HD graphics kexts are installed) so if we can get the 201 errors in our DSDT patched up, we might be able to get graphics working that way. The auto-fixer patches all but 1 error and a few warnings but obviously that stops it from being able to build the DSDT.aml file and I don't have much experience working with DSDT since I kind of dropped off the face of the OS X planet a few years ago.

 

What are you using for sound? VoodooHDA is horrid! Lots of background noise and it pops and hisses :/

Share this post


Link to post
Share on other sites

Yea, the pops and hisses are a problem. So I'm not using sound at all. lol. I'm not savy AT ALL with DSDT Patching. If I got into doing it though I may not have as many issues. I had to remove OSX from my gf's dell. She wanted to play games and since we couldn't get everything working perfect she wanted Windows back. :/

Share this post


Link to post
Share on other sites

You have the HD3000 on a N7110 working? How do i use this?

 

post-18550-0-15543200-1356303578_thumb.jpg

 

 

Just put the dsdt.aml in the /Extra folder. I'm pretty sure the rest of my kext are stock. I also have the chameleon r2149 and use GraphicsEnabler=y. And I'm using a smbios.plist from the MacBookPro8,3

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×