Jump to content
r b

Ideas on getting Logitech quickcam pro9000 to work in ML?

5 posts in this topic

Recommended Posts

Hello again,

 

Does anyone have any ideas on getting a logitech quickcam pro9000 to work in mountain lion?

Seems that the microphone works and is identified as "unknown USB audio device" under sound preferences' INPUT tab.

 

Trying to use it within a camera application fail. The little light on the front of it never goes on and no picture is ever displayed.

 

I've done some searching for drivers but have failed to find anything that look applicable.

I see that most people say it should just already work with apple's default drivers.

 

Logitech control panel didn't detect anything..

 

thank you for your time,

-Ryan

Share this post


Link to post
Share on other sites
Advertisement

Not sure about the pro9000 but if you want a webcam that works OOO with native Apple drivers, get the HD Pro C920. Works perfectly.

Share this post


Link to post
Share on other sites

I have the Logitech QuickCam Vision Pro and the Webcam Pro 9000 which is the Windows version of the same webcam and they both work in Snow Lion, Lion and Mountain Lion.

 

The mic of the Windows version (Webcam Pro 9000) show up as unknown usb audio device but it works.

 

Ive tested a few of the newer Microsoft webcams too and they work so Im thinking theres a problem with your usb.

Share this post


Link to post
Share on other sites

it works fine if i boot into windows7.

so.. maybe an issue with the USB setup or kext(s) or something...

 

thanks for the feedback!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By twikoffin
      Hello. My hardware is:
      AMD Athlon X2 7750 dual-core
      Gigabyte NVIDIA 8400GS 512MB ( [VGA] ,HDMI,DVI)
      Motherboard Gigabyte based on NFORCE without AHCI support (only IDE)
      I have successfully installed Mac OS Yosemite, Mavericks and El Capitan with AppleNFORCEATA.kext
      But I can't use it with Mac OS 10.8, don't know why, it just gives error and my internal HDD's are not appearing in Disk Utility.

       
         
    • By ltooz_audis
      I got both of my laptops Broadwell and Haswell working perfectly with the released Mojave but the webcam detected, internally and usb HD externally, BLACK - Screen. If the Framebuffer is not loaded (ie kext not loaded 7M), the webcam show picture. I'm using everything up to date: lilu, intelgraphicsfixup, AppleALC, etc... I think it has something to do with the new frame buffer and usbhostfamily.kext. Any pointer will be great. This is the last hurdle.


    • By Oschły
      Hi! I have problems with my mouse and keyboard on hackintosh.
       
      My mouse, Logitech G300s after installing Logitech Gaming Software slow down where cursor is near to something "clickable" (like exit buttons, etc.), when it is on this buttons, it's freeze on about 2s and it doesn't react on any mouse's move. I heard many users have this problem, but I didn't find solution. I don't want to uninstall LGS, because one button is changing mouse's DPI when I press it and with LGS I can disable it.
       
      My keyboard, Corsair k70 RGB can't be noticed in CKB. Just CKB doesn't see it. I tried to plug keyboard to USB 2.0 and 3.0, changing work modes (from 1000MHz/1ms to 500MHz/2s and slower), plugging after system's boot and nothing works and after install CKB media keys has stopped working.

      My specs:
      MOBO: Gigabyte P85-D3
      CPU: i5-4670
      GPU: GTX 750 Ti
      RAM: 8GB DDR3
      Ethernet: Realtek rtl8111
      Sound card: ALC 887
      OS: macOS Sierra 10.12.6
    • By hornpipe2
      I have a Mac Mini 2006 (upgraded) with Intel GMA950 graphics, running MLPostFactor 10.8.5.  It is connected to an ASUS VS197 LCD panel using DVI-D.  This is natively a 1366x768 panel that is recognized and works fine.
       
      However, the other choices for resolution are 4:3 800x600 and 1024x768, and then the oddballs 832x624 and 1360x768.  None of these are useful as a low-resolution widescreen for gaming or watching DVD content.  Specifically I want to get access to 848x480 or 854x480, and also 1024x576.  SwitchResX makes these choices available, but it doesn't work with a "full screen" game, presumably because the game directly queries OSX Display to get a list of valid resolutions and SwitchResX is bypassing that system instead.
       
      So the solution is obvious: buy a new computer pull the monitor's EDID data, hack it to enable new resolutions, and then tell OSX to use this custom EDID instead of the one retrieved from the monitor.
       
      Following the steps of the EDID injection guide, here is where I am:
       
      * Retrieve EDID, DisplayVendorID etc from ioreg.
      00 FF FF FF FF FF FF 00 04 69 F2 19 24 94 00 00 31 16 01 03 80 29 17 78 EA F5 45 A4 55 50 9E 27 0F 50 54 BD EE 00 81 C0 01 01 01 01 01 01 01 01 01 01 01 01 01 01 66 21 56 AA 51 00 1E 30 46 8F 33 00 9A E6 10 00 00 1E 00 00 00 FD 00 32 4B 18 53 11 00 0A 20 20 20 20 20 20 00 00 00 FC 00 41 53 55 53 20 56 53 31 39 37 0A 20 20 00 00 00 FF 00 43 43 4C 4D 54 46 30 33 37 39 32 34 0A 00 F1 * Use an EDID editor to enable new 848x477 and 1024x576 resolutions.  (Verify with an online EDID tool, and compare to the previous version)
      00 FF FF FF FF FF FF 00 04 69 F2 19 24 94 00 00 31 16 01 03 80 29 17 78 EA F5 45 A4 55 50 9E 27 0F 50 54 BD EE 00 81 C0 4B C0 4B CA 4B CF 61 C0 61 CA 61 CF 01 01 66 21 56 AA 51 00 1E 30 46 8F 33 00 9A E6 10 00 00 1E 00 00 00 FD 00 32 4B 18 53 11 00 0A 20 20 20 20 20 20 00 00 00 FC 00 41 53 55 53 20 56 53 31 39 37 0A 20 20 00 00 00 FF 00 43 43 4C 4D 54 46 30 33 37 39 32 34 0A 00 47 * Create a new subfolder and plist within /System/Library/Overrides/Display/ containing the new EDID string and monitor name.
      * Reboot.
       
      Now the problems begin.  Even though the plist file is being read (which I know because the Monitor Name has changed in Displays), the custom EDID is not being used.  When I dig into IORegExplorer I am able to come up with AAPL00,EDID string and it is the unmodified one read from the monitor.  I even tried a plug-and-unplug while OSX is running, and also tried to reset the SMC and NVRAM, but no dice.
       
      Do I need to start digging into DSDT hacking?  Is the Intel driver pulling down EDID during boot and I need to override it somewhere else?  What am I missing here?
    • By joaquinp
      Hackintosh Spectre XT 15t-400 Touchsmart Sierra
       
      For complete info go to my repo https://github.com/joaquinperaza/Hackintosh-HP-SpectreXT-15t-4000
      This i just a future discussion post. I want to contribute as  thank of all your help.
       
       
      I made this repo to collect all related info about this laptop. I am not using other dsdt or ssdt patches than clover ones, but I am open to your contributions. Where to start:
      Have a Mac? So prepare a USB using your preferred method, you can choose:
      Clover (Base guide Dont have a mac? Dont worry you can use a virtual box machine in your HP: To set up the vm use: http://www.wikigain.com/install-macos-sierra-10-12-virtualbox/
      I discovered and posted how to run usb intaller in VirtualBox VM using Linux/Windows host:https://www.reddit.com/r/hackintosh/comments/5zks4c/create_sierra_bootable_usb_from_virtualbox/
      I followed this guide that was the most similar to this model: https://www.google.com.uy/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&cad=rja&uact=8&ved=0ahUKEwiT2KW8v9HTAhWGIJAKHRtkAZIQFgggMAA&url=https%3A%2F%2Fwww.reddit.com%2Fr%2Fhackintosh%2Fcomments%2F5pwtdd%2Fhp_spectre_xt_pro_13b000_running_macos_sierra%2F&usg=AFQjCNEXuPraFVEtqD7am308-wVd7ssCZQ
      So I did it with UxxxBxxx, with this options: UEFI Mode and Inject Intel
      USB installer tunning:
      After completing the UxxBxxx installation donwload clover configurator and add the settings that appear in cloverconfIMG folder. PD:You should also select -v (verbose) flag in boot section in first tests. PD:Ignore ket patches for the moment Copy the drivers inside the drivers64UEFI folder to your EFI/CLOVER/drivers64UEFI folder. Copy the kexts from the kext folder to your EFI/CLOVER/kexts EXCLUDE VoodooHDA inside kext/10.12 folder. Sierra install:
      Now you're ready to run Sierra installer (if you are lucky the only issue you would have is no mouse and keyboard during install). Follow normal instructions for install OSX. Key points:
      Disable Secure boot in bios and disable legacy, enable cpu virtualization Boot vith -v flags in first tests. Post installation:
      Install those 'post install kext' with EasyKext Pro:
      VoodooPS2Controller.kext (Enable mouse and keyboard) USBInjectAll.kext (enable touchscreen and webcam) Dont install the optionals fixes yet. Reagarding audio i have tested to solution:
      Apply AppleHDA patched kext (Inside other files folder) //No microphone Use VoodooHDA installer and add the VoodooHDA inside kext/10.12 folder to clover. VoodooHDA provide microphone and beats audio but less quality and no volume. Hdmi fix: The plattform 0x01660004 dont have connectors, but is the onlyone compatible with our screen, so I patched the HEX table for you to make our screen compatible with 0x01660008 wich natively support our HDMI port. Just delete AppleIntelFramebufferCapri.kext from your System/Library/Estensions folder and immediately install the one inside kext folder/optional fixes with EasyKext Pro Then add this kextspatches in CloverConfigurator: | Name | Find | Replace | Plist checked? | | ------ | ------ | ------ | ------ | | AppleIntelFramebufferCapri | 04006601 01030101 00000002 | 04006601 01020402 00000004 | NO | | AppleIntelFramebufferCapri | 05030000 02000000 30020000 00000000 01000000 40000000 00000000 01000000 40000000 00000000 01000000 40000000 00000000 00000000 | 05030000 02000000 30020000 02050000 00080000 06000000 03040000 00040000 81000000 04060000 00040000 81000000 00000000 00020011 | NO |
      Wifi fix: Unfortunately our Intel Centrino N wifi card is not compatible i bought an Atheros AR9285 AR5B95, just replace and add install kexts inside Atheros AR9285 AR5B95 Sierra with EasyKext. | Name | Find | Replace | Plist checked? | | ------ | ------ | ------ | ------ | | AirPortAtheros40 | pci168c,30 | pci168c,2b | YES |
      Author Disclaimer:
      The majority of the software is public on the internet, I only have patched some files and wrote this guide, I am not responsible of any possible damage to your PC, do it at your own risk despite I consider it worth it. If you have any question/issue/suggestion/collaboration please report it via issue tab I will look it immediately.
×