Jump to content
InsanelyMac Forum
sniper9911

need help booting mountain lion installation on my laptoplaptop

Recommended Posts

hello there

thank you for giving me the oppertunity for writing this thread

anyway I have this modern laptop from samsung model is 300e4a-s0esa

core i5-2450m with 6gb of ram and nvidia optimus (intel 3000 + 520mx)

so far I was not able to boot my freaking system via the usb flash disk and I tried at least three ways so far but only one seems to work but I don't want to use it cause I need to find the problem with my method

I tried the method for the vanilla mac os x mountain lion and I did all the neccessory steps but it seems that my system does not see the bootable usb stick (I tried guid partition type but no luck strange even though my system is uefi compilant and I did set the ahci to manually enabled but I think I don't have legacy usb support)

I am now trying to make it mbr and redo the hole thing

I am doing this on a vmware image of lion 10.7.4 with a purchaced copy of the mac os x mountain lion app

any way I hope I can really boot to the installation this way

note : I selected smbios of the 9.1 mac book pro once and the other time I selected 8.3 mac book pro

I ma goin to keep this post alive until I completely reach the desktop of lion

 

ps: I really don't need to say this but the only working way for me was a tonymac with a cold boot  but I ma not happy with it and it catches my systems as a mac book pro 8.1 but I am discarding this way of use

 

if any one have an idea about laptop support files to boot my installation please tell me !!!

 

sorry for my newbishness and thanks in advance

Share this post


Link to post
Share on other sites
Advertisement

Specs:

 

Samsung 300E4A-S0ESA

i5-2450m

6 GB of Ram

Intel 3000

Nvidia 520MX

 

Guide:

 

Use the following boot flag and report back with a

picture of what is no the screen:

 

-v

 

Also what do you mean that your computer does not see the flash drive? Are you saying that in the laptop BIOS Boot menu it does not appear?

Share this post


Link to post
Share on other sites

i don't have a bios menu to check for boot sequence

i only did put the usb-hdd option at the top then cd then sata hdd

and i do mean that bios skips the usb flash (guid partitioned) and boots directly from sata hdd

 

i am planing on installing the ML on a 32gb usb san disk cruz blade

 

thanks for your help i will report back soon i hope

Share this post


Link to post
Share on other sites

sorry for my bad expression

what I meant was that I did change the boot sequence from the bios itself not from the boot menu because I don't have one

any way I managed to boot up my usb flash drive

the problem was that no one told me that it has to be mbr partitioned okay

but I had a panic but I don't know what it is

I took a picture of it and I will attach

post-1058527-0-21433600-1344821834_thumb.jpg

post-1058527-0-40270900-1344821916_thumb.jpg

Share this post


Link to post
Share on other sites

thank you for understanding

do you have ann idea about that panic code in pictures

its getting late already here at my country so I will countinue in. at 12gmt

Share this post


Link to post
Share on other sites

thanks every one for your feedback

thanks ifire for pointing out the extra folder

but anyway i was experimenting with the installation methods soo deep that i put alot of kexts in my installation folder

now i only did put the macbook pro 8.3 smbios.plist (only modified the cpu max speed to 3100 and the memory to ddr3 1333mhz) file in my extra folder and the themes folder created by the chameleon wizard

and vioalla i booted into the installation and i saw the new apple (ooh yeah finally) but i got stuck on the welcome screen because there is no KEYBOARD OR MOUSE support for my laptop (mouse is ps2 elan tech and the keyboard is a generic arabic enabled with functions keyboard)

what should i do now (is there any keyboard or mouse kext or something) ??

 

artur-pc : thanks for the heads up but i need to know what does this appleacpiplatform.kext do ?? should i put it even if i had a successful boot ??

 

appreciate all the possible help guys

Share this post


Link to post
Share on other sites

nevermind everyone about the mouse keyboard problem cause I used apple ps2 kexts

and I booted into the installation successfully but before the apple logo I had two lines says that there was some problems during boot and there is a pause for 5 seconds then apple logo and the system boots

when I changed to verbose mode at first it says dsdt.aml not found and too much lines afterwards of kexts . is this okay ??

anyway I installed the mac os x mountain lion on my 32gb usb flash disk guid formatted and the installation completed successfully

i rebooted my system and then I got another panic twice !!!

what should I do help me please !!

I will attach the picture of the panic

post-1058527-0-73166900-1344997727_thumb.jpg

Share this post


Link to post
Share on other sites

thanks ifire for attaching the file but I already posted about the mouse keyboard problem

however do you have an idea about that second panic I got

do I need to change something or to rick something in the chameleon wizard perhaps

please respond quickly if you can .

Share this post


Link to post
Share on other sites

thanks for replying so soon BUT :

where is the kext man !!! Is it the same as the above one ??

again thanks ifire i will confirm its working when you attach

 

i am sorry ifire but it seems you have put all the needed kexts in one zip file

I am gratful to you

i will try them now

Share this post


Link to post
Share on other sites

the needed kexts in one zip file, man this is what I post for yours problems ,

DOWNLOAD THE PS2.zip

files an

put this kexts in your Extra/Extensions of USBInstaller and boot with -f -v, this is very

difficult for you understand?????

 

 

PS2.zip

Share this post


Link to post
Share on other sites

ifire : thank you for your support i did put your files in my extra extention folder (only just them)

i was able to boot with no panics

but now i am stuck at the loading screen

the circle under the apple keeps spinning and spinning for 15 minutes and nothig happens

this is where am i right now in verbose mode

it says waiting for apple smc or something like that

help please !!

post-1058527-0-84850400-1345032015_thumb.jpg

Share this post


Link to post
Share on other sites

try this boot flag again:

-f -v -x GraphicsEnabler=No busratio=25 npci=0x2000

 

post your folder EXTRA!!!!!!!

Share this post


Link to post
Share on other sites

thank you so much ifire for your rapid resposes

the thing is i tried your flagboot but nothing happened so i searched i little more this time and found that i do need to put fakesmc.kext in e/e as well as s/l/e

i reinstalled my mac os x lion on 32gb guid partitioned usb disk and it took around 30 minutes to complete

anyway it said install completed and i shut down my computer and started a cold boot from usb (as always) an vioalla` i have reached the welcome screen with the following working on my laptop :

keyboard , mouse , cpu core i5 and ram all recognized 6gb ddr3-1333 , intel hd 3000 , ethernet worked after i inserted the rtl81xx.kext , camera worked but a little blurry (its alot better on windows so it may need patching or kext) , usb mouse also working

 

not working :

sd slot card not working (supports xc) , Sound obviosly (realtek alc269) , Nvidia gt520m , camera resolution , cannot boot without installation usb , wifi (wireless-n 130) , multi touch track pad function (basic functions are ok)

sleep , thanks for ifire for battery kext but it doesnt see the status of it (stuck at 0%) , also i dont know how to reduce screen brightness nor the function keys on my keboard except for the sound functions

note : i also tried yesterday to replace installation files to intall to MBR partition but it said installation failed (only 3 minutes left but fails and cannot boot correctly )

does any one how to

 

So Finally i reached the mac world and i hope it comes to a good stay

Thanks to ifire for the kexts

 

I need just one more thing : How can i install ML on an mbr partition ???

 

and this is my extra folder content :

Extra.zip

Share this post


Link to post
Share on other sites

I did another attempt to install osx on mbr and it worked

oh my god

the only thing I did was deleting battery kext and off I got it up and running on my external mbr usb hdd 80gb

I also tried the synaptics tracpad kext and it failed to see my mouse and I was forced to redo my hole installation from zero

I redid the usb installation and reformatted like every attempt but this time when I reached the welcome screen my trackpad didn't work and I needed to connect my usb mouse to continue installing but keyboard works

 

I don't know how to get it working again please help me if you can so to close this thread or move it to continue on fixing the not working list

 

I am so sorry ifire for not using your method only but I was eager to try mac os x on my laptop !!

and anyway thanks for everyone for helping also

I promise you a well written guide on how to install ML on my laptop model when I finish fixing

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×