Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
theoh88

Sony VAIO VGN-FZ31M

39 posts in this topic

Recommended Posts

Hello everybody,

I'm sorry for my bad english, i'm french...

So, i have a Sony VAIO VGN-FZ31M, and i want to install OSX Snow Leopard on my computer.

My configuration:

-Motherboard: CPU Type: Mobile DualCore Intel Core 2 Duo T7250, 2000 MHz

Chipset: Intel Crestline-PM PM965

System Memory: 2048 MB (DDR2-667 DDR2 SDRAM)

BIOS Type: Phoenix

-Display: NVIDIA GeForce 8400M GT

-Audio: SigmaTel STAC9872AK @ Intel 82801HBM ICH8M - High Definition Audio Controller

-Network: LAN: Intel® 4965AGN (192.168.1.68)

Ethernet: Marvell Yukon 88E8036 PCI-E

 

(I don't know if i forgot something..)

I have not succeeded to create DSDT because i can't find my bios on the net

I already tried: iDeneb v1.6 (Leopard) --> My audio works, my graphic card works, my ethernet works

iAtkos S3 v2 --> Installation completed, but my mouse and my keyboard aren't recognized

SL 10.6.1 by hazard --> installation completed, but i have a kernel panic

 

I need your help to get SL on my computer ! Thank you !

Share this post


Link to post
Share on other sites

Have you tried a retail Snow Leopard installation? I did a quick look at your hardware, and it looks like that it should work OK except for WiFi. WiFi will not work at all. Graphics should work as Snow Leopard has drivers for 7xxx, 8xxx, and 9xxx NVIDIA GeForce cards. Looks like your ethernet might work. Audio most likely will work with VoodooHDA. For now, try getting it installed. Try with http://www.insanelym...howtopic=269841 to install Snow Leopard on your PC. If you have issues, post here.

 

OK, looks like someone got ethernet working:

hi I have installed Leopard 10.5.2 and the only thing you should change to make Marvel Yukon (88e8036) work is: (Dev ID: 4351, Vendor ID: 11AB)

Just edit the file:

 

sudo nano /System/Library/Extensions/IONetworkingFamily.kext/Contents/Plugins/AppleYukon2.kext/Contents/Info.plist

 

and change just the 88e8053 section on this file

 

88e8053 change to 88e8036

AND

436211ab change to 435111ab

 

save the file copy it to

 

/System/Library/Extensions/AppleYukon2.kext

 

and that's it

 

Enjoy your new NIC on Mac Os

The same method should work fine in Snow Leopard.

Share this post


Link to post
Share on other sites

I have a problem. I have downloaded Mac OS X Snow Leopard Retail 10.6.3, his size's 6,77GB and my dvd's size is 4,7, so can i burn this image file on two dvd ?

Share this post


Link to post
Share on other sites

So I get the original DVD. The installation succeeded, but I can boot only on safe mode, because I have kernel panic

Share this post


Link to post
Share on other sites

ok, boot with -s and put this code for delete AppleTyMCEDriver.kext, this kext cause KP for you.

 

boot with -s

 

 

mount /

rm -rf /System/Library/Extensions/AppleTyMCEDriver.kext

sudo rm -rf /System/Library/Caches/*

schutdown -r now

 

 

now boot with this boot flag: -f -v GraphicsEnabler=No npci=0x2000

Share this post


Link to post
Share on other sites

It works ! Thank you very much !

Now i need your help again to :

active my touchpad

active sound because i have an error when i open voodooHDA "Can't get registry-entry path" just delete and reinstall !!

configure my graphic card in 1280x720

active my usb ports because they don't recognize my devices After the second reboot, it works

configure my keyboard in french

active "About this mac"

Share this post


Link to post
Share on other sites

for trackpad instal this two kexts in S/L/E with KextWizard app, repairPermissions and Rebuild Caches with KW app, now reboot, for graphics card put in your org.chameleon.boot.plist GraphicsEnabler=Yes, use app Chameleon Wizard for configure this.

 

 

 

 

1448-PS2-Synaptics-Keyboard-32+64.zip

Share this post


Link to post
Share on other sites

Ok i install Chameleon 2 RC5 VS and i check Graphics enabler but when i boot, i have a black screen. So i uncheck graphics enabler and i check npci-0x2000. Now, audio, ethernet, bluetooth are working. My resolution is 1280x800. Sleep mode and "About this mac.." don't work. And is it possible to get multitouch with my trackpad ?

Share this post


Link to post
Share on other sites

Make one backup of the your Disk, or clone your disk for one hard disk external with C.C.C CARBON COPY CLONER and for test install update in the clone, if this work, install in your disk.

Share this post


Link to post
Share on other sites

Ok so i used update helper, and i installed 10.6.8 combo. After installation, i rebooted but i have KP because of sleepenabler.kext so i rebooted with "pmVersion=0" and i deleted SleepEnabler.kext i hope it's the right solution..? :angel_not: I have an other little problem, when i'm using safari or google chrome, my mouse is slow but only in the browser and i don't know why :(

Share this post


Link to post
Share on other sites

It dosen't matter, it's not a very big problem ^^ Once again, thank you very much for your help :) Just a last question, do you know the intel 4965AGN wireless will get a driver for mac ? And if you know tutoriel on how to create kext ?

Share this post


Link to post
Share on other sites

I don't know how to, and i prefer keep my config. Is it possible to recover driver on ubuntu of my wireless card, and modify the code to can use it on SL ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×