Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


OSx 10.5 install on Lion-Fusion 4.1.1

3 posts in this topic

Recommended Posts

Hi all,


Love the idea of having to pass a quiz to post. :) Hopefully I don't noob my question too much.


I followed and tried the guides I have found online, and then I fell on here to install OSx on VMWare Fusion.


My main purpose is that I have an older app I want to run (Homeworld 2), but because it requires a PowerPC, only 10.5/10.6 will support it. (my legit installs)


I have the retails disc for 10.6, but the original install disc for my MBP for 10.5...and now that I am writing this, that might be my issue...but who knows. :)


Basically, I have the following:


OSx 10.7 Lion

Fusion 4.1.1


Model Name: MacBook Pro
 Model Identifier: MacBookPro5,2
 Processor Name: Intel Core 2 Duo
 Processor Speed: 2.66 GHz
 Number of Processors: 1
 Total Number of Cores: 2
 L2 Cache: 6 MB
 Memory: 8 GB
 Bus Speed: 1.07 GHz
 Boot ROM Version: MBP52.008E.B05
 SMC Version (system): 1.42f4


My install disc is the disc that came with my laptop, version 10.5.


I followed a guide here: http://blog.michael....are-fusion-4-0/


I didn't end up making it work, but it did give me a better idea as to why I can't load it natively.


From the comments, I came here and I have since tried and retried to make it work, but after having registered, I did realized that I was attempting to run the install from a 10.5 disc that is for my MBP. Could this be the reason why I can't install it under VMWare Fusion 4.1.1 ?


My only solution other than VMWare Fusion is to dual-boot into 10.5 (haven't looked at guides for this yet), but I imagine that can work. Obviously running 10.5 virtual would be better, if only to provide me with my game over the virtual session.


Anyway, when I attempted my install, I see the Apple logo boot screen, the little spinning icon, then the Apple logo turns into a Circle+X and just hangs there are the install.


The guide here seems to focus so much more on VMWare Workstation, etc. Can someone link me to a guide specifically for Fusion 4.1.1, or at least confirm if it works?


One thing I did notice, is that VMWare Fusion had 10.7 as an option, after running your patch. It still didn't seem to go.


Thanks to any and all help!

Share this post

Link to post
Share on other sites

I think the hardware-specific restore discs will boot and give you a message as such and what you're seeing is it not finding a device to boot from. The guide you posted said something about using the physical DVD drive, is that what you're using? You could try a .dmg too and see if that works better, but it seems like something is not set up right to get it to see the disc.


But that's your first problem, I think the fact that it's a restore disc will be your next problem. Your best bet is probably to use the 10.6 DVD to get rosetta rolling in Snow Leopard, with the non-server hack in that guide.


However, virtualizing emulation without GPU acceleration might result in a pretty lousy experience for you when you do get it working...

Share this post

Link to post
Share on other sites

I am doing this first and foremost for the experience and the learning. The game itself I might be able to find a copy for PC and then use something like wine to run it.


At first, I was running the DVD in drive, then I made a R/W image, touched the ServerVersion.plist file in the image, chmod 044 on the image, then mount as my bootable disc. That's where eventually the Apple logo disappears and I'm left with a circle+X and the progress circle under logo continues to spin, for hours and hours to no end.


I'm off of work for a bit, but I will find time and go get my retail disc for 10.6 and 10.5 (corporate licence) to play around with.


I just wish we were given the option out of the box as it used to be.


Thanks for any other advice.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By KyleGP
      Hi all,

      I have 5 disks including four SSDS and a 4TB HDD configured in a CoreStorage (Fusion drive) volume.

      I have Filevault enabled also.

      When I turn on my hackintosh, I am presented with the Filevault screen to select my user, enter my password and continue to decrypt and boot macOS. This works around 80% of the time with no issues at all.

      Sometimes with seemingly no identifiable pattern, after I enter my password it just hangs on the Filevault screen with the loading bar and does not progress. There is no disk activity either. After a while of the hanging, it will just display the prohibitory sign against a black background.

      I have to force shut the hackintosh off with the power button and try to boot again. Usually after I do this, it will boot the second time.

      I'm currently running Sierra 10.12.6 but this has also happened when I tried 10.13 too.

      Clover is fully up to date as of today (r4380). 

      Does anyone know why this might occur?

      The only thing I have picked up on is the drives change disk identifiers and move themselves around (eg. /dev/disk1) during different boot ups so maybe it's getting confused when trying to decrypt and boot as a corestorage volume. I have no idea how to prevent this from happening either.

      Any help or suggestion would really be appreciated.

      My specs are:

      Motherboard: GA-Z97X-UD7 TH
      RAM: 16GB Corsair 1866MHZ Memory
      GFX: 2x Nvidia GTX 760
      CPU: Intel Core i7-4790K 4GHZ
    • By sunborn
      So I just got Yosemite up and virtualized in ESXi.
      However, I am using workstation as a console like the KB says to do after 6.5.
      So the benefit of the workstation is that sound can come out if you add the adapter. This works just fine with a window$ VM. (BTW the documentation says it shouldn't work)
      In the yosemite VM it just produces a white-noise static when the sounds should be played.
      This tells me that it is a driver issue, and should be able to work in theory.
      However, does anyone have experience with VMWare workstation and the sound in OS X?
    • By grumpycat1984
      I am doing it under Sierra via VM and system refuses to do this (install to apps), also there is no ption to "buy" El Capitan from store.
      If someone give me advice how to make it run I will be very glad.
    • By iammodus
      Hello there,
      a while back I tested El Capitan on an old computer, and had a pleasant first impression. So, I decided to take a spare hard drive and install EC using Clover on my main PC.
      The installation went fine, no problem. [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] ran fine, installed all kexts OK.
      I still don't have the Wi-Fi kext (TL-WN722N), apparently someone did one but I have to build it myself. I'll get to that on another moment.
      Now, the main issue I'm having is getting both displays to work. Unfortunately, both displays turn out to have only VGA input.
      So, I have an i7-4790, with Intel HD4600 integrated graphics, plus a discrete Gigabyte GTX 650. Because the discrete card only has one VGA out, I need to enable the iGPU too in order to be able to use the second port. On Windows, this works fine. Both displays get along without issues.
      OS X is a different story though. Only the GTX 650 works. It has full hardware acceleration so that's no longer an issue.
      I'm trying to get the integrated graphics to work at the same time, so I can have both displays operative just like Windows.
      Things I've tried:
      - FakePCIID
      - IGPlatformID
      - Taking out the discrete GPU. It hangs at boot. Only works in safe mode, but of course that's no use.
      - Setting iGPU as Primary, and here's where things get really weird. The computer boots (Apple logo with loading bar) on the HD4600's monitor, but then this display freezes and the login screen appears on the 650's screen. I attached a screenshot in which I try it with verbose mode, but mind you a normal boot is no different. It really seems like the OS just wants the NVIDIA GPU as primary regardless of my Clover settings.
      So, any ideas on how to get this working?