Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
maltba

[SOLVED]GraphicsEnabler isn't working on 10.8 Radeon HD 4890

6 posts in this topic

Recommended Posts

Hey Guys,

 

need some help with my Mountain Lion Installation.

I have a very smooth running 10.7.3 with GraphicsEnabler=Yes and a custom Personality for dual Monitor Support.

 

System specs are:

 

Rampage II Extreme

Intel i7 920

Sapphire Radeon HD 4890 2GB

 

Current Custom Kexts in 10.8 are:

FakeSMC - some old version don't know if it ever got updated but it works fine in lion

IONetworkingFamily\Yukon2.kext

IOBlockStorage - some patched plist for proper detection of the ICH10R chipset

 

 

My problem is that the GraphicsEnabler simply does not inject the card into 10.8. I am not able to get to the login screen with GraphicsEnabler=Yes.

If i boot with GraphicsEnabler=No then OS X is loading some generic NV50HAL driver which only gives me 1440x900 Resolution w/o QE/CL. This behaviour is also different from Lion, where even when GraphicsEnabler=No the right driver is picked but because of the wrong standard personality the dual monitors aren't working.

Does anybody else ran into that problem and might give me a hint what i'm doing wrong?

 

If you need more information i will be happily answer your questions.

 

 

 

thanks in advance

 

maltba

Share this post


Link to post
Share on other sites

i don't think that this would work. i've tried this before on lion because this kext was always loaded when i messed up my ati4800Controller.kext, while editing the personalities. when i've tried that on lion it crashed my hole system. maybe someone with a working 4890 on 10.8 could provide me his ATI4800Controller.kext and his ATIRadeonX2000.kext that would be awesome.

 

thanks in advance. :)

Share this post


Link to post
Share on other sites

sorry my internet was messed up yesterday evening -.- i tried this though but it doesn't seem to work. Also it seems like i don't even get this ***DEVICE IN SLOT-1*** Message which i usually get on lion before the gui starts up. To me it really looks like chameleon isn't injecting the graphic card correctly. I will try to change the pcie port of the card now because i've changed the port recently to the 2nd one, because the first one had some strange problems. Furthermore i will try to set up vnc on mountain lion and try to vnc into it when its booted up fully with graphicsenabler=yes and post some ioreg stuff. Will report back soon.

Share this post


Link to post
Share on other sites

Ok guys i fixed it. Just forgot to update the Kernel Caches after I Installed the Kexts from fantomas. -.- Single Display is working now but no dual display but this is a problem with the Motmot Personality which i can fix myself. Many thanks for your help :) A Difference from 10.7 is although definitly that the 4890 isn't wokring anymore without the qe/ci patch. althought this isn't a problem if you know it^^

 

For everyone reading this thread:

GraphicsEnabler=Yes

fantomas 48xx qe/ci Enabler kexts

!!use cvads kext utility to install the kexts!!

 

and then everything will run smoothly.

 

see you

maltba

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×