Jump to content
InsanelyMac Forum
Sign in to follow this  
Alex Auditore

Hibernation for Mountain Lion 10.8

Recommended Posts

Can anyone make latest chameleon with hibernation support (suspend to disk) with patch from Vladimir Zidar? like this:

http://www.osx86.net/view/2254-chame..._for_lion.html

Or give me at least the source code Chameleon 2.1 1793(for lion) and 20xx(for mountain lion). Although I am not programmer and never done it. But I'll try invent something.

 

Bootloader Chameleon 2.1 1793 do not load the system. (immediately goes to restart )

 

Or maybe the bootloader Clover will help to solve this problem?

 

I use hibernatemode 29.

Share this post


Link to post
Share on other sites
Advertisement

how did you get it to work on lion? i tried vlad's boot loader, it sleeps, but upon waking from it gives me an infinite loop of restart. is there a way to get it to wake from hibernation? i'm always annoyed when putting the command "Wake=No" to stop the loop

Share this post


Link to post
Share on other sites

LifeOnRice, in the Lion version 10.7.4 won't work. I have works it fine in the version 10.7.3 with sudo pmset hibernatemode 29

 

and with Chamelion 2.1 1793.

 

- In the file / Extra / org.chameleon.Boot.plist you must have the lines:

<key> Wake </ key>

<string> Yes </ string>

<key> ForceWake </ key>

<string> No </ string>

Share this post


Link to post
Share on other sites

if someone friendly enables hibernation on the latest build of chameleon, then imma test along with your guide. atm can you get regular sleep working? mines won't wake because of my locked bios, but if someone found a solution without tinkering the bios then my computer is 100% functioning

Share this post


Link to post
Share on other sites

LifeOnRice What's problem you have? Is loked bios? -> Then you should remove the bios-baterry, after you must wait 5-10 minutes, and then you should put in your bios-baterry back.

What do these words mean, such as "imma" and "atm"?

Share this post


Link to post
Share on other sites

Can anyone make latest chameleon with hibernation support (suspend to disk) with patch from Vladimir Zidar? like this:

http://www.osx86.net/view/2254-chame..._for_lion.html

Or give me at least the source code Chameleon 2.1 1793(for lion) and 20xx(for mountain lion). Although I am not programmer and never done it. But I'll try invent something.

 

Bootloader Chameleon 2.1 1793 do not load the system. (immediately goes to restart )

 

Or maybe the bootloader Clover will help to solve this problem?

 

I use hibernatemode 29.

 

 

I will patching the chameleon boot file with hibernation patch, if chameleon works with 10.8 i upload the patched boot file.

As LifeOnRice said hibernation stop working in 10.7.4...well i will try it to 10.8 now! Wish me good luck! :)

Share this post


Link to post
Share on other sites

I trick the boot file with "Vladimir" patch but headers isnt same with 10.7. The resume proccess starts with a crapped image and when restore complete machine reboots!

i uploaded the bott file for any want to check!

Also i remove the headers check and secure check from boot file. Thats all can i do, we need chameleon dev team to work on this!

Please report it to chameleon issues! Thanks.

boot.zip

Share this post


Link to post
Share on other sites

Hello. Let's talk about it again!

I am using the Chamelion now. Because I don't see what is clover better than Chamelion for me.

First of all, if we want that hibernation will be to be done. We must, must fine a part of these sources that is responsible for this.

http://www.osx86.net/view/2254-chameleon_2.1r1793_-_fixed_hibernation_for_lion.html

Our hammer is Xcode for it.

I'm not a programmer but I did a sweat thing http://www.osx86.net/view/3558-applesmartbatterymanagermini_for_ml.html with Xcode.

Maybe in this case we should find a part that is responsible for it. And past it into new Chameleon for Mountain Lion.

Here we go!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • It seems nice that chris1111 provided a patch, but I can't -- in good conscience -- download a random binary file from github and run it on my system.    What is so proprietary about his patch that he can't include source? I think I'll wait until the updated driver comes out before I update...  Does anyone know where to look for updates to the webdriver from Nvidia? I've ever found a page that lists them, just links to the actual files to download, and that root is not 'browsable'. I'd like to monitor that site to see when a version is updated for the 17E202 build. Once that is released, I can update OSX and should be fine.  
    • hey MaLd0n  It's been a while since I used clover, so a lot of things went rusty. Can you please look at my setup and guide/help what should be done next?  https://fex.net/354949878474?fileId=441517695   Current setup:  GA-Z97X-UD3H Xeon e3 1245v3  Msi GTX 1050ti Gaming X
    • Hi @fabiosun and thank's for your patience with an old and stubborn man.   I am 100 % sure that my MSR 0xE2 register is unlocked thank's to you.   My system is 100% stable and I haven't had one kp with this configuration in the last two weeks.    I'm now running without TSCAdjustReseat.kext and I can't se any issues in performance with or without that kext. What I however can se is that the amount of total energy consumed during the test-cycle are 10 times higher without the kext (three times Cinebench CPU and two times Luxmark open CL) as you can see in the output from my AppleIntelInfo.kext attached in my earlier post.   I have tested running Cinebench five times in a row with or without TSC kext and have exactly the same performance (see attached files). Temperature is not a problem at all.   Everything seems to be fine so I guess I have to wait and see if upcoming 10.13.5 maybe recognise Intel Xeon w series processor as native.     
    • Tried with HPET enabled and disabled so I don't think it's that. I'd tried with bus ratio before to no effect but wouldn't hurt to try again. The clock runs at the correct speed.
    • could be an HPET / TSC Sync issue. does your system clock slow down or run faster then it should. also check cpu and buss ratios.


×