Jump to content
theconnactic

Mavericks kernel testing on AMD (formerly Mountain Lion kernel testing on AMD)

6,477 posts in this topic

Recommended Posts

Advertisement

here the pictures

 

it does not look bad :wink2: :king:

 

 

to mention is that I have not installed the tool by Andy! Andy what do you think? Can the tool obtain an improvement? I wait for your response before I start the tool. :help:

http://www.insanelymac.com/forum/topic/286043-autoamdtool-10-automatic-system-decrypter-cpuid-patchert/

Share this post


Link to post
Share on other sites

hello :)

 

 

you forgot nawcom which contributed greatly with his passing legacy_kernel which served to create a "##### legacy" of a certain tonymac for sandybridge CPU!

 

 

yup! you're right ;)

But you're missing my point :)

 

 

I know there were a lot of developers who also build their own legacy kernel projects

and we all have to give credits to them for all their efforts :thumbsup_anim:

 

But in this case,

I only wrote the date when AMD users started to run a specific version of osx in either i386 or x86_64 natively for the first time

especially for all users of any older version of AMD

 

 

btw, sandybridge isn't the architecture for AMD, is it?

 

 

T*nym*c , seriously ?

 

Do you know that the evil stole nawcom's code and claimed it as his own ?

 

 

http://prasys.info/2...ymac-seriously/

 

 

 

For cpuid, because we know all the kernel functional work very well on AMD CPUs Intel without the bug we know about graphics cards.

 

all research seems vainse but keep hope or adapt its hardware with a good graphics card ATI indeed compatible.

 

We were still the solution, not negligible, Lion 10.7 with kernel Bronya (Dimitrik Bronzovka) (i386) capable of K10 and K15 with 64 bit support.

 

the day Apple utlisera CPUs AMD we have more subjects to feed! the cpuid problem will be solved.

 

 

The Year Is Not Over Yet !!! :D

Share this post


Link to post
Share on other sites

Just updated to 10.8.3

I must say it runs wel.

NVDAStartup works for my 8300 GS.

How about other (but then AMD) NVidia users?

Share this post


Link to post
Share on other sites

amazing is it that our annoying kernel panics since I modified the driver no longer occurs. :thumbsup_anim:

 

Just updated to 10.8.3

I must say it runs wel.

NVDAStartup works for my 8300 GS.

How about other (but then AMD) NVidia users?

Hi Andy, all Graphics Driver are from Mountain Lion 10,8,3

 

andy, I'll install ML update10,8,3, what do I need?

 

Beta Version or ComboUpdate ? OS X Mountain Lion Update v10.8.3 (Combo)

Share this post


Link to post
Share on other sites

amazing is it that our annoying kernel panics since I modified the driver no longer occurs. :thumbsup_anim:

 

Hi Andy, all Graphics Driver are from Mountain Lion 10,8,3

 

andy, I'll install ML update10,8,3, what do I need?

 

Beta Version or ComboUpdate ? OS X Mountain Lion Update v10.8.3 (Combo)

I used latest combo.

The kernels are compatible but we'll make a 10.8.3 kernel soon

Share this post


Link to post
Share on other sites

I just updated to 10.8.3

 

All is OK unless QE/QI :(

 

UMGqZjS.png

 

Maybe have a kernel problem?

PS: I have a 5850 series

Share this post


Link to post
Share on other sites

Yes, is a kernel issue: some cards simply don't work. Now i know the HD5850 won't get along with our current kernel.

 

mmm maybe trying this... but I dont have any idea what I'm saying.

Share this post


Link to post
Share on other sites

If it has sse3 (two "s"s), i'll say yes, it can. If sse2-only, i'm not sure if the opcode emulator also emulates sse3 (two "s"s) instructions, as it does with ssse3.

 

I recommend trying it: if it doesn't work, throw good old WinXP at it :P

 

All the best!

Share this post


Link to post
Share on other sites

If it has sse3 (two "s"s), i'll say yes, it can. If sse2-only, i'm not sure if the opcode emulator also emulates sse3 (two "s"s) instructions, as it does with ssse3.

 

I recommend trying it: if it doesn't work, throw good old WinXP at it :P

 

All the best!

I added sse3 emulator in the last amd_kernel.

Untested but should work

Share this post


Link to post
Share on other sites

Does anyone know if Gigabyte GA-H61M-S1 works on Mountain Lion 10.8.2?

Wrong window maybe? This is an AMD help forum.

 

EDIT: Ninja'd. o:

Share this post


Link to post
Share on other sites

If it has sse3 (two "s"s), i'll say yes, it can. If sse2-only, i'm not sure if the opcode emulator also emulates sse3 (two "s"s) instructions, as it does with ssse3.

 

I recommend trying it: if it doesn't work, throw good old WinXP at it :P

 

All the best!

 

im here with this old laptop while my notebook is on repair... so im running win 8 and opensuse 12.3, both 64 bits. thanks! i can check that in programs like everest or cpuz, right?

 

I added sse3 emulator in the last amd_kernel.

Untested but should work

 

the latest is in the first page? in order to boot i should just create a regular usb installer and put this kernel and chose it in the instalation? add some unusual flag?

 

thanks for the great work!

Share this post


Link to post
Share on other sites

Hi guys, I'm back in the game :D

and how... splitted my 500GB HDD into a win7 and OSX section.

Using a USB powered external HDD (Slooooow) for my data...

 

But right now, i can't boot clover... Fat32 all fine but nope.

I think i read something about fixing fsb made chameleon work for fx?

So no reboot with andy's kernel? or am i wrong?

 

If it works, please tell me how :P

 

http://www.insanelymac.com/forum/topic/287226-make-a-usb-bootloader-for-fx-cpus/

 

Bitcore

Share this post


Link to post
Share on other sites

im here with this old laptop while my notebook is on repair... so im running win 8 and opensuse 12.3, both 64 bits. thanks! i can check that in programs like everest or cpuz, right?

 

 

 

the latest is in the first page? in order to boot i should just create a regular usb installer and put this kernel and chose it in the instalation? add some unusual flag?

 

thanks for the great work!

You need the one with the rc4 diff also attached.

There the amd_kernel is what you need.

Release Client (RC) 4 has SSE3 emulation alongside SSSE3 emulation.

Hope this helps ;)

Share this post


Link to post
Share on other sites

Is there a significant performance loss, because of the emulation of SSSE3? Can't wait to have a fully functional Hackintosh with hardware I thought to be forever incompatible. (Phenom 955BE & GTX 580)

Share this post


Link to post
Share on other sites

white screen on my phenom II x2 565 & HD 6670 (latest kernel from 1st page) (trying boot parameters : -x ; -v; GraphicsEnabler; AtiConfig; all combinations ) - ML 10.8.2

Share this post


Link to post
Share on other sites

Is there a significant performance loss, because of the emulation of SSSE3? Can't wait to have a fully functional Hackintosh with hardware I thought to be forever incompatible. (Phenom 955BE & GTX 580)

 

There's no performance loss. In fact, my Geekbench scores consistently beat what i get on Windows 7. The nVidia card still won't work properly and you'll have to disable the GL kext, meaning no QE/CI. Most ATI cards will work, specially 4xxx and 5xxx EDIT: of the 5xxx series, only the 5450 is confirmed to work (thanks, Kiko) but then again, as you see by the post right above mine, that's not guaranteed.

 

All the best.

Share this post


Link to post
Share on other sites

There's no performance loss. In fact, my Geekbench scores consistently beat what i get on Windows 7. The nVidia card still won't work properly and you'll have to disable the GL kext, meaning no QE/CI. Most ATI cards will work, specially 4xxx and 5xxx but then again, as you see by the post right above mine, that's not guaranteed.

 

All the best.

 

Negative. 5450 work nice, but 5770, 5850, 5870 dont work with QE/QI

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Shaneee
      Here we have the AMD Vanilla guide. Compatible from Windows. 
       
      Click here for the guide.
       
      For installation help make a post here. And for post installation help make a post here.
       
      Thanks,
      Shaneee

    • By CMMChris
      I did it again! With the release of the Navi drivers for macOS by Apple I bought a card and ported my popular PowerPlay Table generators to the RX 5700 and RX 5700 XT. Some might know I already did the same for V56/64 and Radeon VII. This tool allows you to change GPU, SoC and Memory Clocks, voltages for GPU and SoC (for undervolting or overvolting), adjust Power and TDC limits and customizing fan control. The whole thing is based in a simple Excel spreadsheet and provides you with a long Hex string you can then inject to your graphics card via Clover device properties. If you want to use it on a real Mac (eGPU or Mac Pro) you can use a Dummy Kext to inject the PowerPlay Table. Please make sure that you only run this spreadsheet in Excel! iWork, OpenOffice and Libre Office are known to do wrong calculations.

       
      Release: AMD Radeon RX 5700 (XT) PowerPlay Table Generator V1.0
      (October 27 2019)
      Changelog 1.0:
      Initial Release  
      RX 5700 Download: Radeon_RX_5700_PowerPlayTable_Generator.xlsx.zip
      RX 5700 XT Download: Radeon_RX_5700_XT_PowerPlayTable_Generator.xlsx.zip
       
      WARNING: Use this this tool at your own risk! I am not responsible for your mistakes. Wrong / too high values can potentially damage or destroy your card.
       
    • By Arman Hossain
      HI 
      I want install High Sierra  on my pc . my CPU is : AMD Ryzen 3 2200g and my MotherBoard is : ASUS EX A320m. and 8gb ram DDR4 ram . i dont have any external gripch card. i have seen some video on youtube how to install High Sierra but they use extranal gripch card to make it good  but i don't have any extranal gripch card . on my windows sysem the shared gpu is 2GB which is using my ram to crate the vega gripch  . i want know is it possible to install High Sierra on my pc with out any extarnal gripsh card  ?


    • By MatthewBayard
      Current Build ( just purchased the RX 580 )
       
      CPU Intel Core i7-3770K 3.5GHz Quad-Core Processor       CPU Cooler Corsair H100i 77.0 CFM Liquid CPU Cooler     Motherboard Gigabyte GA-Z87X-UD7 TH       Memory 4x 8gb     (Corsair CML16GX3M2A1600C10 Vengeance Low Profile   16GB (2x8GB) DDR3 1600 Mhz CL10 XMP Performance Desktop Memory Kit Black)       Case Fractal Design   Define R4 (Black Pearl)       Power Supply Corsair HX750       HDD SATA 6Gb / s 256GB SSD         Wifi TP-LINK TL-WDN4800 N900 Wireless PCI Express Adapter       Graphics Card MSI RADEON RX 580 ARMOR MK2 8G OC Graphic Card      
       
      The installation has failed a dozen times after creating a bootable USB via the instructions outlined at serval different places:
      https://www.tonymacx86.com/threads/[url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]-install-macos-mojave-on-any-supported-intel-based-pc.259381/   
      https://hackintosher.com/forums/thread/mojave-flummoxed-with-ga-z97x-ud7.1338/
      https://hackintosher.com/guides/guide-to-fresh-installing-macos-mojave-on-a-hackintosh-10-14/
       
       
      I have used UniBest to create my builds in the past and they have mostly been successful. I tried the other methods as a last resort. I have not gotten past the Apple boot screen with any method attempting to install Mojave. 
       
       

       
       
       
      I have followed all the guides I can in order to get a successful install. However, it has been hard to get a definitive guide to solve my issues.
       
       
      Could somebody please help me with the correct [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] settings. Ie UEFI Boot Mode or Legacy Boot Mode? 
      Recommended BIOS Settings for my system. 
       
       
      It might also just be the required Clover boot screen setup / flags 
       
       
       
      I also have no clue which [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] configurations are required for me to build.
       
       
       
      Any help at all will be most appreciated.
       
       
      I can post any more information regarding errors and crashes if required.       
       
       
       
       
       
    • By shinho73
      Can someone help me fix reboot issue? Actually it reboots, but sometimes the hackintosh just hangs with screen off. Here is the Extra folder containing org.chameleon.boot.plist. https://drive.google.com/drive/folders/1MX8-DpQk9kaRUfjPcToxf-ElWh-bN6EY?usp=sharing  and the spec of the PC. https://drive.google.com/drive/folders/1NlcUNK5DBzJFxeFeuyt92eRjQqwO5T32?usp=sharing Can someone look at it? I might be doing something wrong. Any help will be greatly appreciated. Thank you. 

×