Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Glaedr

Patching the app-like Installer

3 posts in this topic

Recommended Posts

There are tons of guides on the Internet that explain how to patch BaseSystem.dmg, restore it to an external drive and boot from it. But since I don't own such a drive (and my BIOS is fighting with Chameleon so I can't boot from an external hard drive partition) I'm trying to patch the Mac OS X Install ESD.dmg file so that I can upgrade to Mountain Lion from the Lion system on which I'm writing this post. My HD is MBR partitioned, so I unpackaged everything, placed the kexts, replaced OSInstall.mpkg in the Packages folder (without moving it into BaseSystem.dmg) and OSInstall in the Install.framework (that actually is in BaseSystem.dmg), and repacked it all. Still the installer is complaining about non-GPT partition table; I googled around, and it seems BaseSystem.dmg shouldn't be involved in the installation when you're not booting from it (and I'm not), but yet there must be an OSInstall somewhere in the ESD dmg the Installer refers to.

Where is it? Or, if you know some other way, how do I patch the app-like installer properly?

Thanks in advance.

Share this post


Link to post
Share on other sites

If you have a spare partition you could install it directly there from within Lion by using the OSInstall.mpkg from Packages.

 

Or on the same partition via Pacifist from charlessoft. But this may crash towards the end... GUID is required for a good reason.

Share this post


Link to post
Share on other sites

I'd actually rather packing a working installer. Ok, if I would do this by USB external drive, is there any reason why other computers when booting from it load Chameleon properly, mine only keeps printing on black screen this:

boot0: test
boot0: done
boot0: test
boot0: done
boot0: test
boot0: done
...

Mobo is an MSI MS-7613.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • For F6 Bios, which DSDT is the one i should use? I´m a little confused in the Mass of DSDT here ;-).   Great Thread by the Way.   Another Question: I have 2 960Pro inside my Rig (one with OS X, one with Windows 10). When i try to mount my EFI on OS X NVMe the system freezes... :-(   DWhen i unplug the Windows NVMe everything is fine an it mounts the EFI.   Anybody an idea?   Tried the upper Port on the Board (OS X) & the middle / lower Port, in the Middle it mounts the EFI in the lower it freezes.   But i need the middle Port for an SATA M.2 SSD :-D... Even when i plug the Windows NVMe into an PCIe Adapter Card it freezes at the point i mount the EFI.   I´m mounting with Clover Configurator.     Thank You guys.
    •   Just add "ngfxsubmit=0" to config.plist to disable the fix within nvidiafixup
    • @MegaCookie   ok, I have no solution for that Trial 7 good for the release?
      Is this codec good enough for you?
    • @onejay09  - thanks again for your help and advice.  I tried various combinations of Info.plist mods (Adding a new Machine entry with my Board ID and GFX0, adding GFX0 to the MacBookPro6,1 Machine entry and adding a Vendor/Device entry to the Board ID and MacBookPro6,1 Machine entries. I thought these might make a difference, but after comparing GPU temps and frequencies to those reported in Windows 7, I'm not seeing any difference.  It appears as though AGPM is natively detecting and handling power management of the NVidia Quadro NVS 140m without any Info.plist mods.   Thanks again.
    • My rig is not booting without the "XCPM bootstrap patch" and "xcpm_program_msrs (c) Pike R. Alpha" patch. Already tested that.  Booting without the TSCAdjustReset.kex is working great and booth sleep and wake is working. The new bios 0603 has an updated microcode. That might be the reason  for the fact that everything is working as it should without the kext.


×