Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
besweeet

Intel HD 3000 (0112) failing (10.8 GM)

4 posts in this topic

Recommended Posts

After over 3 hours of tweaking, I still can't get the HD 3000 (0112,8086) to get native resolution and QE/CI. I've tried a number of SMBIOS combinations and other things.

 

The motherboard is an MSI B75MA-E33 with an Intel Core i3-2105 CPU.

 

I'm using the latest version of Chimera 1.10. GraphicsEnabler=yes paired with the MacBookPro8,1 SMBIOS at least gets ML to recognize that I'm using an HD 3000, however System Profiler changes the device ID from 0112 to 0126.

 

I tried SO many different things, including different SMBIOS files (via ######), older kext files (either prevented the system from booting up or provides full resolution with artifacts and very slow overall performance).

 

Maybe a DSDT edit will fix this? I've never relied on a DSDT for any hackintosh that I've worked on.

Share this post


Link to post
Share on other sites
Advertisement

Try this:

http://legacy.tonyma...hp?f=15&t=28851

 

And you might also need to add your device id to the kext's plist.

 

Not sure if it'll work for desktops though!

 

Will try DSDT edits as an absolute last resort.

 

We changes some BIOS settings. Integrated Graphics Shared Memory was set to 64MB, but it's now set to 128MB. DVMT was set to 256MB, and still is. This, I think, got it to boot up at full resolution (with QE/CI). However, there are some green flashes occurring. Also, we're using HDMI.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • right about logs.... but in my case unpatched apfs are boot slower
    • Test the configplist, copy the folder Other in place of yours, I have filtered the kext you need to your PC ... You should extract ACPI tables from the clover GUI with F4 and post it .... Before doing so, delete all the files you have in Clover Origin ...... We try to make this PC work like a real Macbookpro...... Post Photo DCPI manager Test.zip
    • I have this kinda issue with my monitor, it started a few months ago. Every now and then it will cut out completely, Audio still plays but my monitor like resets. Does it in Windows, macOS and linux. Benq gl2450ht I think my monitor is.

      Sent from my SM-G930F using Tapatalk

    • Hi Urashimataro, No no with something else than a Mac! ;-) I created my USB SSD on my REAL MBPro 15". Then installed the latest CLOVER Then copy paste your EFI partition but with my own serial...   So no more confusion! Have a nice day  
    • Hi,   I still have (and always had) a weird problem with the nvidia card, and I don't know if it is a power unit issue or a driver issue. Do you have such a problem, too:   Sometimes the screen goes black, for example if I scroll a specific webpage. It turns then on again, and off again. Then it may disappear and everyathing works fine again. Or not. Usually a reboot will let this problem disappear. There is no obvious heavy cpu/power usage while this happens.   Do you know this problem? Does it sound like a driver problem?   I use a gt1050 2gb and a 4k monitor connected thru DP.


×