Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
rockinron_1

[Guide] The all-in-one guide to Vanilla OS X (including Chameleon + DSDT) for beginners (updated for Yosemite!)

906 posts in this topic

Recommended Posts

Hello,

 

I would To greatly thank the autour or this guide.

I'm really newbie in this kind or stuff and i managed To setting up this system :

- ga-z97x-ud5h (bios f7)

- i7 4790 K

- 32 gb cucial tactical sport

- evga 980ti

- 850 pro Samsung 250 go

- black magic mini mini for

 

I would want To report an issue i encountered. I was not able To install chameleon on the fresh install of os x yosemite. Perhaps something I made wrong. So i used the install chameleon .dmg found here :

[NEW]_USB Installer_OS X Yosemite Chameleon_r2679 v10.

 

Conséquence is step 3 was not effective. Not a problem for nullcpumanagement with my configuration and smc was easily edited with chameleon.

I also didn't manage To use dsdt editor.

Meanwhile, the system seems To work very well. The only issue i got, exception of imessage i don't use, is the sound. I managed to see the hardware in system pref but no sound out every jack. This is not a big trouble for me as I'm using USB speakers.

 

So, many thanks you for this guide.

 

Ps : sorry for my approximative english

Share this post


Link to post
Share on other sites

Dear Readers,

First of all many, many thanks for the great tutorial and the work done.

In the past I installed os x 10.5 (kalyway) on some older PC.

Now I wanted to Install a recent Version of os x (yosemite) on some newer hardware.

I followed the tutorial till I got stuck at Part 3.

Trying to boot from the USB Stick I got the error "can't find /mach_kernel".

At Part 2.1.7 I copied the kernel from the Essentials.pkg to /System/Library/Kernels/ of the USB Stick.

The tutorial then notes something about the attachment. The attachment resambles the downloads from Step 1.1 (Essential Software).

The only thing different from the tutorial is the version of the chameleon boot loader I used. The tutorial links to version 2.3 svn r2716 (wich didn't work for me; error at the end of the Installation. I used version 2.2 r2404 from the website http://chameleon.osx86.huinstead.

Where does the bootloader get the kernel (mach_kernel)? Is it the kernel from /System/Libraries/kernels? Do I have to specify this at chameleon wizard?

Greetings

Wolfgang

Share this post


Link to post
Share on other sites

I ran into a problem, maybe I just did something wrong. Anyway, I'm stuck here:

 

1. Mount your OS X DMG. If using a copy downloaded from the app store: Navigate to Applications (which is where it will save your downloaded copy of OS X by default) -> right click "Install OS X *version*" and click "Show Package Contents" -> Contents -> SharedSupport -> Double click "InstallESD.dmg"
2. Mount BaseSystem.dmg by typing the following in terminal:
open /Volumes/Mac\ OS\ X\ Install\ ESD/BaseSystem.dmg
open /Volumes/OS\ X\ Install\ ESD/BaseSystem.dmg

open /Volumes/OS\ X\ Install\ ESD/BaseSystem.dmg

 

I have to mention that I am running Yosemite on VMWare on Windows 7. I used an USB stick to copy from PC to my VM the .dmg which I downloaded from http://www.hackintosh.zone/downloads/download/810-nireshs-yosemite-with-amd-intel-iso-usb/ .

 

http://imgur.com/9NNjgSy

Share this post


Link to post
Share on other sites

hi guys,

 

i followed the instructions on how to make a mavericks usb installer on a hackintosh snow leopard.  but when i boot from the usb, i get an error

 

bootcachecontrol unable to open /var/db/bootcache.playlist

 

 have tried multiple common flags, no luck.

 

btw, the mavericks installer.app i have, it was a copy i had when i was still running a mavericks hackintosh.  but when i had to change systems, i did not install another hackintosh, but backed up my installers.  i put this mavericks.app in snow leopard and tried to run "onebeast" from you know who (trying a shortcut since the end game is to download el capitan), onebeast said that the installer is not complete or corrupted.  i also could not download el capitan from snow leopard since i could not fix not being able to log in to MAS.  i dont know if onebeast saying my mavericks.app is incomplete has anything to do with this.  but i was able to copy the files, followed the instructions here.

 

thanks

Share this post


Link to post
Share on other sites

Old thread, I know, but I'm using the guide to finally upgrade my old Mountain Lion to Yosemite.

 

Pacifist won't extract the kernel for me. I can open Essentials.pkg in Pacifist and start to extract, but it stops after less than a minute with the error box "Error - The file (long file name) does not exist". Is there another app that will extract the kernel from the Essentials package?

 

 

NEVERMIND!! - I found the problem - I was using an older version of Pacifist. Updated to the version 3.5.13 and all worked perfectly.

Thanks for your help.   :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×