Jump to content
Spreadwide

I have a problem with my wireless :/ hope you can help me :)

30 posts in this topic

Recommended Posts

Ok so i begin with my specs :

 

Motherboard : Asus P5QL/EPU

Processor : Intel pentium dual core e6600 3,06 GHz

Ram : 4 GB DDR2 (i know it suck like the processor)

Video card : Geforce GT 220 by nvidia

HDrive : Western Digital 500 GB

 

Ok so i think now you need informations of my installation :

 

Snow leopard 10.6.1/10.6.2 by hazard

Chameleon RC3 EFI 10.5

 

Now what works :

 

Sound (rear mic, rear headphones, front mic, front headphone) (VoodooHDA kext modified by me for enable my rear mic)

Nvidia GT220 work (nvenabler)

Ethernet work by defaut on this board

 

Now what doesn't work :

 

Wireless DWA-510 Pci card (chipset RT61) : so about this card i read a lot of post on insanelymac and other forums but still no device on airport i know ralink created drivers for this card but the drivers doesn't work in snow leopard and leopard too, i saw that these drivers are for usb wifi card only, i tried the atheros fix for this card but nothing :/ so now i try here to get more informations about this card so i hope that i can get my card works under snow leopard 10.6.2 :)

Maybe i can try to modify the dsdt i know nothing about dsdt modification.

 

I have another problem but it s not really important, when i go to "about this mac" -> "more infos" -> "hardware" i see only one core detected but i have a dual core and when i launch the activity monitor tools i see my two cores work together with no problem so i want to know if it s a big problem or not and if i can modify this.

 

P.S : Really i m sorry for my bad english, i m french and if you want more information just reply :)

 

Thx all .

Share this post


Link to post
Share on other sites
Advertisement

Or, if that doesn't work, and because I don't want to spend all morning looking for a kext for an older card, my advice would be to go here System Info, an app to get hardware and kexts info download and run that app so you can get vendor and dev ID, then go to http://olarila.com/kexts/ and use the ID's to search if a compatible kext is available

Share this post


Link to post
Share on other sites

Ok thank you for all it s awesome :) i will try your solutions, hum for the ralink website i saw that the drivers are only for ppc only? I tried the last driver i will try the second:)

 

Thx eep357 i will try to do that :)

 

I will reply later.

Share this post


Link to post
Share on other sites

Ok i done the search :

Ven ID : 1814

Dev ID : 0302

 

and that's what i got :

 

mini_887047Screenshot20120716at64656PM.png

 

So now what should i do ? You said search the kext but i tried and i got no result (yeah i know you going to say wtf what is this man, he can't do a search by himself ?)

I going to try again but see if what i did is right.

 

Ok so i finally found --' i was blind maybe ^^

 

mini_381785Screenshot20120716at65602PM.png

 

So i going to try these kext and i'll give you more infos later ;)

 

Ok it doesn't work these drivers are the same that the drivers of the ralink website. i have no problem during the installation but still no device i tried to modifie the info.plist but nothing. Should i boot at 32 bits mode... i don't know.

Strange ralink make these drivers and they don't work --' i used the last driver wich is on the website and i opened the info.plist and found my ID in the IOMatch... so it should work i don't know really i m tired ...

Share this post


Link to post
Share on other sites

searching just the vendor ID will give results that include every ralink wifi device, or which there are many. I'll take a look for ya tho, since at least you tried :) Wup, just saw your first pic, not looking good. Can you post the system info app screencap?

 

Nope, you're SOL. Time to upgrade to wireless N. You should be able to find a compatible one for $5-$10 or you can go native with PCIe to mini PCIe adapter and one of the apple airport cards (or same version without apple branding) for around $30 give or take a few depending on where and what you get.

Share this post


Link to post
Share on other sites

OKOK so you want a screen of the system info app voila :

 

mini_211668Screenshot20120716at73036PM.png

 

euh yeah i will work a bit more on this problem and if i can't do anything i going to buy another pci card :) and for my cpu info do you have an idea my master ^^ now i only hope that league of legends run on this "hackintosh"...

Share this post


Link to post
Share on other sites

Re. I have more information i found the other pci cards wich use the same driver in windows and i got this :

 

 

G630.DeviceDesc = "D-Link AirPlus G DWL-G630 Wireless Cardbus Adapter(rev.E)"

G510.DeviceDesc = "D-Link AirPlus G DWL-G510 Wireless PCI Adapter(rev.C)"

G630B.DeviceDesc = "D-Link AirPlus G DWL-G630 Wireless Cardbus Adapter(rev.E)"

G510B.DeviceDesc = "D-Link AirPlus G DWL-G510 Wireless PCI Adapter(rev.C)"

G650A.DeviceDesc = "D-Link AirPlus G DWL-G650+A Wireless Cardbus Adapter(rev.E)"

G520A.DeviceDesc = "D-Link AirPlus G DWL-G520+A Wireless PCI Adapter(rev.C)"

G630M.DeviceDesc = "D-Link AirPlus G DWL-G630M Wireless Cardbus Adapter(rev.A)"

G510M.DeviceDesc = "D-Link AirPlus G DWL-G510M Wireless PCI Adapter(rev.A)"

DWA610.DeviceDesc = "D-Link Wireless G DWA-610 Notebook Adapter"

DWA510.DeviceDesc = "D-Link Wireless G DWA-510 Desktop Adapter"

 

So i going to search if i found kext with these infos

Share this post


Link to post
Share on other sites

for the ralink website i saw that the drivers are only for ppc only?

That say's a lot right there :) What's the deal with your CPU now?

Share this post


Link to post
Share on other sites

Ok so i going to buy a new card --' sad no money xD, euh for cpu at the first boot i have only one core detected then i used dsdtgui and dsdtse for modify the dsdt file (delete alias) then i got both cores detected see this :

 

mini_504680Screenshot20120716at82120PM.png

 

and when i go to -> about this mac -> more infos -> Hardware i see only one core detected :

 

mini_909515Screenshot20120716at82346PM.png

 

(if you want a translation just say me)

 

So i want to know if i can change these informations because they are wrong and i want to know if it s a serious problem or not that's all :)

Share this post


Link to post
Share on other sites

Hum i gonna make an tutorial for the asus p5ql epu cuz i just one tutorial on it and he don't describe correctly the installation i gonna upload my informations on osx86 database too. I think it's could help someone i just need now to resolve this problem of cores and it s done

Share this post


Link to post
Share on other sites

BTW, the TPLink TL-WN851N is a great Atheros-based card that supports 300Mbps N speeds. :) It's what I use, works great with OS X (both Snow and Lion).

 

As for Ralink drivers, there are some Intel versions, but they are few and far between. I think in particular the RT61 are PPC only, but there is one kext you can try: http://www.mediafire.com/?67b2hzho689upsf I haven't tried it, but it's "supposedly" Intel. One thing I do know is that all Ralink and Realtek drivers are 32-bit only, no Ralink/Realtek driver is 64-bit.

 

Go ahead, submit it to the Genius Bar. :)

Share this post


Link to post
Share on other sites

I tried the 10.5 rt61 kext from the ralink website and i thought that i should boot with arch=i386 for 32 bit mode but i got a kernel panic so.. I will try your link :) still hope but less :D

Share this post


Link to post
Share on other sites

What's your bdmesg output look like? Just type that in terminal.

Share this post


Link to post
Share on other sites

*Pookymacman i tried your kext under 32bit mode and nothing maybe it could work under 10.5.x version but np

*eep357 sorry i can't give you thhis information right now i m on ubuntu installed on a usb key, i can return on sl but it takes lot of time to boot on ubuntu.

I can give you this information tomorrow sorry :/ you need wait a bit but linux and mac terminal are the same i can try this command under linux i will reply.

 

command don't exist under linux so i'll give you what you need tomorrow :)

Share this post


Link to post
Share on other sites

It's "usually" installed as part of Chameleon, so gonna need to be in osx. No rush :)

Share this post


Link to post
Share on other sites

sorry i needed to sleep a bit. Finally i got my 2 cores detected in the system profiler and in the monitor activity. It was simple in my BIOS i have an option "Max CPUID Value" -> this option was enabled and i saw in other post that she can cause some problem with the cpu detection under osx so i just dislabed this option and i got my 2 cores detected.

 

And bdmesg command not found. I typed bdmesg in the terminal and nothing i tryed other command like sudo bdmesg, bdmesg output, sudo bdmesg output and nothing.

I have a question i have a dsdt file, should i put it in the extra folder or at the root of my hard drive ?

And another question can i modify my dsdt for my wireless (last idea)

thx  :)

Share this post


Link to post
Share on other sites

Hmm:

Don't worry about it cause CPU issue fixed anyway

/Extra

Nope

Share this post


Link to post
Share on other sites

DSDT cannot drive hardware. There are times when you can "spoof" a different hardware device ID (which is what the driver detects to be enabled), and make your device look like another device (that is, of course, very similar). I did that once with an Atheros card, but, it won't work for your current one.

 

LatinMcG can probably give you more info on it, as he is the DSDT/networking guru. ;)

Share this post


Link to post
Share on other sites

Just because a question is answered doesn't mean we'll close the thread. ;) It's just not generally what we do.

Share this post


Link to post
Share on other sites

yah cant rebrand that i know of the ath9k type cards.. the ath5k yes but they are buggy as it is.

9k is better cards, 5k is almost obsolete A/B/G only.

 

the ar5b91 can be subven, subsys rebranded in dsdt.

 

im not a guru.. but im close.. i seen others that know a lot moooooore than me.. but they moved on and retired or hardly logon anymore.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771     First... If you need DSDT edits... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Run it, post files generated in your desktop RunMe.app  Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder  CLOVER.zip   --Install Sierra/High Sierra and boot into system!   Post Installation   --Install Clover in HDD/SSD and replace with my folder CLOVER.zip   --Reboot and activate video!   -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/ -Nvidia WebDriver High Sierra http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/ -Cuda http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/   -DSDT My DSDT DSDT.GA H97M-DS3P MaLd0n.zip   -Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -HDEF -RTC -IRQs -SBUS -MIKEY -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -EC -PNLF -HDMI





      -FakeSMC
      https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek -Audio https://github.com/vit9696/AppleALC -LAN https://github.com/Mieze/IntelMausiEthernet   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By b0tus
      Hello :D
       
      I was wondering if it will be possible to put OSX on MSI Trident 3?
      What do you think?
       
      Intel® Core™ i7-7700 Processor
      Intel® H110
      1 x M.2 SSD*
      1x 2.5" HDD
      *BIOS 500 series for PCB 1.0 version support M.2 SATA SSD only and BIOS A00 series for PCB 2.1 version support M.2 SATA / PCIe auto switch
      2 x DDR4 2400MHz SO-DIMMs, up to 32GB
      MSI GeForce® GTX 1060 3GB GDDR5
      5.1 Channel HD Audio with Nahimic audio enhancer
      1 x USB 3.1 Gen 1 Type C
      2 x USB 3.1 Gen 1 Type A (with Super Charger 2)
      1 x Mic in / 1 x Headphone out
      1 x HDMI out (VR Link)
      1 x USB 3.1 Gen1 Type A
      4 x USB2.0
      1 x HDMI out
      1 x HDMI in (connect Graphic card and front VR-Link port)
      3 x OFC Audio jacks
      1 x RJ45
      Intel® Dual Band Wireless-AC 3168
      BT 4.2
      GigaBit LAN (Intel® WGI219VIntel)
      230W AC Adapter
      Fan Cooler
    • By shinho73
      I know that it is almost impossible to install any os x on AMD APU netbooks, but i am hoping that  someone could help me here. Any help would be greatly appreciated.
      Thank you
    • By Angelo_
      I jusst bought a 500gb crucial mx500 to see wheter the slow response of my hackintosh was due to the old 2.5" 500gb wd black hdd that i savaged from a broken laptop at home to install osx the first time but i don't know how to transfer my datas, os, programs and bootloader on the new drive since crucial only shows how to clone the drive but doesn't (obiously) refer to the clover boot partition, how can i do that?
      and what filesystem should i use? apfs or hfs+?
      I can also use windows or linux programs since i'm on a triple boot setup
×