Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
ugokind

[GUIDE] ASUS G53SW Mountain Lion 10.8.2 Complete

28 posts in this topic

Recommended Posts

Starting from here http://www.insanelym...t&p=1775630I'd like to start a different session for ML because I never want to dirty the Lion thread.

 

NO FREEZE WITH INVIDIA GRAPHICS CARD

As described here, the typical random freeze of the 460m GTX due to bad driver (and bad driver AppleIntelGraphics power management) is solved in the DP4 ML release.I did some benchmarks.. and I confirm.

 

__________________________________________________________________________________________

STORY OF THE 1st POST:

EDIT: a new prototype for the setup! http://www.insanelym...38;fromsearch=1

EDIT: test AICPM patch with this http://olarila.com/f...84699e7544fcd16

EDIT: ML GM is slow at boot.. testing this with this

EDIT: Audio is working with AppleHDA patched

EDIT: Good sensors tested with fakesmc. Tested 5 kind only one give no KP at boot and is here

EDIT: Added the external resources to run BT Coexistence algorythm but search for testers!!!!

EDIT: Added SSDT Table but not perfect resume!

06/12/12 : thanks to other 3D http://www.insanelym...l-1082-install/I've merged the 1st post with my smbios and dsdt and I have:-sleep/wake-usb3-backlit keyb

 

__________________________________________________________________________________________

WHAT NEVER RUN: reader card

WHAT IS STILL TO DO: try to enhance the usb remount after the wake.. // enable the audio after the wake // enable the lid funcions

__________________________________________________________________________________________

 

 

 

ATTENTION: I have a modded bios.. but you can run it OOTB also with the original one

 

THE PREPARING GUIDE:

The guide is good for DP4 and Above BUT to have a SLEEP&WAKE must upgrade 10.8.2

 

Requirements:

  • DMG (original)
  • USB pen (8gb at min)
  • a good MAC/HACK
  • the mytical Mountain Lionize superscript by ErmaC
  • the bootloader ErmaC ONLY 2064 !!!!!
  • a drive for the target setup

  1. Read and apply 1 point of the guide http://www.insanelym...ionize&st=0
  2. After a while you have the USB!
  3. Reboot on the USB pen
  4. ATTENTION: that guide only prepare the USB to install ML but doesn't commit changes in the setup procedure.
  5. If you want to alter the setup for example to bypass CPU/RAM detection ot the partition scheme of the target drive.. you must follow another guide or DIY thosechanges.
  6. Follow the setupReboot on the previous mac and attach the installed HDD drive (i prefer to use an usb drive)
  7. Apply the Bootloader on the newer tatget drive
  8. PUT the needed basicly kexts on the Extra/Extension folder of the target drive (FakeSmc.kext and NullCPupowermanagement.kext) no need to run this

 

If you want to enjoy quickly.. reboot

If not.. put the DSDT taken from below or from my LION guide (see 1st row of this 3D), and reboot

 

TO RUN OOTB WITH BASIC FUNCTIONS:

Apply 10.8.2 regular UpdateApply an SMBIOS from 5,1 MacPro to run the latest invidia graphics updateApply the attachment : What you can put on the S/L/E but is not needed:

  • Sensors (attachments included in the FAKESMC plugins)
  • AppleHDA patched (Attachments)
  • AppleACPI from older mac to see the right battery icon (Attachments)
  • APPLY the AppleIntelCpuPowerManagement Patches (or use kext from the net but only for the same processor you've in your lappie or use mine)
  • The OVERRIDE Display Asus patch (Attachments-> copy as is in the folder structure)
  • Patch AppleIntelGpuPowerManagement to fit with MBpro8,2 device card (or use mine)
  • Apply SSDT aml (attachments)

REMEMBER YOU RESET PERMISSIONS

REMEMBER YOU ENABLE TRIM AFTER ALL IF YOU HAVE SSD Drive

 

THE LATEST STEPS:

BLUE PILLS: If you never want to MOD your LAPTOP:

-TAKE THOSE KEXTS expecially the ioatkfirmware and the devicemergenub, BUT ATTENTION: the DSDT must be merged with the one in that folder

Apply the attachment taken from the g74 ootb thread http://www.insanelym...l-1082-install/but take mine attachment because AppleHDA, Appleintelgpupowermanagement, smbios.plist are different!!

 

RED PILLS: If you want to MOD the hardware:

the Delock USB 4.0 has the SAME chipset Broadcom mounted in the newer Iphone and MBPro 2012-

-Discover the PCIexpress expansion slots in the right middle area (I started from this guide) and solder with calm and a smaller solderpen the 36 and 38 pin of the board connector.

Take over the +5v and the ground from another usb pcb pads and you have the 4 terminals for a news USB host device. Buy the DELOCk USB4.0 (yes it's 4.0 usb!!!)

Disassembly the Delock USB and solder in those terminals As I did

g53sw.zip

Share this post


Link to post
Share on other sites

My Major issue with Mountain Lion is the Graphic Card (460m gtx) from Asus G53Jw-A1, i'm using Chameleon r2011. More specifically the HDMI which doesn't work when using video copy on an external TV. It freezes at a blue screen than i have to reboot. I tried to use my previous kexts for graphics from my previous backup (10.7.4 with patched binary from nvidia f006 driver, 29.50 cinebench, no freezes with a custom AGPM, and very smooth) but it doesnt boot anymore.

So i decided to rollback to 10.7.4 for now as everything works well.

Btw, you could get your ALC269 work with this AppleHDA, i think im using the same and works with everything (even mic), but are you experiencing no sound issues after sleep ?

Share this post


Link to post
Share on other sites

after sleep actually I've big problem.

So agree with you! since 10.7.2 no problem in resume... 10.7.4 is quite similar to ML.. and I have the same trouble as ML

I mean: Lion 10.7.2 good resume.. good system. I've also patched video and opencl.. and AIGPM. but in Lion I had problem at boot manager.. no possibilities to run with a real kernelcache

 

in ML: native vanilla kext with native opencl. no freeze anymore.. I've only patched the AIGPM even if people tell that's not needed. But In the boot I see that AIGMP still don't recognize the model.

the pro: kernelcache RUN! audio is applehda patched but I tested (i suppose) 9 different kind of applehda.. so I never want to waste my time to manipulate pins and codec verbs!

the cons: I never run HDMI.. I don't need it and I don't know if it run or not. The resume is bad! after the wake I see for an istant the screen but after the screen become white and dirty. no more screen. but the OS run and I press the power button and the enter to shutdown the OS. AICPM: If I run the patcher I have KP at boot. It collides with SMC and IOplatform. So I have to use the AICPM patched (for our i7) from ML DP4.

 

I want to go high.. but I have a lot of missing experiences.. for example:

-If I try to merge BLC/BCQ/BCM methods in PNLF and LCD .. in the DSDT.. I have black screen at boot.

-If I disable pstate generaion and cstate generaion at boot.. I have less functions

-I'm not able to mod the SMC plugin for the macbookpro8,2 (because i7 with that device is quite similar to mb8.2)

-I try to move to GE=no, but I have no gfx and I read about gfx strings are not useful with recent bootloaders

-I use 2009 boot.. 2003 is bad but 2009 or 2011 is the same. I suppose

-I'm sure that applehda patched is not good in the resume.. and in tonymac blog you can catch the IOaudiofamily modded to have the proper resume audio. but in the MLGM is KP at boot. and Voodoo drivers (pstate.. keyboard.. audio are still bad as the releases of Mac osx grow!)

Share this post


Link to post
Share on other sites

Sleep nd rtc have to be improved but nw the aigpm ia good enough to have video at resume

Bye

Share this post


Link to post
Share on other sites

Hy. whith my attachments.. I can see the orz bar in the display control panel to select the Brightness using the ACPIBacklightpanel.kext

 

but at verbose boot I see

 

ACPIBacklightPanel: Found Backlight Device: DPOD

ACPIBacklightPanel: ACPI Method _DOS found. Device path: _SB.PCI0.PEG0.GFX0

ACPIBacklightPanel: ACPI Methods _BCL _BCM _BQC found. Device path: _SB.PCI0.PEG0.GFX0.DPOD

ACPIBacklightPanel: getIndexForLevel(10) not found in _BCL table !

ACPIBacklightPanel: Version 1.2

Share this post


Link to post
Share on other sites

One more thing I mentioned. I had random freezes until I got rid of the Patched AppleHDA.kext which I grabbed from jeff, thread on the Asus G73 series over at TonyMac's. Both the G73 and G74 use the same audio card and I think your G53 does to. I also had to find the exact correct Voodoo.kext since it was also causing random freezes to. It took forever to figure that out but after I while I realized there is another audio component in our Laptops related to HDMI. Its an Nvidia Audio device.

 

You should not need any other kexts just a good DSDT and Graphics Enabler =yes. I would not change any other kexts for Mountain Lion 10.8 Golden you will only have to do as I said below.

 

Once I got a correct audio driver all freezing stopped!! This was for 10.7x. Also proper patching for OpenCL and very important for 10.7x. I would remove these 4 files or just rename them without the .kext extension at the end of the driver so they will not load.

 

Try these suggestions I bet your freezing will stop!! Just remove the audio driver for now. You could try the one I have attached that is working 100% both in 10.7x and 10.8x.

 

Remove these kexts or rename them:

 

ApplePolicyControl.kext

AppleTyMCEDriver.kext

AppleUpstreamUserClient.kext

AppleGraphicsPowerManagement.kext

 

I removed all these in 10.8 no issues and my graphics card GTX 560M works great!!

 

Maybe try Chimera v1.10.0. That is what I am using for Mountain Lion golden.

 

Here is the voodoo audio driver. Remove AppleHDA or use the APpleHDADisabler.kext.

AppleHDADisabler.kext.zip

VoodooHDA.kext.zip

Share this post


Link to post
Share on other sites

This evening i'll try. Sure ..but do you have a good aicpm patched kext fot 10.8 gm?

 

Does the voodoohda boot fine in kernelcache?

I boot ssd in 6..7 secs

 

Actually i'm applehda and is good no hdmi

 

Ps my aigpm patch (look inside the mbp8,2)

Was good sleep resume in lion.. And also now in ml gm

The kernel.log shows (as time goes by) aigpm run fine

 

The mousewheel and not responding system after the resume think is due to not good restore of cpu

But usb devices return green after the red in the sleep mode

that

Bah

Share this post


Link to post
Share on other sites

@ugokind,

 

As far as I know voodoo does boot fine in kernelcache enabled. My boot time on non SSD drive is about 10-15 seconds. I am telling you the audio kext I was using caused all the problems. Apple SPinwheel and Freezing. I would disable temporarily while testing.

 

That resume after sleep does cause some issues with our Laptops but everything comes back after a few seconds. No Spinwheel for me when resume.

 

Make sure your DSDT is perfect. I might be able to make you one to test, attach both your patched and unpatched DSDT, the unpatched one extracted from Linux or windows AIDA64 for example. You can't extract your DSDT in OSX with DSDT override because you will be sending me a modified DSDT.

 

What does System Profiler show for your graphics card. Can you attach an image of the graphics info from System Profiler.

 

Thanks

AppleIntelCPUPowerManagement.kext.10.8__Patched.zip

Share this post


Link to post
Share on other sites

this is my log for AIGPM

NVDAGF100HAL loaded and registered.
[AGPM Controller] build GPUDict by Vendor10deDevice0dd1
AGPM: GPU = GFX0 Initialized, Control ID 17

 

 

and the normal log kernel

 

PUHwPstate(1, 0): fHwPstate = 3 fFB = 0xffffff801f313000
AGPM: updateGPUHwPstate(): state = 1. Calling fFB->setAggressiveness()...
AGPM: GPU = GFX0 G-state set to 1 from 3, ControlID = 17. SW occupancy updated.
AGPM: updateGPUHwPstate(2, 0): fHwPstate = 1 fFB = 0xffffff801f313000
AGPM: updateGPUHwPstate(): state = 2. Calling fFB->setAggressiveness()...
AGPM: GPU = GFX0 G-state set to 2 from 1, ControlID = 17. SW occupancy updated.
AGPM: updateGPUHwPstate(0, 0): fHwPstate = 2 fFB = 0xffffff801f313000
AGPM: updateGPUHwPstate(): state = 0. Calling fFB->setAggressiveness()...
AGPM: GPU = GFX0 G-state set to 0 from 2, ControlID = 17. SW occupancy updated.
AGPM: updateGPUHwPstate(0, 0): fHwPstate = 0 fFB = 0xffffff801f313000
AGPM: updateGPUHwPstate(0, 0): fHwPstate = 0 fFB = 0xffffff801f313000
AGPM: updateGPUHwPstate(0, 0): fHwPstate = 0 fFB = 0xffffff801f313000
AGPM: updateGPUHwPstate(1, 0): fHwPstate = 0 fFB = 0xffffff801f313000
AGPM: updateGPUHwPstate(): state = 1. Calling fFB->setAggressiveness()...
AGPM: GPU = GFX0 G-state set to 1 from 0, ControlID = 17. SW occupancy updated.

 

 

the IOsysprogiler tells for graphics:

NVIDIA GeForce GTX 460M:
 Modello Chipset: NVIDIA GeForce GTX 460M
 Tipo: GPU
 Bus: PCIe
 Slot: PCI-E 16x
 Larghezza Lane PCIe: x16
 VRAM (totale): 1536 MB
 Fornitore: NVIDIA (0x10de)
 ID dispositivo: 0x0dd1
 ID revisione: 0x00a1
 Revisione ROM: 70.06.26.00.0A
 Monitor:
ASUS G53 LED FullHD:
 Risoluzione: 1920 x 1080
 Profondità pixel: Colore 32 bit (ARGB8888)
 Monitor principale: Sì
 Mirror: Spento
 Online: Sì
 Integrato: Sì

 

and the pci card section tells:

NVIDIA GeForce GTX 460M:
 Nome: NVDA,Display-B
 Tipo: Controller Monitor
 Driver installato: Sì
 MSI: Sì
 Bus: PCI
 Slot: PCI-E 16x
 ID fornitore: 0x10de
 ID dispositivo: 0x0dd1
 ID fornitore sottosistema: 0x1043
 ID sottosistema: 0x0010
 Revisione ROM: 70.06.26.00.0A
 ID revisione: 0x00a1
 Ampiezza link: x16
 Velocità collegamento: 5.0 GT/s

 

But I'm never KP! I have weel at resume and no operations.

 

WRONG: AppletyMCEDriver is invoked only if you have MacPro4,1 or MacPro5,1 so for me is not a damage to have or not

 

WRONG: ApplePolicyControl.kext: solution: if you have an smbios.plist that identifies your system as something that ApplePolicyControl.kext will not panic on – no panic will happen, this was the case with my own system.

 

RIGHT: AppleUpstreamUserClient.kext: lags can happen when irqs are in PIC and TIMR section of dsdt. remove them ,for sleep only internal usb in dsdt is most important. appleupstreamuserclient can make lags on nvidia cards, but it is safe to delete it, even for ati users. nobody needs this kext that osx loads all the time.

 

?AppleGraphicsPowerManagement.kext: I'll try with and without

 

EDIT:

I removed ALL but nothing

 

the voodooaudio is good 1 step above applehda patched because I see also the ext mic

 

but I see that the wheel is still runnning after the rersume: but I cannot click anything.. but if I press Shift+CMD+4 I see for an istant the Screenshot area selection.

It seems like the kernel is alive.. the server x also.. and some other daemons.. but after.. nothing.

 

bah

 

EDIT: your AICPM and mine are identycal.. same behaviour.

 

ps: sure that I never patch RTC? the dsdt mod and the vanilla kext are enought? in the past it didn't.

 

EDIT LAST: for the 1st time I'm crazy on the boot: now I cannot boot in -f

If I want to boot -f it boots as it is in usekernelcache, but I never wrote usekernelcache in nowhere!

And voodoo never loads.. even if I don't write kextload voodoohda! but IF I put another kext.. reset permissions.. it loads at next boot and I don't boot -f why?

bah goung bed for sleep

 

see tomorrow

screenshot.zip

Share this post


Link to post
Share on other sites

WHere did you get your DSDT or how did you patch it?

 

Where did you get your APpleHDA or how did you patch it?

 

Can you check you kernel messages look for this:

 

ACPI_SMC_PlatformPlugin::initFanThrottleControl - waiting for AppleSMC

 

Do you have this message or any message about ACPI SMC Platform.

 

Let me know!!

 

EDITED:

 

Check this out they are saying we don't need to use ssdt its a mistake with fakesmc and should be an easy fix?

 

http://www.insanelym...dpost&p=1835422

 

I will try it soon!!

 

 

Edited Again:

 

Still need ssdt unless I did not edit the plist correctly but kernel message went away:

 

ACPI_SMC_PlatformPlugin::initFanThrottleControl - waiting for AppleSMC

 

Does your serial number say Null in System Profiler? Trying to figure out how to fix that?

Share this post


Link to post
Share on other sites

yes me too .. waiting for SMC

 

AppleHDA is patched for alc269 for the asus k53sd here http://www.osx86.net/downloads.php?do=file&id=2786&page=2

because I tested eleven applehda 269 but only this run!

 

dsdt.. i'm able to patch for a lot of thing .. i like patching it but the asus ROG has a very non standard one! sigh

 

my dsdt has:

-cosmetic patches

-no irq on devices .. except for the 4 irq for HPET

-rtc patched (but most recently told that the 0x02 coult not be enought or could not be needed anymore)

-darwin OSYS and OSTI injection to run and enable funcions as in win7 device in the power management mode and some little other

-hda and pinvode injection

-sata injection

-usb injection and usb wake after resume (but also in lion it was not good.. also in win7 !!! i think is a not perfect hw in that!)

-processor injection

-wak and pst injection (to improve the sleep command)

-pnlf and lcd injection

-complete video nvda injection (no need to use any enabler)

-wifi injection

-SMBus total injection (the kext is up and running and improve the reading of sensors and EC)

-LPC total injection (the kext is up and running and improve the PCI and southbridge communication)

-cosmetic not running identification of the segment for usb3 injection and BT for those who still have the combo card

-NO LID injection (the lid is the {censored} of this laptop.. I left a DV6-6132 HP for that.. but HP has the lid open and resume function as the MBP!)

-NO smc/ssd fan method

-NO BCxxx mods for acpi backlight

-NO thermal zone mod

-NO EC zone mod (in acer and hp I did a lot of mods.. but in the Asus ROG I have not the table of allocations (to manage LID for example) and I cannot manage also the INI or REG method to alter the EC register at boot .. it's strange but it doesn't run in that laptop

 

I'll test Olarilla post..

 

ah

Share this post


Link to post
Share on other sites

Can you attach your unmodified DSDT. I want to compare in this program I have both your vanilla dsdt and patched dsdt side by side.

 

Thanks

Share this post


Link to post
Share on other sites

i attach the original dsdt

don't remember the source because in those months I used RWeverything, Ubuntu and W7 native

 

now I'm testing some changes i've in the buffer from a couple of weeks.. but never tested (gcst method..)

origDSDT.zip

Share this post


Link to post
Share on other sites

Hey ugokind,

 

did you get your USB 3.0 working under Mountain Lion GM?

 

 

I've a Transcend USB 3.0 PCI Express Card, with patched LaCie PXHDC.kext I get the Super-Speed Bus in ML but my LaCie USB 3.0 eHDD is not mounted at all, as it was under Lion...

 

Thank you!

Share this post


Link to post
Share on other sites

True.

Me too had a discrete usb running in lion

Now it's fog everywhere

Share this post


Link to post
Share on other sites

Hi I am a Paraguayan new Mac user, I really want to mount a server for my home/ office, people here run an architecture office, we have 10 computers, I would like centralized windows seven administration, file sharing, daily back up, media streaming, (Im tired of duplicated files and people mess), something similar to deep freeze, and also want it to be a render server.

At the beggining I was aiming towards the windows home server 2011, but now that have read some reviews, I wanna learn more about Mac.

Cand I do this with an osx server? is a lot better than the WHS 2011,

Could you plz help me from scratch?

Greetings!

Share this post


Link to post
Share on other sites

complicated.. but why you wrote this here? you may want to do a server farm or a render farm with that laptop?

Share this post


Link to post
Share on other sites

Hey ugokind,

 

did you get your USB 3.0 working under Mountain Lion GM?

 

I've a Transcend USB 3.0 PCI Express Card, with patched LaCie PXHDC.kext I get the Super-Speed Bus in ML but my LaCie USB 3.0 eHDD is not mounted at all, as it was under Lion...

 

Thank you!

 

Hey guys, to get USB 3.0 to work, just copy IOUSBFAMILLY kext from 10.7.4 over ML's one, the rest should be the same ( either with the lacie's driver or Asmedia one-> i prefer this one).

Let me know if it works for you guys.

Share this post


Link to post
Share on other sites

Hi Ugokind,

Just want you know that the AppleAPCIPlatform.kext you attached degrades the performance of my SSD. The random 4K uncached read goes from 18MB/s -> 15MB/s . Maybe it is not worth it just for the correct battery icon.

 

Hey unii,

 

Caldigit USB 3 driver works pretty well for my ASUS G53SW. Maybe you should try it.

usb3 for ASUS G53SW.zip

Share this post


Link to post
Share on other sites

Woa. But tje appleacpi is the same as every people uses to see a proper battery icon.

So..are you kindly to attach your caldigit+what you have modded ?

I tried a dozrn from caldigit and others.. With or without dsdt or chameleon or iousbfamily modded. But i never had a really usb3

My caldigit gave me only an unknown device

did you put other changes to make caldigit run?

 

Woa. But tje appleacpi is the same as every people uses to see a proper battery icon.

So..are you kindly to attach your caldigit+what you have modded ?

I tried a dozrn from caldigit and others.. With or without dsdt or chameleon or iousbfamily modded. But i never had a really usb3

My caldigit gave me only an unknown device

did you put other changes to make caldigit run?

 

Woa. thanks.But the appleacpi is the same as every people uses to see a proper battery icon.

So..are you kindly to attach your caldigit+what you have modded ?

I tried a dozen from caldigit and others.. With or without dsdt or chameleon or iousbfamily modded. But i never had a really usb3!

My caldigit gave me only an unknown device

did you made other changes to make caldigit run?

Share this post


Link to post
Share on other sites

Woa. thanks.But the appleacpi is the same as every people uses to see a proper battery icon.

So..are you kindly to attach your caldigit+what you have modded ?

I tried a dozen from caldigit and others.. With or without dsdt or chameleon or iousbfamily modded. But i never had a really usb3!

My caldigit gave me only an unknown device

did you made other changes to make caldigit run?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×