Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  
Guest lip2502

(SOLVED) 10.5.8 Combo Update Restart error at boot

4 posts in this topic

Recommended Posts

Guest lip2502

Hi all,


I have been working on my hackintosh for a few days now, and I finally got everything working fine (except WEP for wifi).

I have used ideneb 1.3 (Leopard 10.5.5).


But after installing the combo update 10.5.8, everything is messed up. I can't even boot. I get a message at the beginning of the booting process telling me that I have to restart my computer.


I tried safe mode (-x), I tried (busratio=20), I even repaired the permission via the disk utility of the Ideneb DVD. Nothing's changed.


Do you have any idea on how to fix this up ?


Thanks for your time and help :D

Share this post

Link to post
Share on other sites

These iXXX disks is AKA "distro" or simple put a patched retail OS X disks. The disk was patched in order to make it run and install on ordinary PC (not Mac). In order to make it possible some files from original install disk are patched, some are replaced with different ones, some are added (not present on the original media). It usually also have some modified kernels added for incompatible CPUs to be supported. Also some components are removed in order to "stuff it" to a single layer DVD disk (instead of dual one) - such as printer drivers and/or languages.


One can use a retail OS X disk/disk image to install OS to a PC. It is done by using an additional boot CD/USB drive. It might be more difficult to install it like this (depending on hardware used), but usually works better. Including updates.


When you update OS X using either combo or delta update file (the one downloaded from Apple's website), it updates many system files including kernel. Now if some of these files were patched on the distro disk, they are overwritten by a newer and not necessary compatible version. Therefore OS X can no longer boot - because some patched files what were essential for the system to work were replaced with new and not patched (original) files.


In order to get your OS X working again, you need to replace these essential files with the patched ones (newer version but patched the same way older files were). Obviously one must know what files were the essential files and how to patch/modify/get them and replace them. I can't tell what these file were. I would be difficult to figure this out or you can also restore OS X from a backup (if you have one).


Therefore you should avoid updating OS X installed from a dsitro disk, via official/non patched (these also are/were present in the same places where you have found your distro disk) Apple updates, if you use a distro disk. In other words, if you have distro based OS X - don't use non-patched updates. Or you will have to restore the system files.


Now if a retail disk is used, most official updates will install without any issue (depending on the hardware used). This is because there are no patched files in the retail disk so updating these doesn't breaks anything.

Share this post

Link to post
Share on other sites
Guest lip2502

Could not wait any longer, I had to reinstall a brand new system. I have switched to MAC OS X 10.6.3. Anyways because extra careful when updating from ideneb.


@ fantomas 1 : It said Debugger called (panic) or something like that :(


Thanks for your help. Any idea on why I can't connect WEP protected networks ?


Wifi specs : Hercules Mini G - Realtek 8188SU 10.6

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By dfear

      I am try to install High Sierra, as per #####
      I have have successfully booted from the install usb drive and have booted into "Install macOS High Sierra". I had to add a boot flag (-no_compat_check) to the clover bootloader in order for the usb stick to boot properly. Also, at first I couldn't see the SSD drive in disk utility, but I fixed that by asking disk utility to show all drives.

      Onto the current problem. I am having major issues trying to install High Sierra to a NVMe SSD. When I run "Install macOS High "Sierra" I get the following error:

      "The version of macOS installed on this mac is newer than the version you are trying to install. When a new update is available, you can install it from the Updates plane in the Mac App Store. If you want to reinstall macOS, please use macOS recovery."

      Also, It doesn't matter if the startup volume is formatted as APFS or HFS+.

      If I format the drive using GPARTED on linux, the installer just says the startup volume doesn't have journaling enable. If I then run disk utility and enable journaling on the startup volume, then go back to the installer, I get the aforementioned error msg.

      I have the following specs:

      Asus Prime X299 Deluxe.
      ADATA 512GB NVMe SSD.

      How do I fix this issue?
    • By davideantonio
      Hi guys, I Have an ASUS N752VX, and I've installed mac OS High Sierra, in my laptop. Unfortunately I have some problems with kexts.
      - Touchpad I2C,
      -  Ethernet.
      P.S. Maybe , the second one, is caused by my USB Wi-fi, because my wi-fi module seems to not work 'cause it is not compatible! 
    • By zafirofx
      Hi everybody. I can't install my graphics card on my Hackintosh. I've tried several methods and no one of them work, when I go to the tab "About this Mac" it says on Display that I have a 3MB screen and I don't have 1920x1080 resolution.I'm a beginner here in the Hackintosh world so please be patient with me. Hope you can help me. Thank you. Also I'm uploading my Clover folder.
    • By Friendlyx
      Hello everyone!
      I'm trying to get my hackintosh running, but i haven't been able to sadly. I'm basically trying to install high sierra onto my computer which is the following specs:
      Intel i7 8700k
      Gigabyte Z370 AORUS Gaming 7 
      Gigabyte 1080 Ti AORUS Xtreme Edition 11GB
      I had high sierra installed, but i messed up the software somehow, and then i thought i could just reinstall it (since it was really easy the first time, no issues) but was i wrong. I haven't been able to reinstall it even after wiping the drive completely clean. I am running windows 10, so i will be doing a dual boot.
      I started following the following guide and it worked for the first time, but even after using their EFI it isn't working still: 
      I'd appreciate any help i could get, i'm really at a loss. 
      Thanks in advanced!