Jump to content
Sign in to follow this  
Followers 0

AD1988B for DP4

2 posts in this topic

Recommended Posts

Hi all


Anyone have a AD1988B working on ML DP4?


I have a modified dsdt, extract the zlibs (ayout12.xml.zlib and Platforms.xml.zlib) change-it like in Lion compress again... but no go.


DSDT Modification:

Device (HDEF)
			Name (_ADR, 0x001B0000)
			Method (_DSM, 4, NotSerialized)
				Store (Package (0x08)
						Buffer (0x04)
							0xA0, 0x00, 0x00, 0x00
						Buffer (0x04)
							0x6B, 0x10, 0x00, 0x00
						Buffer (0x04)
							0x0C, 0x00, 0x00, 0x00
						Buffer (Zero) {}
					}, Local0)
				DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
				Return (Local0)


Thanks, cya

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By pippoaacc
      Hi, I have a perfect running ML 10.8.5 setup on a Gigabyte X58A-UD7 rev 2.0 FD BIOS (with UD5 DSDT), but cannot get HWSensors control my CPU Fan, which runs at 900rpm regardless of temperature (won't scale up). Tried both 1067 and latest release. I'm looking for 2 possible solutions:
      1)A working setup to control pwm cpu fan with the IT8720F setup thag comes with this MoBo
      2)A valid hardware controller for my Arctic Freezer 13 Pro CPU Cooler, but which could automatically scale according to cpu temp readings. If using an external sensor, I really appreciate any hint on how to position the sensor on CPU correctly, because I'm worried about relying on a non-mobo controller for cpu cooling.
    • By kvonlinee
      Hi everyone!
      I have a old Dell XPS 410, I was run 10.7.5 and with many attempt to run 10.8. I got great news as it works in 10.8.3 for me, I learn form many sources I will give credit to the place I learn.
      let begin.
      To be continue from
      Dell XPS 410 Resource Extravaganza


      my hardware specific
      you need to downgrade bios to 1.3
      Cpu core2duo 6300 1.8 ghz
      Ram 3 Gb : 2x1GB, 2x512 Mb
      Graphic card Nvidia PNY 9800 gtx+
      hard drive 1TB.
      you need MountainLion app fromt he app store 10.8 or 10.8.3
      first you create an usb installer like 8 GB at least and follow this guide credit to Still Win Fan

      the same for mountain lion. when you done the usb installer.

      then you install extra folder to that usb installer from myhack from Conti


      we need to prepare some thing like this for it to able to boot into 10.8 install srceen is put on PciRoot=4 because this guide credit go to oldnapalm


      used text edit to edit org.chameleon.Boot.plist for the PciRoot=4

      used chameleon wizard to create a SMBios and place it in extra folder.

      for the ATA drive to be recognize need kext IOATAFamily.kext from


      run myfix from myhack.

      it is ready to install now.

      after install success get to desktop then run combo update to 10.8.3 the the rest for you to enjoy you hack
      I have it running Maverick, this time I found a easy way to tunning to a workable machine,   this time I have the graphics to nvidia GT 610 which have a audio over HDMI with voodoo HDA 2.8.2
      i have attack the extra filer from my machine, when you created usb installer, I recommend MyHack, then use my hack to install this extra folder to USB installer, this way will help your tune the machine easy. follow the installation to the end, it may not be finish but it is ok.  boot up with the usb installer again, don't install, go to utility and then Myhack, then install extra folder from download, done and reboot and enjoy the machine.
      Yosemite         Yosemite
      Hot the idea from mpalomba3 about running Yosemite on this Dell recently. I start the work and finally it run of ok.
      due to my hack is not release, this time I use the installer from chris1111 I used the OS X Yosemite Chameleon V2.zip at the link
      with some tweak and it can run Yosemite. we can begin now.
      1- you need the Yosemite from the App Store, go head download it, have a hard drive to make the installer and the boot drive also ( I recomment it because I found it is easy to get it running. portion the hard into 2 partition, one boot drive with big capacity, one install name USB size like 10 GB.
      2-the time you run the OS X Yosemite Chameleon V2.zip, if you down load already it is in the Download folder, open it and run it, when it hit to standard install then you can change to the USB location. let it run some time it will let you know it done. it is not ready to run yet, in the extra-10.10-ps-410.zip has 2 kexts copy and paste it to the USB/Sytem/Library/Extention/   . it will as for replacement, yes then copy the org.chameleon.Boot.plist to the USB/Extra/Extentions, now it is ready to boot install.
      3, when done the installation, it will reboot, if you good at terminal then boot the installer again, using the terminal copy and paste 2 kext about in USB/Extra/Extensions/   to {boot drive}/System/Library/Extentions/  and make a new cache or similar thing or
      3a, you can use the mac before, plug the drive through usb adapter copy and paste 2 attack kexts that to 
      {bootdrive}/System/Library/Extentions/  and  and copy the OS X Yosemite Chameleon V.2 to a foldler in the USB-Yosemite and then use the kext wizard app to Maintaince/---System/Library/Extension----Reapair permissions-rebuild cache,  copy   it is ready. to go by itself.
      4 boot to the new install Yosemite, after all registration, add Users, to the desktop, run the OS X Yosemite Chameleon V2 choose the Post install with chameleon,  IntelGB Ethernet, nullcpu, fakesmc and what other you need, when installation is done copy the org.chameleon.Boot.plis from extra-10.10-ps-410.zip to {boot}/Extra/ and it is ready. to go. 
      I add to the org.chameleon.Boot.plis boot flag: -v PciRoot=4 Kext-dev-mode=1 dartwake=0
      the value 4 of PciRoot because the machine say that, if you found a different and better value then you go for it.
      the one kext the AppleIntelPIIXATA  is require one, the other AppleRTC is modify one at the link of http://www.insanelymac.com/forum/topic/298536-applertc-patch-cmos-reset/?hl=%2Bapplertc&do=findComment&comment=2080142
      about this machine, Dell XPS 410, 3 GB of Ram, cpu E8600 1.86 Ghz, Asus Fanless GT610/
      thank you to Marchrius,chris1111 have the way to run on this old machine, a hobby for me.
      ****         *****update to show 4 drive, **********  
      I look on the AppleLPC.kext to load or not, and when I add the string   <string>pci8086,2812</string>   in the AppleLPC.kext, the kext is load and it show 4 drives from port 0 to port 3, this motherboard has 6 Sata drive, other port or drive 4 and 5 I don't know how it go. put the kext AppleLPC.kext in S/L/E and do rebuilt cache, I include the original AppleLPC.Kext also.
      about the shutdown and Restart, I got a hard time, after a while I found that use terminal to shutdown it work, so when your system need the shutdown and the power led still on for a long time enter inter terminal, for shut down: 
      sudo shutdown -h now for restart:
      sudo shutdown -r nowand enter your extreme secure password. it from http://www.maclife.com/article/columns/terminal_101_properly_shutting_down_your_mac************about the AHCI port*************after I look close, I don't see the data drive on the system profile, and the system still able to boot the installer and boot to the system, turn out it use ATA drive. so enjoy your hack.
      Extra for XPS 410.zip


    • By codorosa
      Ho bisogno di aiuto.
      Sto cercando di installare 10.8 OSX su Virtual Box. L'avevo fatto anni fa sia su Virtual Box e su un vecchio notebook.
      In questi giorni sto provando a installarlo ma senza nessun esito positivo.
      Ho la Retail Mountain Lion 10.8 INSTALL.
      Ho provato ad installarlo sia con [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url], HackBoot e Chamaleon, ma nessun esito.
      Al F5 per il cambio CD faccio partire l'avvio, parte un breve codice e si ferma.
      Ho provato -v , -x, -f, graphisenabler, cpus e altri due che non mi vengono in mente.
      Avete per favore qualche soluzione?
      Se c'è un metodo piu rapido con VMWare mi va bene anche, basta che mi parte sto sistema operativo,
    • By quesoms
      Hi. Im trying to install OSX (niresh) on my Aspire 5551G Laptop.
      My laptop specs are:
          - Amd Phenom II x3 n830 (i'm not putting this topic on the section called "AMD" because is a problem related with graphics card, processor works perfectly).
          - Ati Mobility Radeon HD 5470
          - 4GB RAM
          - 500 GB HDD.
          - Broadcom wifi
      Everything including wifi is working except the graphics card. I'm not able to get QE/CI Acceleration.
      I have tried to use niresh mavericks or niresh mountain lion (10.8.5). None of them supports.
      I have already tried patching EDID with clover, but no sucess (all works but there's still no qe/ci acceleration or resolutions).
      Using chameleon or chimera with "GraphicsEnabler=Yes PCIRootUID=1" i get a screen full of glitches. If i connect with VNC there's still no qe/ci acceleration, And if i don't use "PCIRootUID=1" Then nothing happens (no qe/ci acceleration but screen ok).
      I have already tried with some kext's. Nothing happened.
      I dont know how to inject EDID on chameleon and i think that this could save me.
      Someone can help me?
    • By campbell92
      I'm not sure if this is in the right section, if I'm not could a mod please point me in the right direction?
      I was trying to make a hackintosh laptop for myself and eveything was going fine until I got to the part where I needed to "Use pacifist to extract mach_kernel from “OS X Install ESD/Packages/BaseSystemBinaries.pkg” and copy it to the root of your USB drive (note: this is in the attachment)" Being the dumbass I am, not reading all the directions, and having no idea what to do, I thought that I had to install BaseSystemBinaries.pkg. So I double clicked and installed the BaseSystemBinaries.pkg for Mavericks on my iMac running 10.6, 10.7 or 10.8 (the right escapes me right now). After it finished installing I figured out I was supposed to use a file I didn't download yet so I tried to open chrome but all it did was bounce a few times then stop. Then I tried safari and it did the same thing, so I kept trying different apps but everything showed up on the dock bounced a few times then quit. Then opened the folder that had the Mavericks installation in it and doubled clicked the installer hoping to fix whatever I had done. After it bounced a few times it went away and stayed like it had been for about 5 minutes then the gray background with the spinning circle came up on the screen. I waited for about 10 minutes to see if anything would happen and nothing did so I tried to reboot it, it went normal except it just stayed on the gray screen with the apple and spinning circle. I even tried booting into safe mode but the same thing happened.

      I don't know what to do or how to fix it, if someone here could help or point me in the right direction that would be awesome. Thanks