Jump to content
Sign in to follow this  
Followers 0

Partition Table damaged (i think)

5 posts in this topic

Recommended Posts

Hi, i have a wierd problem.. I have a 320GB HD, it was partitioned with GUID with 3 partitions:


-MACOSX (hfs+)


-WINDOWS7 (ntfs)


-MACBACK (hfs+)


It was working well with dualbooting options..


But since my Laptop is not well supported i decided to remove completely MAC, and install Debian.. So from the debian installation i deleted the two hfs+ partitions and installed debian WITHOUT touching the Windows Partition...


The system start, but from GRUB i cant see my windows OS, and only can start Debian.. So i readed a guide on how to repair windows boot from Linux, but i think i f*cked up the Partition table / EFI partition...


Now when i start my laptop i see "no bootable devices found, press a key to continue".. i tried also to plug my HD in my other PC i can see the HD but i can't access it.. (no partition found) if i try to open the HD from Computer Resources i get promped to format it.. On that pc i have MacDrive, so hfs+ partitions are recognized and i can access them.. So it is a problem with that HD.


It is possible to fix The partition table at least to see partitions and save data? It is important...


Thank you.

Share this post

Link to post
Share on other sites

Try using either the windows install CD and running startup repair(if the installer sees your windows install) and/or reinstall debian from CD/DVD to at least get grub back. You can also try Hiren's boot CD which has various startup and partition repair tools included. Since your not using MBR, grub might be needed to boot win, but not my area of expertise, can try super grub too. Did you nuke the hidden windows boot partition?

Share this post

Link to post
Share on other sites

I tried to start up Windows recovery, but it do not recognize. I get an error saying that this Recovery tool is not compatible with the current windows installation. (it is the same DVD i used to install, 110% sure.) it's strange.


And, i do not know what i did.. I'm trying a software right now (MiniTool Partition Wizard) I can see all partitions, but can't do much.. only can copy/paste partition, resize etc. I can browse the windows partiton, but can't copy files, only see them.. Since all my important data are on Windows partition, i'm trying to delete all partition except the windows one and move it at the start of the disk.. and see if i can atleast browse files to backup..


I know that this forum may not be the right place to discuss my problem.. I asked here only because of GUID partition and was related to my previous MAC installation..


EDIT: That worked! I can see my Windows partition now and backup data and to a full disk format!

You can close/delete.. Sorry if i posted for nothing!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.