Jump to content
Sign in to follow this  
Followers 0

ALC1200 / Nvidia 9800GTX+ / 64bit

3 posts in this topic

Recommended Posts

Hi, I'm new and noob on hackintosh.

I tried to do my first hackintosh using guides, but now I'm stuck.



ASUS P5Q with ALC1200 (sound)

Nvidia 9800GTX+


Installation Steps:

1. ###### + SL retail on USB Stick

2. GUID Partition on HDD

3. 10.6.8 Update using system date prior 23 March 2012 (apple installer certificate deadline)

4. ###### ([url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url])

5. Audio Kexts + ATE1L Network Kexts


First problem:

Audio is working on Front Panel only.

There's a way to fix the rear plug?


Second problem:

VGA seems to work OOB

resolution ok, the bar in translucent, there are effects

but when I use intensively the system, It seems a bit sluggish.

I didn't used nvenabler nor graphicsenabler in chameleon, yet.

I must use them for achieving fully vga power? (like playing Starcraft2 or Diablo3)


Third question:

how to use 64bit? I installed SL with only 4Gigs of RAM but I want to go 6.



Share this post

Link to post
Share on other sites

Snow Leopard will run in 64-bit kernel and drivers mode by default on that hardware, unless you have the arch=i386 kernel flag set in /Extra/org.chameleon.Boot.plist.


OS X is not like Windows. In 32-bit kernel and drivers mode OS X can run 64-bit apps, use up to 32GB RAM in total, and each running process can to use up to 4GB RAM. So even if you were running in 32-bit kernel and drivers mode, 6GB RAM would work fine.


For ALC1200 you can patch 10.6.8 AppleHDA.kext with HDAWizard. There are .xml and .plist files for ALC1200 in the HDAWizard thread if you look around a bit. However if you're already using VoodooHDA make sure to delete it first. Also make sure that your AppleHDA.kext is unmodified before you run HDAWizard on it. Additionally you will need the standard Intel HDEF device code in your DSDT.

I am unfamiliar with ALC1200 so I cant' promise you that this will make all your I/O work.


Since you're using several TonyMac products, you should go to the TonyMac forum for support. There's no way to know from here which patches are in effect on your system already, as you say you shouldn't have accelerated graphics working, but you do. So those TonyMac tools that you used installed something for you already. The same goes for the sound, if you want to try what I wrote above you're going to have to undo whatever modifications are already in effect first.

Giving you advice on what to do without having more information could easily make things worse.

Share this post

Link to post
Share on other sites

thanks for your suggestions.

The audio kext I used is this: http://www.insanelymac.com/forum/index.php?showtopic=161430

Simply I'm an idiot: on sound preferences I must select Line Out instead Headphones. I can't use two outputs simultaneously.


regard VGA: I see ripples when adding widgets on screen, I see screen savers correctly.

The system identifies correctly my card on system informations. It seems to be working.

I will test with Diablo3

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By simplyhuman
      Hello All,
      I am trying to install SL from retail DVD image on Vmware 15.0.2 on a desktop with the following specs:
      PC: Lenovo ThinkStation P510
      OS: Windows 10 1809
      Memory: 16 GB
      CPU: Intel Xeon E5-1607 V4 @ 3.10 GHz
      GPU: nVidia Quadro K620
      Steps taken till now, got the errors and progressively removed them by going through the forum topics:

      1. Used unlocker 3.0.2 to unlock VMware workstation 15.0.2 (https://www.insanelymac.com/forum/topic/335757-macos-unlocker-v30-for-vmware-workstation/?tab=comments#comment-2638208)
      2. Copied the patched EFI unlocker to x64 folder in VMware Workstation directory (https://www.insanelymac.com/forum/topic/336110-macos-efi-unlocker-v10-for-vmware/?tab=comments#comment-2642442)
      3. Provided the full path of the patched files in the vm configuration file
      4. Got the cpuid mask from here (https://www.insanelymac.com/forum/topic/243274-how-to-install-retail-os-x-106-snow-under-vmware-workstation-7-or-player-3/)
      Now my VM boots up without errors but it displays a stop sign after the apple logo
      Please let me know how should I proceed as I think this is the last hurdle before successful installation of SL on VMware 15

    • By Insanelymac_user_abc
      Is it possible to install an older OS X.5 Leopard or OS X.6 Snow Leopard Hackintosh system on a modern i7 processor PC?  
      I need to to run either of those systems using an Intel Core i7-4770K Quad-Core Desktop Processor on a Gigabyte GA-Z87MX-D3H motherboard.
      I saw this post where someone said “Clover 32Bit should boot Leopard as well, using Legacy mode. You will need 32bit kexts as well.”  https://www.insanelymac.com/forum/topic/331457-bootloader-for-leopard/ .. Would that be valid advice for me to follow up on for my configuration?  I see that Clover 32 bit is no longer in development.. https://www.insanelymac.com/forum/topic/317521-good-bye-clover-32/
    • By MateusPT
      Hi there.
      Soo i was trying install mac at 4 days ago and finnaly today i can. I installed the Leopard and all works fin except the keyboard and ps2 mouse. And then i try a lot to put a .kext with transmac on windows xp cause im dual booting it.When i try to use Transmac i have the error"This drive is read only".
      Who i fix this?! This is my first question!
      The second i think is more hard. I have a Amilo Pro V3505 with 2gb ram and Intel GMA 945, a Intel Pentium T2130 idk the motherboard i aleardy try find the name but i couldnt with a Atheros ar5007eg wirless adapter.
      So i instal iAtkos S3 v2 but when i was booting(after installing) it he boots and starts make the sound of the animation video of snow leopard but THE SCREEN WAS GREY WITHOUT THE APPLE LOGO AND WITHOUT THE MOUSE JUST A GREY SCREEM.
      Well i try much flags but when i try GraphicsEnabler=No while the booting appears i recuve the message "you need to restart the computer" and i restart and gives again the same error.
      I think is some missing kext graphical but i cant add/remove kexts cause transmac give error!
      Thanks in advanced!
    • By geekingoff
      Hello everyone, this is my first post here.
      I have a pretty old laptop that I'd like to get Snow Leopard running on. At first, I tried booting Nawcom's ModUSB with a retail DVD image, but I would always get kernel panic, no matter what I tried (I couldn't even get to the installer).
      So I decided to try a distro, after trying many different things with ModUSB. I decided to use Hazard's 10.6.1-10.6.2 SSE2/SSE3 Intel/AMD distro. I was shocked when it booted to the installer with no issues! I formatted the HD as Mac OS Extended (Journaled), GPT. I then installed Snow Leopard. After a while, the installation succeeded, and I was happy. It went ahead with the restart necessary for the installation, and... kernel panic. The same kernel panic I got before when trying ModUSB. I was really disappointed. 
      I've tried many things:
      boot flags, such as: acpi=off arch=i386 GraphicsEnabler=No PCIRootUID=0 -f -s -x (and more, including verbose mode of course)
      booting the installer again after successful installation, and then going to System/Library/Extensions on the HD in terminal, then: "chmod 755 *.*" as well as "kextcache -a i386 -m *.*"
      reinstalling with no customize options selected apart from the boot loader (first installation, things such as the legacy kernel and specific kexts were specified)
      and probably some other things that I can't remember right now
      The thing is, if the installer can load with no issues, then Snow Leopard should work fine too, because they're theoretically (don't know for sure) using the same components (kernel, kexts, etc.). If I boot the installer in verbose mode, it gets right past the part where it kernel panics after installation just fine. This makes me think that something is configured differently after it is installed - something that the installer does not have - which is causing the kernel panic and preventing the boot.
      Here are the specs of the laptop I'm trying to install this on:
      Intel Pentium M 753 ULV @ 1.2GHz
      1GB RAM
      855GME Graphics/Chipset
      I know that this probably isn't the most compatible with SL, and I know the chipset/graphics are unsupported. However, I think I will be able to get it to work eventually, I just need some input on what might be going on. Looking at the kernel panic, it points toward AppleACPIPlatform.kext, but I don't know what's exactly wrong with it that is causing the kernel panic.
      Please take a look at the verbose mode image I have attached. I appreciate any and all help I receive!

    • By dark_hacker
      I am trying to install the snow leopard from the distro to amd iatkos it does well boot but when I go to the disk utility does not detect the disk do not know why someone can help me to solve this?
      There is a photo of the kexts I have in the extra folder