Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Still waiting for root device

4 posts in this topic

Recommended Posts

Okay, so I've been trying to install Iatkos l2 all morning on my custom built PC, When I boot it up, I get a unavailable logo over the apple logo,when I install it through the command prompt styled window, It loops over "Still waiting for root device". I tried booting in safemode, tried the rd=disk0, pcirootuid=1, # -pci 1, and a ton of other things I read on the web. Nothing works and I am stumped. My hardware is as follows:

i5 2500k

gtx 570

4gb ddr3 crossiar xms3

Asus p8z68-v motherboard

2tb western digital hdd 5400rpm

And an exteran HP DVD writer (1270e)

Also, I'm running my pc on windows 7, and created a 20gb partition for the iatakos, any ideas ???

Share this post

Link to post
Share on other sites


Hmm, well I already checked my bios settings and they seem to be good, Sata is set to AHCI, SMART is Enabled, But I don't think anything else is relevent since I only have one drive in my pc, which is sata, the dvd writer is external. Also, it doesn't boot into the osx installer at all, so I don't know if I can work with the injectors.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MikixIT
      Salve a tutti ho installato OSX, Sierra 10.12.6 (16G29), grazie a questo forum
      Ho installato tutti i Kext necessari da Nvidia a quelli per l'audio HDMI,ethernet ecc..
      L'unico problema che  Mouse e tastiera USB collegati ad un hub FUNZIONANO, mentre senza hub usb non funzionano nelle altre porte, NELLE ALTRE PORTE PERO' FUNZIONANO PEN DRIVE USB,ho provato vari kext in rete mentre il Forum era in manutenzione
      Ma non riesco a farli funzionare su altre porte,vi allego La mia EFI( http://www.mediafire.com/file/mimomvp1on4ys58/EFI-MikixIT 12%3A03%3A2018.zip) E vari screen del mio OSX con info varie

    • By zafirofx
      Hi everyone. I installed MacOS High Sierra on my computer 3 months ago, in January. After a long way to get the computer fully working now I'm facing a new problem: imagine I'm working or doing something in my computer and it suddenly freezes and I have to restart it.  There's no reason why the computer restarts by itself...
      Here I also attach my Clover EFI folder in case you need it (it doesn't allow me to attach it so here i give you the link: https://mega.nz/#!92xCiLDZ!WY1F55ZvuP-9WW369EP9KY-3hNLt5sWUgJDxPrbgpPM .
      Thank you in advance.
    • By MikixIT
      Hi guys
      i need help for this kernel panic its the first hackintosh for me
      I posted photo error
      my spec: i7 720qm,gt 730 2 gb ddr3 msi,8 gb ram
      its a desktop
      Pls help me

    • By Angelo_
      Hi guys, i'm trying to help a friend of mine trying to install osx(possibly high sierra) on his pc with the following specs: 
      Amd fx8350 
      Asrock 990fx extreme 3
      8gb of fury Kingston ddr3 ram(2x4)
      Radeon hd 7950
      128gb ssd( crucial m550)
      A couple of hdds I don't remember the brand(maybe a seagate barracuda and a dumb old disk for data)
      We tried to install it using the regular clover+high showers installer but we couldn't get it to reach the installer, then we tried osx-amd(don't know if i can talk about it there, sorry if i can't) and we still couldn't get to the installer.
      Is there a guide i can use to install osx in that machin, i tried to search in the forum but i couldn't find it.
    • By dfear

      I am try to install High Sierra, as per #####
      I have have successfully booted from the install usb drive and have booted into "Install macOS High Sierra". I had to add a boot flag (-no_compat_check) to the clover bootloader in order for the usb stick to boot properly. Also, at first I couldn't see the SSD drive in disk utility, but I fixed that by asking disk utility to show all drives.

      Onto the current problem. I am having major issues trying to install High Sierra to a NVMe SSD. When I run "Install macOS High "Sierra" I get the following error:

      "The version of macOS installed on this mac is newer than the version you are trying to install. When a new update is available, you can install it from the Updates plane in the Mac App Store. If you want to reinstall macOS, please use macOS recovery."

      Also, It doesn't matter if the startup volume is formatted as APFS or HFS+.

      If I format the drive using GPARTED on linux, the installer just says the startup volume doesn't have journaling enable. If I then run disk utility and enable journaling on the startup volume, then go back to the installer, I get the aforementioned error msg.

      I have the following specs:

      Asus Prime X299 Deluxe.
      ADATA 512GB NVMe SSD.

      How do I fix this issue?