Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Youtube Problem (flash video playback freezing)

7 posts in this topic

Recommended Posts

Hello to all of you!


I have sucssesfully install Hazards Snow Leopard today and updated to 10.6.8 using Legacy kernel for 10.6.8.


Everything works great including games and HD video playback in vlc, the only problem i face is video playback in flash (youtube, dailymotion etc) freezes every 2-3 seconds, if i play youtube videos with html5 everything works great!


problem occours on both chrome and safari!



my build:

Asus M2N-SLI

AMD X2 6000+

nVidia GeForce 9600GT





Just to add: Flash in safari is updated to last one, and in chrome the included one with latest chrome.

Share this post

Link to post
Share on other sites

What about running Safari in 32-bit mode?

That did the trick for me as I had a similar issue with flash and video playback in Safari on 10.6.8 on my AMD machine (same cpu ^^, but MSI board).

Are you using GraphicsEnabler=Yes, NVEnabler.kext or ATYInit.kext? I had some issues with GraphicsEnabler. Video was

juddering on my 8600 GT, i then used NVEnabler or ATYInit. Both worked fine for me and fixed my video issues. I had some issues too when i moved a window. The content in the windows freezed.


assoricks :-)

Share this post

Link to post
Share on other sites

i cant see any 32bit option so i think my computer runs in 32bit mode (i think because of the nforceata.kext)

im using nvenabler.kext

i dont have any other issues with my video performance, for example i play CS:Souce and Batman: Arkham Asylum without a glitch!


so i think the problem is on flash player only! any other idea?


thanks for reply!


Also some Flash games i tried in FB run very well!

Share this post

Link to post
Share on other sites

Have you done patching yet? ; http://www.osx86.net/desktops/14304-guide-use-more-than-4gb-ram-amd-32-64-bit-apps-working.html

Most of the issues i had were fixed by patching some system files. (I use 64-bit mode aka "-force64")

I would suggest to backup your files before doing that. I don't think it harms your system, but just in case ;-)

Maybe this could also help you : http://www.insanelymac.com/forum/index.php?showtopic=253773


Btw. you can easily check if you're on 32 or 64-bit. Open "Activity Monitor" and have a look on the right side. Does it say "Intel (64 bit)" or just "Intel"?


Greetings : assoricks :-)

Share this post

Link to post
Share on other sites

i dont think i can run in 64bit because AppleNForceATA.kext is 32bit only, whenever i try to boot in 64bit mode it load superVIAATA.kext and i get still waiting for root device! any other suggestion besides 64bit?


(im on 32 bit, i run uname -a and it says kernel i386)

Share this post

Link to post
Share on other sites

64-Bit mode on AMD isn't good. You can't run 32-bit apps on it. Boot with "arch=i386 -force64". System itself runs on 32-bit, but you're able to run 64-bit apps. You'll probably have to run Safari in 32-bit mode.




EDIT: And you don't need 64-bit compatible drivers too ;-)

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Mr.Darkwraith
      Is it possible to install/run Android TV/x86 on the 1st generation Apple TV?
    • By sl0wtarget
      Disk Warrior shot up a hardware error ("5, 1502" whatever that means) with my boot drive yesterday and now I'm wondering, in the process of replacing this drive (because hardware failure will be complete failure with hard drives), if there's a way to create a bootable installer thumb drive with NVIDIA's WebDrivers so I can actually see a screen.
      Also, I'm hoping that after a clean installation I can use my Time Machine backups to get my system back to where it was? TIA for your patience.
    • By garnerlogan65
      I've been trying to figure this out for a few days now, without any success. A couple days ago now, I noticed that my system had rebooted and my Clover entry said that it was trying to boot macOS from a hibernated state, which didn't work. Ultimately however, I got it to boot once I selected "Cancel hibernate wake," but once I did this, the graphics driver would not load, requiring me to reinstall the driver, and having to boot with both NvidiaWeb and nvda_drv=1, it seemed like it was finally back to normal. But it just kept freezing after a while, no matter what, it freezes after I login every time, until I restart it, only for it to do so again. I've tried wiping the drive and reinstalling the OS, along with the GPU driver, but it still freezes every single time after I log in to the system, I have no idea why it is or how to fix it. Other people seem to have no clue either. The fact that it is persisting after a reinstall is concerning.
      It was working completely fine before a few days ago. I'm lost. I'm looking for any suggestions as to how I can solve this. Are there any logs I should grab that could shed more light on the situation?
      EDIT 1: System seems fine when Nvidia web driver isn't loaded. Removed nvda_drv=1 from clover boot flags, NvidiaWeb variable is not working for some reason. Currently no hardware acceleration. Also fails to load driver with just nvda_drv flag.
      EDIT 2: Fixed GPU acceleration by re-running Clover installer, and selecting "Install all RC scripts on target volume." Now to see if it still freezes on me. Using just nvda_drv=1 flag.
      Edit 3: Still seems to freeze, just not as quickly. All signs point to an Nvidia web driver issue, but I'm not sure how to fix it.
      Edit 4: Have been using it for a significant amount of time without freezing, at this point, I'm assuming the window server has been intermittently dying, if it happens again, I'll attempt to remotely kill it via ssh and see if that fixes it.
      Edit 5: Tried restarting WindowServer. System UI is still frozen but ssh access is present. 
      Edit 6: Fixed the issue by completely wiping the drive including the EFI partition, and configuring it slightly different, reinstalled everything. Haven't had a single issue since. Last reinstallation attempt was done via recovery partition, re-making the installation USB and using that seemed to have an impact.
    • By nico3469
      Hey guys
      Here is my little guide to install OSX 10.6.8 on the EeePC 1000H.
      I'll quote some of the CicciMTS and scenemusic topics, thank you guys.
      What is needed ?
      A Asus EeePC 1000H
      A 8GB or more USB Pen drive
      An empty hard disk drive
      An other mac or hackintosh
      A USB mouse
      My package of tools, including the latest Apple OS X 10.6.8 Combo update
      Restore and Boot from USB
      On your mac/hack, go to Disk Utility, find your USB Pen drive, erase it with GUID Partion Table and Mac Extended Format (journaled). Then, restore your iAtkos image on your USB pen drive.
      Next, you need to make your USB drive Bootable. Find Chameleon in the tools Folder, open it and install it on your new Snow Leopard USB pen drive.
      Boot into BIOS, if available, set the SATA mode to AHCI. If you can't it should work too so don't worry
      Select your USB Pen Drive and boot on it. Chameleon will appear, select your iAtkos install drive, and type -v to boot in verbose mode. After a moment, the OSX installer should appear. Trackpad will not work so plug in a usb mouse. Select your language and click next. on the top of the screen, find disk utilty, and erase your HDD with GUID Partion Table and Mac Extended Format (journaled) options, and close Disk Utility. Click Next until the installer ask you on which drive you want to install OSX. Do not install it yet, click on Customize. Select the following options :

      USB (all)


      SATA/AHCI or INTEL SATA/IDE if you didn't enable AHCI in your bios





      GMA950 (all)

      Ralink RT2860

      Click OK and install OSX on your HDD.
      First Boot and update to 10.6.8
      Remove your USB stick from your computer, Chameleon should appear, boot your new OSX installation with -v boot flag. Once you've created your account you should be on your desketop.
      Run the Combo Update installer but do not reboot!! Force Quit out of the installer (hold down the Option key and click and hold over the Installer icon in the Dock. Select Force Quit) and Run the Legacy Kernel installer and then reboot the machine.
      now you should see that your graphics driver doesn't work anymore. Run Kext Utility and let it repair the permissions and update the cache. when it says "all done" drag and drop all the graphics kext into kext utility, and when it says "all done", reboot your computer. Cross your fingers and reboot your computer. You should now have a fully working EeePC 1000H, with graphics, sound, wifi, USB, bluetooth and Ethernet Working with the lastest Snow Leopard update. You can have the latest security updates on your system with Software Update, it will not damage your installation.
      Sorry for my bad english, I'm french. Fell free to ask questions if you need, thank you guys