Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
JBX

[Solved] F12 to Open/Close tray? (see page 4)

76 posts in this topic

Recommended Posts

Forget about a vanilla solution. Jmicron kext wont be updated untill the next OS release next summer. The one /w the version 1.0 has been in the system since 10.6 through 10.7.4 and never updated. Apple just forced them to release an update for ML. Its a 3rd party kext anyway, why have extra trash in your system? At least this is my approach.

Share this post


Link to post
Share on other sites

Forget about a vanilla solution. Jmicron kext wont be updated untill the next OS release next summer. The one /w the version 1.0 has been in the system since 10.6 through 10.7.4 and never updated. Apple just forced them to release an update for ML. Its a 3rd party kext anyway, why have extra trash in your system? At least this is my approach.

I agree, I think MacPro 3,1 was the last supported mac to have PATA anyway so it will likely be dropped before it ever gets another update

 

 

Link needs to be updated

not working

 

tks

Here you go, just a good thing to have as part of your standard tool kit

lspci.zip

Share this post


Link to post
Share on other sites

lists your pci devives that may not show up otherwise in osx to get additional info that may be needed to enable them properly, like device and vendor ids, etc. similar tool to kexstat or ioreg

Share this post


Link to post
Share on other sites

ok. tks

lists your pci devives that may not show up otherwise in osx to get additional info that may be needed to enable them properly, like device and vendor ids, etc. similar tool to kexstat or ioreg

 

Ok! tks!!

Share this post


Link to post
Share on other sites

I don't understand how to fix this... can someone please explain what info I need to edit in which file?

Share this post


Link to post
Share on other sites

If you want to use ESB2 as mistudio did above, find SATA section in your DSDT and edit it adding device ID:

				   Device (SATA)
					{
							Name (_ADR, 0x001F0002)
							Method (_DSM, 4, NotSerialized)
							{
									Store (Package (0x02)
											{
													"device-id",
													Buffer (0x04)
													{
															0x81, 0x26, 0x00, 0x00
													}
											}, Local0)
									DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
									Return (Local0)
							}

DVD player and keyboard to eject will work and no orange icons on sata drives. Although there is more to it than just an "orange icon fix", that is what you will find it is often referred to as in DSDT patch/editors. Verify your own device address for SATA before adding, mine is at 0x001F0002 or 00:1f.2 in lspci

Share this post


Link to post
Share on other sites

@eep357, I appreciate your help

 

I have installed and ran Ispci and for SATA I get:

 

00:1f.2 SATA controller [0106]: Intel Corporation 82801IR/IO/IH (ICH9R/DO/DH) 6 port SATA AHCI Controller [8086:2922] (rev 02)

 

I noticed when I open my DSDT and look under SATA (for 0x001F0002) I see "device-id" already listed at line #4448. Is this correct or do I add/change the entry? sorry I'm newbie at this, I tried to edit it but got errors every time. If you get chance can you please take a look at it. I've attached the file.

jb_dsdt.zip

Share this post


Link to post
Share on other sites

@eep357. replaced and re-booted but still not working.

check system profile/sata and see what is listed as the controller. ICHx, generic or ESB2?

Share this post


Link to post
Share on other sites

Also latest version of Fabio's Enoch branch of Chameleon includes a module to address this issue referred to as "yellow icon fix". In the installer, choose customize to install it.

Share this post


Link to post
Share on other sites

update chameleon using latest Enoch branch and yellow icon fix, however DVD Player was not fixed when I restarted. After another restart...

 

I have a different problem now. Somethings a mess with Chameleon and I can no longer boot my ML HD. I have Chameleon on it's own partition. Will try and fix (I'm in Win 7 HD atm).

Share this post


Link to post
Share on other sites

Fixed my boot and back in ML. I think the newer boot loader installers mess my system up. Anyway is there a way to get the fix for DVD Player and Eject without using those installers?

Share this post


Link to post
Share on other sites

Hello, i need a help...

 

before i instaled the ML my eject button works fine but now at ML it wont work.

 

i have Apple Keyboard Wireless.

 

Please some one help me.

DSDT.aml.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×