Jump to content
InsanelyMac Forum
I-Heine-I

New G5 casemod: best postition for motherboard?

Recommended Posts

I am currently working on a G5 ATX conversion but I have one thing which I yet have to decide. I really want to keep the stock look on the back of my G5. But the problem, of course, is the fact that fitting the motherboard directly to the back of the case will force you to cut out space for the motherboard I/O panel. Thinking of this, I came up with the idea of placing the motherboard slightly to the front of the case (so the PCI cards will not be mounted directly to the rear slots). When a GPU is installed, I could simply use a DVI bracket with a DVI extension cable attached to extend the video output to the rear slots.

 

Common version

21muwbc.jpg

 

Alternative

huje43.jpg

 

A DVI bracket:

2z7mxc9.jpg

 

This might work, although I have two major concerns:

- I am planning to use a high power GPU (ATI HD5850) in this build. The GPU blows out it's heat at the back of the card, through its mounting bracket. When placing the back of the GPU in the case, the GPU may not be able to blow all it's heat out of the case. This may be solvable by making a air duct which extends to the back of the case to guide the heat out of it. I would also replace the stock expansion slot brackets with ones with ventilation holes.

- Is it okay to fit a pretty heavy GPU just to a PCIe-slot, instead of also attaching it with a screw to the case? I'm slightly worried about the amount of weight which will be put on the motherboard because the GPU is not attached to the case itself.

 

I am planning on using a Gigabyte M-ATX motherboard with this build.

 

I would really appreciate any feedback, thanks in advance! :D

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Similar Content

    • By gachogavacho
      Hello everyone!
       
      I've been using the following hardware for some time now:
      GA-H77N-WIFI
       
      CPU:  i7-3770 (LGA 1155)
      Video:  integrated Intel HD 4000 via HDMI  (About this mac: Reporting Intel HD 4000 1536MB)
      Storage: SSD Samsung 850 Evo 250GB
      Apple native support Wifi card (can't find the model at the moment)
       
      Presently I have 10.12.6 installed.
       
      I upgraded months ago to 10.12.3, and at that time, I had an old VGA monitor connected to the DVI input via a VGA to DVI adapter. The computer would start up and the resolution would be fuzzy. Somehow, I discovered if i unplugged the monitor and plugged it in, the resolution would fix. Since we left the computer on always, I didn't think much of it. I had posted about it and tried to see if anyone could give me an idea as to why it was doing it but no real answers came through.
       
      [sTILL NOT WORKING AT FULL REZ] Now, I discovered recently that Apple has said they don't support 3rd party adapters and VGA, so I upgraded to a new monitor:
      LG 25UM58-P 25-Inch 21:9 UltraWide IPS Monitor 
       
      [THIS IS FIXED, THANKS!] I also upgraded to 10.12.6 before installing the monitor. The computer starts up using the usb install drive when i select my installation. But the video still looks fuzzy. I'm attaching a picture. https://goo.gl/photos/YsdM7KfE54WRE52D8
      What do you think i'm missing? EFI folder attached.

      edited to include IoReg file. 
      EFI.zip
      Send me gachovacho's iMac.zip
    • By jgperson
      Here is my build in its current form. I absolutely love this project as it has grown! All hackintosh install instructions were found at Ryzen Clover Installation Guide macOS Sierra - AMD - InsanelyMac Forum
       
      First thing to know is that two of these systems were built at the same time. One for my buddy to use for his YouTube channel (See the video here for the twin system https://youtu.be/rRW4c1FnRrE), and mine. He called me up with an idea, to build a water-cooled Ryzen hackintosh inside of an old PowerMac G5 case, and as soon as he said the idea I was hooked. I have always loved the PowerMac G5 because when it came out, I liked to edit photos and it was what I thought at the time was "The Ultimate Machine". So here are some pictures of how it came about. 
       
      I picked up two PowerMac G5s (both working mind you) in case I messed anything up on the first one. I did not so now I still have a working PowerMac G5. Lol.
       
      Starting off we have disassembly. Note that I don't have a lot of pictures of this progress as I have impulse control issues and wanted it apart ASAP. lol. This is a challenging computer to take apart but well worth doing as this case is amazing! The case I had was pretty beat up with scratches and stuff so I had to do a lot of sanding to get them out.
       

       

       

       
      After disassembly, I took to a small test fit by placing an old mother board in the case to figure out where to cut out for IO in the rear of the case. A quick sharpie line and some dremel time were in order after that.
       

       

       
      Following the IO I cut out the side panel for my piece of acrylic. Using the existing frame that holds on the door of the case, I marked 1/2" in from the inside edge of it and drilled holes in all the corners so they would be rounded. (remember that at this point you want to drill your holes with a 1/2" drill bit and make it so the outside of the bit matches up with your lines.) Then cut the acrylic sheet to fit the inside of the frame (not your cutout).
       
      From there you need to use a jigsaw to cut along your lines and connect your 4 holes that you drilled.
       

       
      Then on to paint. I sanded all the pieces with an orbital sander then used a can of primer and did 3 coats of primer on them all. Followed up with a few coats of black. I added a coat of clear to just try to keep it a little more durable but I should have just done more coats of black. To finish off the case, run some edge moulding around the side panel cut out and attach your acrylic sheet to the side panel with double sided tape. Re install your side panel frame and you are good to go!
       

       

       

       
      To mount the motherboard, I used the existing standoffs from the PowerMac G5 case (be careful here as there are two different heights of standoffs). Add in some JB weld on the base of them and a small coat around the outside of them it was ready to go. I used a GPU to line up where it goes in the case.
       

       
      Now for the final assembly. I test fit a bunch of different hardware placements but what I ended up settling on was the PSU at the bottom mounted with double sided foam tape.  All of the cables were then run up the front side of the case along the motherboard mounting tray and grouped together using zip ties. It is also important to know at this point I bought a cable from Black CH mods to use the existing IO on the front of the case with an ATX motherboard. Radiator at the front with pump/res combo unit mounted to it using the EK uni bracket. I secured the radiator to the front with car grade double sided emblem tape. If you have ever used this stuff you know it is not going anywhere. I reused the existing hard drive cage from the case and secured it to the top also using emblem tape.
       
       

       
      One of the most important steps in this process is the running of tubes (since it is watercooled and all). There are only 4 tubes in this build thanks to the plethora of fittings I have in the case. I don't know if I listed them all but any time you do a hardline watercooled build it is important to have a handful of rotary 90s and dual rotary 90s on hand. I tried to do it without them in my last version of this build using the NZXT H440 and couldn't get my tubing runs to look like I wanted.
       

       
      Fill up the system, leak check, then hook up the power and you are good to go. I added in a RGB light strip and hooked it up to the ASUS aura sync header for a little bit more color. This process was a long time coming and took almost a month from idea phase to final assembly.
       
       

       

       

       
      I spent a long time without a working home PC but man was it worth it! Thanks for reading!
    • By crazyeye1
      Hello guys, I just got a Power Mac G5 complete desktop and I would love to tear it down and install all new hardware and make the best hackintosh I could possibly create.
      I removed all the components and decided to keep the drive bay, bluetooth and wifi wires (maybe I'll toss them) and screws (why not!?)
       
      The only thing this case is missing is the side panel, its gone and was gone from when I found it, as well as the G5 heat sink cover (damnit!)
       
      Does anyone know where I could get a replacement cover or would I have to design and fabricate a cover from scratch? Any help is appreciated of course and I had no idea where to post this question considering all the main forums didn't quiet fit so I apologize in advanced.
       

    • By Emphasising
      Hey all,
       
      I recently just finished my first ever Hackintosh build and am extremely happy with it apart from one major issue..
       
      The specs:
      Intel Core Skylake Processor i5-6500
      Gigabyte H170N-WI-FI Motherboard
      Crucial Ballistix Sport LT 16 GB Kit (8 GB x 2) DDR4 2400
      Corsair 550W CS550M
      Samsung 850 EVO 250 GB
      Broadcom BCM94352Z DW1560 Wireless-AC 867M WiFi Bluetooth 4.0 NGFF M.2 Card (being shipped)
      OSX El Capitan (not sierra)
      NOTE: I'm using integrated GFX as I don't want to spend anymore just yet on a GPU but maybe in the near future!
       
      I followed ammulder's guide on installing El Capitan and everything is working apart from my Display Ports. I have a HDMI plugged in (top HDMI port on mobo) and works fine it's just when I have my other monitor hooked up using either the other HDMI provided or DVI port I get a complete blank display and my other monitor is still working as normal.
       
      I tried other guides, few different tweaks and even hotplugging but that doesn't seem to work. I also tried taking the HDMI out of the working port and inserting it into another HDMI or DVI and that doesn't seem to work either.
       
      Please help me as I would highly appreciate it and would love to be using this amazing build with 2 monitors instead of 1. 
       
      Regards, Emphasising
    • By FBarcenas
      I have an Nvidia 750 TI with 1DVI 1VGA and 1 HDMI. I'm running clover and Nvidia Web Drivers. I don't see anything in Clover Configurator that I recognize related to changing the display port.
       
      Thanks in advance for any help that can be lent.
×