Jump to content
PumaTechTV

Re-Branded Atheros AR5007 ( AR242x / AR542x ) not working on Snow Leopard

8 posts in this topic

Recommended Posts

UPDATE 3- I actually figured out something, thanks to the help of LatinMcG. What appears to be wrong is that the card is rebranded to a brcm subid. The problem now is, what is an apple compatible, and compatible with my card, b/g only subsys ID's. I dont know where i can find subsystem ID's, so if you could give me one for my card, or atleast point me to the right direction, that'd be awesome.

 

UPDATE 2- It seems that my previous hypothesis was invalid. I fixed my computer to load the wifi card at startup and it loads it properly on both windows 7 and ubuntu; however when i try to boot it into snow leopard, it desn't even see the card. Please help, im getting desperate.

 

UPDATE- I belive i (partially) found the problem! The hypothesis is that my card isn't starting when my computer is starting. For example, my card should start up, or turn on, or atleast enable wlan, during the BIOS screen; If not, before Snow Leopard starts up. I figured this out when i went on ubuntu. I had to press the wireless button to enable wireless. The new question now is: How do I make my wifi card so start up during the BIOS, or before Snow Leopard starts?

 

Hey guys! I successfully rebranded my card (ar5007) using iHack13 's guide. When I installed 10.6.1, 2, or 3, A kernel panic would occur. I was able to fix these kernel panics, involving the kexts AirPortBrcm4311.kext and AppleTycmeDriver.kext by going into single mode or windows and deleting them from there. The thing is, that after i successfully boot, my airport card is not recognized. My card should work OTB but it doesn't. Not even system profiler can see it! But how can it not see something that is branded ad an Apple AirPort card? the sub id's are 106b:4e and the card is a b/g only card

 

Here is my lspci -vvnn:

02:00.0 Network controller [0280]: Atheros Communications Inc. AR242x / AR542x Wireless Network Adapter (PCI-Express) [168c:001c] (rev 01)
Subsystem: Apple Inc. Device [106b:004e]
Physical Slot: 1
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 17
Region 0: Memory at d2600000 (64-bit, non-prefetchable) [size=64K]
Capabilities: [40] Power Management version 2
	Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
	Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit-
	Address: 00000000  Data: 0000
Capabilities: [60] Express (v1) Legacy Endpoint, MSI 00
	DevCap:	MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 <64us
		ExtTag- AttnBtn- AttnInd- PwrInd- RBE- FLReset-
	DevCtl:	Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
		RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
		MaxPayload 128 bytes, MaxReadReq 512 bytes
	DevSta:	CorrErr- UncorrErr+ FatalErr- UnsuppReq+ AuxPwr- TransPend-
	LnkCap:	Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <64us
		ClockPM- Surprise- LLActRep- BwNot-
	LnkCtl:	ASPM Disabled; RCB 128 bytes Disabled- Retrain- CommClk+
		ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
	LnkSta:	Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
Capabilities: [90] MSI-X: Enable- Count=1 Masked-
	Vector table: BAR=0 offset=00000000
	PBA: BAR=0 offset=00000000
Capabilities: [100 v1] Advanced Error Reporting
	UESta:	DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq+ ACSViol-
	UEMsk:	DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
	UESvrt:	DLP+ SDES- TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
	CESta:	RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr-
	CEMsk:	RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr-
	AERCap:	First Error Pointer: 14, GenCap+ CGenEn- ChkCap+ ChkEn-
Capabilities: [140 v1] Virtual Channel
	Caps:	LPEVC=0 RefClk=100ns PATEntryBits=1
	Arb:	Fixed- WRR32- WRR64- WRR128-
	Ctrl:	ArbSelect=Fixed
	Status:	InProgress-
	VC0:	Caps:	PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
		Arb:	Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256-
		Ctrl:	Enable+ ID=0 ArbSelect=Fixed TC/VC=01
		Status:	NegoPending- InProgress-
Kernel driver in use: ath5k
Kernel modules: ath5k

 

 

I can supply with any pictures or logs from terminal/verbose mode needed. I have access to ubuntu and windows+transmac if needed.

 

Thanks in adavance

 

Here are my computer specs:

hpg50specs.png

Edited by PumaTechTV

Share this post


Link to post
Share on other sites
Advertisement

Did you delete only the bcm4311 plugin or the entire IO80211family.kext? And if not, finding out why the broadcom plugin was causing KP may lead to the solution

Share this post


Link to post
Share on other sites

Did you delete only the bcm4311 plugin or the entire IO80211family.kext? And if not, finding out why the broadcom plugin was causing KP may lead to the solution

 

Thanks for your reply! Ionly deleted the bcm4311.kext .... I actually figured out something, thanks to the help of LatinMcg. What appears to be wrong is that the card is rebranded to a brcm subid. The problem now is, what is an apple compatible, atheros chipset, b/g only subsys ID's. I dont know where i can find subsystem ID's, so if you could give me one for my card, or atleast point me to the right direction, that'd be awesome.

 

Thanks in advance,

-PumaTechTV

Share this post


Link to post
Share on other sites

what is currently after rebranding the device, vendor and sub sys ID's?

 

I have AR5008 in my MacBook and also in my Hack, same apple card. Vendor ID is 168c, but device ID's will be different, your's "probably" 001c. Not sure on sub

Share this post


Link to post
Share on other sites

Before rebranding-

device id's- 168:1c
sub id's: 103c:137a

 

After rebrand-

device id's- 168:1c
sub id's- 106b:4e 

 

And i just encountered a new problem. On Ubuntu, i can no longer change the id's. When i change the sub id's to 106b:87 (or 106:0087 they are theoretically the same) in the EEPROM it only updates the EEPROM, but when i do:

lspci -vvnn

it gives me the same id's as before, which would be 106b:4e

Share this post


Link to post
Share on other sites

From lspci in OSX (AR5008)

Network controller [0280]: Atheros Communications Inc. AR5008 Wireless Network Adapter [168c:0024] (rev 01)
Subsystem: Apple Computer Inc. Unknown device [106b:0087]

 

your device ID is missing the "c", in your last post, but is present in your OP

Share this post


Link to post
Share on other sites

he has AR5bxb63 i believe = junk. G only.

rebrandables are AR5bxb62 and AR5bxb6 .. all 3 use 1C device id.

 

go with AR5B91 = N Draft .. not plain b/g

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By ITzTravelInTime
      Hi guys, this thread is to show you a new and open source app, created by me, that I called TINU:
       
      The name means: TINU Is Not #####, the U refers to a popular software that is used to create Mac OS hackintosh installers (that for good reasons is banned on this forum), but the aim of the name is to explain that this app is a totally different thing from that software and works in a totally different way.
       
      This app basically is a graphical interface for the createinstallmedia executable that is inside the Mac OS installer apps, it is capable to create a Mac OS installer on a drive completely vanilla like what you do using the command line method, and also this method is recommended by apple itself. In addition to this, this app provvides also to you some customization features and a better management of the hall macOS isntall media creation process
       
      Allows you to create easily a macOS install media without messing around with command line stuff and without using disk utility, all you need to do is use the app and then install clover on the usb drive once TINU has finished or leave it as is you want to use it on a Mac.
       
      Features:
        - Simple to use UI that allows you to easily start the macOS install media creation process
        - It can work with every Mac OS installer app that has the createinstallmedia executable inside of it's resources folder (including also beta and newly released installers)
        - You can use any drive or partition you want that can be erased and is at least 7 GB of size
        - Works on Mac OS recovery, so you can create a macOS install media from a bootable macOS installer or from the macOs recovery, and you can use TINU to install macOS too.
        - All vanilla, the macOS install medias created with this tool are 100% vanilla, just like you created them using the command line "createinstallmedia" method in the terminal, with also some extra optiona features
        - Open source, you will know what this program does on your computer and also you can create your own version by downloading and playing with the source code
        - Does not requires to do anything of special first, just open the program
        - No need to go in disk utility first, TINU can format your drive for you
        - Uses recent and more modern APIs and SDKs and Swift 3 language
        - Transparent graphics style available (use alt + s on the keyboard or View->Use transparent style)
        - Works using the latest versions of macOS and will also support newer Mac installers out of the box without needing for an update
        - Advanced section, to customize your macOS install media
        - Installer customization: Kernelcache/prelinkedknerel and boot files replacement (a feature that can be handy while dealing with old Macs or with beta installers when you need to mod or change the boot files some times)
        - Clover EFI folder installer
       
        Features that are planned for some future versions:
        - Integrated EFI partition mounter tool (TINU can already mount EFI partitions from version 2.0, but a dedicated section which allows to mount every EFI partition in the system will be added)
        - Install clover and configure clover
        - Install kexts inside the kexts folder of clover
        - Clover drivers customization
        - Use custom dsdt in clover
        - integrated pre-made clover config templates database from a remote and open repository
        - Support for other languages, at least Italian   Rquirements:  - A computer that runs Mac OS X Yosemite or a more recent version (Mac OS X El Capitan is required to use TINU in a macOS recovery or installer)  - A drive or a free partition of at least 7 GB that you want to turn into a macOS/Mac OS X installer  - A copy of a macOS/Mac OS X installer app (Maveriks or newer versions are supported) in the /Applications folder or in the root of any storage device in your machine (excepted the drive or volume you want to turn into your macOS install media)   Note that this app is under the GNU GPL v3 license so any reuse of the source code must follow the license's terms   Latest stable TINU release:   Download the app:                                https://github.com/ITzTravelInTime/TINU/releases   View the source code:                            https://github.com/ITzTravelInTime/TINU       Frequently asked questions about TINU:  https://github.com/ITzTravelInTime/TINU/wiki/FAQs     NOTE: if you have problems with your USB installer of 10.13.4 or newer version not being detected by clover you have to use the latest clover and if it still does not detectets your usb installer you have to remove the invivible file called .IAPhysicalMedia located into the root of the usb installer. This issue is caused by a changement in the apple's createinstallmedia, don't blame TINU for that, TINU does only uses the installer creation method from apple, which has been changed by appleitself, causing this problem for hackintosh users some times, this issue should be resolved in the latest versions of clover which will no longer require that you do changements to let your usb dive to be detected, a setting to do this fix automatically in tinu is also present TINU in the adavnced settings, starting from the version 2.0 of the app. I leave also some screenshots as well
       
       
       
       
       
       
       
       

    • By Insanelymac_user_abc
      Is it possible to install an older OS X.5 Leopard or OS X.6 Snow Leopard Hackintosh system on a modern i7 processor PC?  
       
      I need to to run either of those systems using an Intel Core i7-4770K Quad-Core Desktop Processor on a Gigabyte GA-Z87MX-D3H motherboard.
       
      I saw this post where someone said “Clover 32Bit should boot Leopard as well, using Legacy mode. You will need 32bit kexts as well.”  https://www.insanelymac.com/forum/topic/331457-bootloader-for-leopard/ .. Would that be valid advice for me to follow up on for my configuration?  I see that Clover 32 bit is no longer in development.. https://www.insanelymac.com/forum/topic/317521-good-bye-clover-32/
       
    • By MateusPT
      Hi there.
      Soo i was trying install mac at 4 days ago and finnaly today i can. I installed the Leopard and all works fin except the keyboard and ps2 mouse. And then i try a lot to put a .kext with transmac on windows xp cause im dual booting it.When i try to use Transmac i have the error"This drive is read only".
      Who i fix this?! This is my first question!
      The second i think is more hard. I have a Amilo Pro V3505 with 2gb ram and Intel GMA 945, a Intel Pentium T2130 idk the motherboard i aleardy try find the name but i couldnt with a Atheros ar5007eg wirless adapter.
      So i instal iAtkos S3 v2 but when i was booting(after installing) it he boots and starts make the sound of the animation video of snow leopard but THE SCREEN WAS GREY WITHOUT THE APPLE LOGO AND WITHOUT THE MOUSE JUST A GREY SCREEM.
      Well i try much flags but when i try GraphicsEnabler=No while the booting appears i recuve the message "you need to restart the computer" and i restart and gives again the same error.
      I think is some missing kext graphical but i cant add/remove kexts cause transmac give error!
      Thanks in advanced!
×