Jump to content
InsanelyMac Forum
Sign in to follow this  
uzmi

(SOLUCIONADO) Problema con wifi N en tarjeta TP-LINK TL-WN851N

Recommended Posts

Hola:

Tengo una tarjeta wifi TP-LINK TL-WN851N ( http://www.tp-link.c...model=TL-WN851N ) que era reconocida perfectamente tanto en Lion como en Snow.

Hace unos días atrás aumenté la velocidad de conexión a internet y me cambiaron el router y ahora permite wifi N.

En Seven 64 navego sin problemas pero en Lion a pesar de reconocer la tarjeta y tener una buena señal cuando abro safari se queda congelado.

Muestra la barra como que va a cargar la página (por ejemplo google) pero no avanza, tampoco da error alguno.

 

 

87806088.jpg

 

 

 

56728964.jpg

 

 

 

diaggj.jpg

 

 

Si bien es cierto que actualicé a 10.7.4 también sucede con 10.7.3.

Probé con otro navegador (Chrome) y pasa igual.

Probé con otra red (una abierta sin contraseña) y tampoco funciona.

Reinstalé desde cero y el problema persiste.

 

A continuación dejo algunas imágenes que quizás puedan aportar mas información.

 

 

ior1.jpg

 

 

 

ior2.jpg

 

 

 

ior3.jpg

 

 

 

pciu.jpg

 

 

 

redql.jpg

 

 

 

wifit.jpg

 

 

Si alguien puede orientarme acerca de como solucionar esto, estaré infinitamente agradecido ya que después de intentarlo por mi cuenta, aun no he sido capaz de lograrlo.

 

Un saludo y gracias.

Share this post


Link to post
Share on other sites
Advertisement

Hola, yo también tenia este problema e he sulucionado usando un dns free i ahora me va bien.prova esto.

post-333439-77592_thumb.png

post-333439-43911_thumb.png

Share this post


Link to post
Share on other sites

Gracias iFIRE y Derty por vuestras respuestas:

De momento probé ambas cosas y sigue sin funcionar.

Como ultimo recurso voy a llamar a R (que es mi proveedor de internet) aunque ya se de antemano cual será su respuesta:

" Lo siento solo damos soporte para Windows" malditos sectarios, el servicio es impecable (caro si pero a prueba de todo) pero no entran en el terreno de Mac.

 

Un saludo.

Share this post


Link to post
Share on other sites

Prova borrar IO80211Family.kext y instalar de nuevo los kext de la tarjeta

 

EDIT:No lo borres :blush: el IO80211Family.kext, solamente los pluguins Atheros y usas este en x32, luego probas si te va en 64 :whistle:

AtherosFix.kext.zip

Share this post


Link to post
Share on other sites

Prova borrar IO80211Family.kext y instalar de nuevo los kext de la tarjeta

Entendí bien? Borrar qué? Compañero, esa tarjeta es 100% compatible, es decir que funciona con los drivers de Apple (sin instalar nada más), por lo tanto en lo absoluto es una opción lógica que borre la IO80211Family.kext, porque esa extensión es precisamente la que lleva TODOS los drivers (.kexts) de inalámbricas nativas AirPort. La de Uzmi (pci168c,23), por ejemplo:

Captura de pantalla 2012-05-30 a la(s) 21.01.44.png Captura de pantalla 2012-05-30 a la(s) 21.06.24.png Captura de pantalla 2012-05-30 a la(s) 21.00.56.png

Uzmi, deberías probar inyectando "de manera correcta" en la DSDT los dos (2) IDs nativos de Apple como vendedor y subsistema. Los míos por ejemplo:

Captura de pantalla 2012-05-30 a la(s) 22.25.44.png Captura de pantalla 2012-05-30 a la(s) 21.15.45.png El "built-in"= 0x00 (integrado) también es efectivo en Lion, al menos en portátiles.

En mi caso el dato clave es el 8F, porque es el que se debe inyectar en las tarjetas recientes que levantan el driver - firmware "AtherosNewma40".

 

Y en tu caso, te pego unas capturas de una MacBook2,1 (2006) genuina que lleva una Atheros (pci168c,24) muy similar a la tuya, mira los datos que vas a inyectar (87 "o" 86 en lugar de 8F) porque tu inalámbrica levanta el mismo driver - firmware "AthrFusion21":

 

Captura de pantalla 2012-05-30 a la(s) 21.22.35.png Captura de pantalla 2012-05-30 a la(s) 21.38.54.png

 

Espero que sea de ayuda. Saludos.

Share this post


Link to post
Share on other sites

Hola Juanerson:

Gracias por tu respuesta.

Este fin de semana me pongo manos a la obra con el dsdt y cuento que tal me ha ido.

Un saludo

Share this post


Link to post
Share on other sites

Hola, yo también tenia este problema e he sulucionado usando un dns free i ahora me va bien.prova esto.

 

Hola:

Como siempre antes de preguntar trato de solucionarlo por mi cuenta.

Esto significa que revuelvo, modifico, agrego, quito cosas en Lion a ver si logro resultados.

Siempre trato de hacerlo con un poco de criterio de acuerdo a mis conocimientos.

 

Había probado lo de cambiar los DNS y no funcionó. Sin embargo luego de varios reinicios dejó de reconocer el hardware (la tarjeta wifi) por lo que sospeché de algún "mal dedazo" mío.

Reparé permisos y tal, y volví a probar el cambio de DNS y esta vez si funcionó, así que voy a intentar hablar con mi proveedor a ver si me aclara algo mas.

 

Muchas gracias por tu respuesta.

 

Uzmi, deberías probar inyectando "de manera correcta" en la DSDT los dos (2) IDs nativos de Apple como vendedor y subsistema.

 

 

Hola:

Hace algún tiempo atrás solicité tu ayuda en Nosolo... para hacer el hack correcto en el DSDT de mi tarjeta wifi y muy acertadamente (como siempre) me diste la solución, por lo que estaba convencido de tener el DSDT bien.

Es verdad que en dicho hack no tengo ni ID nativos de Apple ni los originales de la tarjeta en si, pero siempre me funcionó sin problema alguno.

Pensaba retocar de nuevo el DSDT pero visto que cambiando los DNS (por los que menciona iFIRE) ahora si puedo navegar, deduzco que el problema es con el proveedor de internet.

 

De todos modos gracias por tu tiempo.

 

Un saludo.

 

P.D. No dudo que con un poco mas de tiempo haré las modificaciones al hack a ver para probar.

Share this post


Link to post
Share on other sites

Bueee... es que inyectar seis (6) líneas y compilar NO es trabajo de más de 5 minutos.

 

Además, aclaremos que la vez pasada en nosolohd te orienté para inyectarla y que fuera reconocida en el perfil del sistema (la ruta), nada más.

 

Con los ID de Apple en muchos casos se mejora la recepción y la conexión en general responde mejor. Es lo mismo que haría un rebranding por hardware desde un live cd de linux, para que te la reconozca como una genuina de cabo a rabo, pero mucho más sencillo desde la DSDT, es la ventaja de las Atheros.

 

En fin, lo damos por solucionado. Saludos.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×