Jump to content
pmdci

VMWare or VirtualBox - Which one has better audio/video performance?

8 posts in this topic

Recommended Posts

Hello there,

 

I currently have Mac OS X (10.7 Mountain Lion) running under VMWare Workstation 8 on Windows 7. I have 16GB of RAM and I dedicated 4 to MacOS X

 

At first I wasn't very happy with the video performance. But after getting some SVGA II drivers here at Insanely Mac, I reckon the video performance is alright considering is a Virtual Machine.

 

 

What I am looking for is a VM that would give me a fair 2D and at least some general audio playback capability (something tells me running Logic Pro under a VM would never be a good idea).

 

I can't stop but wonder whether VirtualBox would be better than VMWare, mainly because with virtual box there aren't any hacks I must do in the virtualization software to run Mac OS X. I mean, with VMware I had to "unlock" Mac OS X as a guest OS option. Plus, perhaps I am wrong but I believe that it would also be easier to get audio and video? working at a better performance, since I reckon that Oracle thelselves would be working to provide decent drivers for Mac OS X under Virtual Box.

 

Before I venture into trying to run Mac OS X under VirtualBox just for the sake of comparison (and risking wasting some precious time when I could be doing something more productive, like playing The Witcher 2 or diablo 3 :thumbsup_anim: ) I would rather "hear" what the community here has to say. What do you guys reckon?

 

Also I never ran ######. on my Mac OS X VM as I thought this is only really necessary in "physical" (as in non-VMs) Mac OS X installs. But I have a feeling that I might be terribly wrong :)

 

Any suggestions / recommendations are greatly appreciated. I am a total "noob" in the hackintosh scene. So my appologies in advance :angel_not:

 

Cheers!

P.

Share this post


Link to post
Share on other sites
Advertisement

Do you mean 10.7 Lion or 10.8 Mountain Lion?

 

From what I know, VMWare presents an emulated actual graphics card to the VM, and I believe there are ways to get QE/CI (hardware 3D acceleration) on VMWare. However, on VirtualBox it presents it's own virtual graphics card to the VM, and since there are no guest additions for Mac OS X it is impossible to get QE/CI working. QE/CI is essential to many parts of the OS, so I think it might be a no-brainer. :)

 

On VMWare, you will have to install a boot loader and drivers afterwards. However, I would not use [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] on any system, virtual or not. :P Quite unreliable. I would simply find the boot loader and drivers manually.

 

I personally believe that it if you need to have Windows and OS X, it is more profitable to arrange a dual-boot rather than a VM, because when it runs in a VM it is not quite like native (particularly games), but I would use a VM only if I absolutely had to run both OSes at the same time. OTOH, it might be more profitable to run Windows in a VM on OS X... :rolleyes:

Share this post


Link to post
Share on other sites

Neither product can do QE/CI. VMware presents its own graphics card. VMware does have audio. However the simple answer is forget playing games on a virtualized OSX environment, probably wont work and not worth spending the time trying.

Share this post


Link to post
Share on other sites

Hi PookyMacMan (cool nick btw)

 

Thanks a lot for your help and patience with my noob questions :)

 

Yes I meant LION, not Mountain Lion (sorry). I reckon I will get the 10.8 when the RTM is out.

 

I reckon by combining what both you and Donk and you said below, VMware seems to be the "keeper". I installed Mac OS X 10.7 using a "template" VMware that was already configured to boot. It seems to work fine and I didn't have to do any further modifications with regards to booting.

 

However I am pretty sure that future system updates might "break" this predefined boot loader configuration and I might need to patch the VM up for it to keep working. In fact I tried an update the other day and my Mac OX VM hanged on the grey apple logo after reboot. Thank heavens I took a snapshot so I reverted the mess.

 

Now, when you said that you use ####### on any system, did you intend to say that you would NOT use it? Where could I get the bootloader and re-apply it in case I need before/after a system update?

 

Also, how is the audio working for you guys under a VMware? I got some audio driver I found whilst crawling through Google but I am not sure I got the latest or the best one out there. Any pointers? :)

 

Thanks for all the help!

 

P.

Share this post


Link to post
Share on other sites

Use my Unlocker for VMwareall posted in this forum. No need for anything other than retail copy of OS X.

Share this post


Link to post
Share on other sites

Yes, I meant do NOT use [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]! :D Me and my typos...

 

You can google for Chameleon packages and for your proper drivers.

 

Is this a retail installation? Updates shouldn't break the system...

Share this post


Link to post
Share on other sites

oracle provides no drivers what so ever but virtualbox is free and has a load of features so it's my {natural} choice.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By JohnOl
      Hi,
       
      I've just upgraded to OSX Catalina from Mojave on my VMWare Workstation 15.5, running on Windows 10.
       
      The Sidecar feature is there, and after connecting my iPad Pro 12.9" 2018 running iPadOS 13.1.2 via USB cable, it is recognized as a display device in the Sidecar preferences.
       
      However, when I enable it, the Sidecar screen on the iPad is completely black / blank. I can't send anything over, and if I mouse over the green + on an app window (i.e. Safari) to move it to the iPad, nothing happens and the screen remains blank. The sidebar will only appear after I turn it off and on again at Catalina's Sidecar preferences. The buttons there actually work. For example, if I move Safari over to iPad, the screen is blank, but if I activate the on-screen virtual keyboard and type there, the text actually goes to the Safari's search bar (the Safari still appears on the desktop).
       
      Is this a compatibility issue with VMWare, where Catalina can't properly recognize the second screen? I've tried changing host VM settings too, i.e. to "host setting" or 2 monitors, enable / disable 3D acceleration, nothing works. the iPad is definitely correctly connected, as I can browse / backup its data at the Finder.
       
      Can anyone please advice on how to enable Sidecar properly in VMWare? Thank you.
       
      Below is a screenshot of how it looks like on my iPad:

    • By MSoK
      This is the current version of VMware Tools for OS X / macOS from the VMware CDS repository for Fusion 11.5.0
       
      VMware are no longer including the ISO images as separate "packages" in the CDS respository as of Fusion 11.5.0, instead the ISO images are included as part of the "core" download which is 522 MB.
      It is not possible to download the com.vmware.fusion.zip.tar due to upload limits.
       
      However, I have extracted the darwin.iso and darwinPre15.iso from the "core" and uploaded to this thread.
       
      If you prefer to download the "core" tar file and extract the ISO's they are located in the following directory in the tar file:
       
      com.vmware.fusion.zip.tar\com.vmware.fusion.zip\payload\VMware Fusion.app\Contents\Library\isoimages\
       
      Please note: In the latest VMwareGfx.kext from Fusion 8.5.5 onwards VMware have discontinued the 2D-Acceleration code, and graphics performance is better now, thanks to Zenith432 for the update.
       
      To check for the latest version visit http://softwareupdate.vmware.com/cds/vmw-desktop/fusion/.
       
      The various VMware Tools downloads are located under the packages folder for each version upto and including 11.1.0.
       
      Instructions for extracting darwin.iso and darwinPre15.iso
      - Download the files above
      - Extract com.vmware.fusion.tools.darwin.zip.tar
      - darwin.iso is located in the "payload" folder
      - Extract com.vmware.fusion.tools.darwinPre15.zip.tar
      - darwinPre15.iso is located in the "payload" folder
    • By technosinner
      Hi guys,
       
      I need help with my Sapphire RX580 8GB. It works and I have it connected to a BenQ EW3270U (4k monitor through DP), but I noticed that the quality of my video is not exactly great; I just don't feel like it's up to spec with some fuzziness and everything just isn't as sharp as I expect it to be. It's hard to explain exactly what I see, but especially when there's transparency in windows for instance, I see what I would compare to colour compression artifacting in the gradients of the images showing through the transparency effects. It looks like a video with fading on Youtube but the compression makes it look like waves of pixels as opposed to a real gradient, if that makes any sense? It's impossible to film or photograph properly, and - the part that gets me - if I do a screenshot, it's not visible! I must have been super tired when I posted... it's visible on screen shots after all (see attached). It screams graphic acceleration issues to me but I really am at a loss on how to diagnose this issue further. It's not unusable or anything, but I want to get it to work properly and get as much as I can out of it all.
       
      As a comparative I did plug in a Retina MBP to the monitor to make sure it wasn't the issue and as expected, I did not see any of this with the MBP.
      I have Lilu and WEG in my 10.14 kext folder, and my (shameful) config is attached, but I more than likely am missing something important...
       
      All this explained, I want to point out a few things: this is an old machine (built 2012) and I had the same config throughout with exactly 0 issues. This is one reason why I not only never had to optimize it, but I now also pretty much fell off the Hackintosh bandwagon: I am not exactly well versed in all the technical backend of this community as I was until now lucky with a plug and play machine with no issues.
       
      I will need a lot of help to get back up to date... that said I also had incomprehensible and undiagnosed issues getting the RX580 to work on this machine. Even if it was effortless for everyone else, I had to do a LOT of troubleshooting and in the end, I have no clue how I got it to work! So I'm mortified of changing anything on it without getting some advice first since everything, iCloud and iMessage included, works. I'll be happy to fill in any info and I'm hungry to learn. It's just a bit daunting to start over and my searches have discouraged me a but. I know beggars can't be choosers but I have a 60-hour a week job and I just need a bit of guidance if anyone wants to help me off my training wheels  I fully know I'm in a bad spot and quite frankly I'm ashamed of it. Help me make it better please.
      config.plist



    • By lestercamp234
      Ho da poco installato High Sierra sul mio computer, ma da subito ho notato che non si sente niente. Ho Realtek ALC887.
      Come faccio a sistemare?
×