Jump to content

Atom/ION Install?


gusz
 Share

2 posts in this topic

Recommended Posts

I have a Zotac IONITX-D-E motherboard, which uses Intel Atom 330 CPU and Nvidia ION 9400 graphics, with a Seagate Barracuda 7200 1 TB 7200RPM SATA 6 Gb/s NCQ 64MB Cache hard drive. I am aware that OSX 10.6 can be installed for this motherboard per the thread http://www.insanelym...howtopic=197516, but the method described on that thread requires using another OSX system to set up the HDD for the target, which other system I do not have (I do have Linux and Windows PC systems). So my problem is how to accomplish my Zotac OSX install without using another OSX system.

 

I've set SATA to AHCI in the BIOS and tried alternative methods, such as using iBoo t Legacy to boot my Zotac, thereafter using my OSX 10.6 retail install disk with various boot options such as cpus=1 busratio=12 arch=i386 maxmem=2048 -f -v. Twice it actually started the install, but then it stalled before completing. Most of the time it stalls before starting the install, with error messages like those shown on the attached screen photo. The key messages seem to be

 

AppleUSBEHCI: start unable to initialize UIM

SerialATAPI device reconfiguration did not complete successfully

AppleAHCIDiskQueueManager::setPowerState timed out after ...

Still waiting for boot device ....

 

To me it looks like the problem is accessing the hard drive to do the install, but in any case I'd appreciate info on what's wrong and how to fix. Also some specific questions .....

 

-I know my Atom 330 CPU is not supported by OSX 10.6, tho I believe iBoo t Legacy does support Atom (?). Does the iBoo t Legacy kernel replace the 10.6 kernel on the hard disk during the install?

 

- I tried setting the BIOS for Legacy USB to possibly cure the "AppleUSBEHCI: start unable to initialize UIM" error, but I don't know if it worked, or even if the error is relevant, since thereafter my USB keyboard/mouse didn't work so I couldn't start the OSX install. If I should go back to the USB Legacy BIOS setting, what type of keyboard/mouse will still work?

 

-Is it possible that the Seagate hard disk I'm using is the problem? If so is there a boot/OSX config fix I can use, or ... what type of disk or specific disk do I need to use?

 

Thx, Gus

 

 

post-862297-0-49636200-1337790386_thumb.jpg

Link to comment
Share on other sites

  • 2 weeks later...

I'm surprised that iBoo t legacy got mach_kernel to load. prior to 10.6.2, atom was supported. But if you're doing retail disk, you need to load mach_kernel with atom support compiled in. Search for that, and try to restore the retail install bits to a USB or ISO image but add in a new mach_kernel_atom to the top level directory for the Mac OS X Install image. When you boot into iBoo t and you have a disk selector, select the Mac OS X install and then type "mach_kernel_atom -v arch=i386" on the boot loader command line. This should pass the options and load the correct kernel. I've used this on Zotac IONITX and Asus AT3N7A-i systems with success.

 

And if you had issues identifying the disk to install (especially new ones without a GUID partition table and Mac Extended FS Journalled) then simply select Utilities menu item along the top bar when you get the install window, and pull up the diskutil and search for disks and erase the drive and put in a GUID partition map and label name for Mac Extended FS Journalled and then exit the diskutil. The installer should now find the disk to install on. I can't vouch for all IDE drives - which may need some IOATAFamily.kext modification put into ./Extra/Extensions on the installer. But for SATA/AHCI capable systems, that seems to usually work with iBoo t.

Link to comment
Share on other sites

 Share

×
×
  • Create New...