Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

SL 10.6.8 - USB Storage Devices

2 posts in this topic

Recommended Posts



Hi, I've recently managed to get OS X SL up and running on my AMD PC. I've been able to overcome most problems myself but this one has me a bit lost.


This thread in a nutshell: Upon updating to 10.6.8, USB mass storage devices are not recognised, while peripherals are.


Specs are as follows:

  • ASRock 970 Extreme3
  • AMD Phenom II X4 960T Quad Core
  • 8GB Kingston HyperX Genesis RAM (using maxmem=4096 to avoid CPU halt)
  • Bunch of old Seagate 80GB HDDs (SATA set to AHCI)
  • PowerColor Radeon HD6850 1GB
  • Installed Snow Leopard 10.6.2 Hazard

Okay, so I managed to install Hazard's 10.6.2 DVD. I then followed a guide to update to 10.6.8. In this guide, it suggested you use ####### to install "IOUSBFamilyRollback" (back to the 10.6.2 USB I imagine).


On reboot, everything worked, graphics acceleration, sound, ethernet etc. Apart from USB. It worked fine in 10.6.2, but now it's just not working at all. USB mouse and keyboard work fine, no problems with them, but devices such as USB HDDs and memory sticks just aren't recognised at all.


After extensive searching, I found some other people with similar problems. One guy tried installing a newer IOUSBFamily.kext, however this didn't work for me. Another used the flags "USBLegacyOff=Yes" and "USBBusFix=Yes" which worked for him. Another possible solution was to remove "AppleHPET.kext" as it may be conflicting. This didn't work for me either.


In BIOS, I have USB 2.0 and 3.0 enabled, with USB Legacy on. I'm starting to tear my hair out over this, so if anyone has any possible solutions please do share!


Many thanks in advance,



Share this post

Link to post
Share on other sites

Fixed my own problem - For anyone having a similar issue:


I deleted IOUSBFamily.kext from S/L/E and ran ####### and selected "IOUSBFamilyRollback" from the selection menu. Upon reboot, USB worked fine!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By ITzTravelInTime
      Questo è il thread in italiano dedicato alla mia app TINU, l'app open source che ho creato per creare chiavetta di installazione di mac utilizzando il metodo "createinstallmedia".
      Il nome è l'acronimo di TINU Is Not U (Per le regole del forum devo censurare, ma la U si riferisce ad un programma che piu o meno svolge lo stesso scopo che che per buoni motivi è bandito su questo sito, il punto del metterlo nel nome sta nel sottolineare che la mia app è totalmente divera)
      L'app è pensata per essere molto semplice ed immediata da usare (con un interfaccia grafica progettata con criteri e metodi usati in ambito professionale per lo sviluppo di applicazioni utente) e per essere molto solida e stabile che funziona sempre al primo colpo (a differenza di altri tool che conosciamo ...)
      A livello funzionale quest'app non è altro che un interfaccia grafica per il metodo da terminale "createinstallmedia" che viene sfrutatto dalla stessa per creare la chiavetta, quindi le chiavette create con TINU sono chiavette al 100% vanilla come se le aveste create dal terminale, a questo l' applicazione aggiunge funzioni utili come la formattazione automatica della chiavetta USB che si sceglie di usare in formato Mac OS Extended (journaled) (detto anche HFS+) con mapatura di partizione GUID.
      Tra gli altri vantaggi troviamo il fatto che permette di creare chiavette utilizzando qualunque applicazione di mac che contiene l'eseguibile "createinstallmedia" inclusi installer delle beta ed installer appena rilasciati, e non richiede di fare cose particolari prima come formattare la chiavetta e cambiare lingua al sistema e puo utilizzare applicazioni di mac che si trovano in vaie directory nel sistema e non solo quelle sche stanno in applicazioni ed hanno un nome specifico (nota che l'applicazione di installazione di mac deve essere quella interacche pesa diversi gb e non quella da pochi mb che l'app store puo scaricare alcune volte e che contiene tutto quello che serve per permettere a createinstallmedia di funzionare)
      l'applicazione è completamente aprta ed open source e trovate qui alcuni link utili:
       - Scarica l'app: https://github.com/ITzTravelInTime/TINU/releases
       - Repo github di TINU: https://github.com/ITzTravelInTime/TINU
       - FAQs (in inglese): https://github.com/ITzTravelInTime/TINU/wiki/FAQs
       - Thread in inglese su tinu (English thread about TINU): http://www.insanelymac.com/forum/topic/326959-tinu-the-macos-install-media-creation-tool-mac-app/
      Qui invece ci sono un paio di guide (Anche se l'app è molto facile da usare):
       - Piccola guida su come usare TINU per un hackintosh: https://www.youtube.com/watch?v=fZOZOUt2ErM
       - Piccola guida su come usare TINU per creare cheiavette per Mac "originali": https://www.youtube.com/watch?v=fZOZOUt2ErM
      Attualemente è in fase di sviluppo una nuova versione di questa app che verrà rilasciata a breve e che include diverse novità e migliorie importanti.
      Per chi se lo chiede, il supporto a clover in TINU è pianificato per una versione futura, anche se dei protipi a livvello codice per renderlo possibile, sono gia stati sperimentati con successo.
      Spero che anche voi del forum italiano aprezzerete questa app come gli utenti del forum inglese, per idee e suggerimenti, siete liberi di esprimervi :-)

    • By hguandl
      I used BCM943602CS for my Hackintosh. On High Sierra, the WiFi works well, however, the bluetooth doesn't work. I cannot find the bluetooth icon on the system preference pane. From the system report, I can see that the Device can be recognized as 'Bluetooth USB Host Controller'. From IORegistryExplorer, I've found that the device for it has a UsbConnector value of 0x0, which is weird. And the IOResources part says the device is not built-in. I don't know whether it has something to do with my MSI B350 Tomahawk (an AMD platform) motherboard. If someone has some advice, please help me out.

    • By MikixIT
      Salve a tutti ho installato OSX, Sierra 10.12.6 (16G29), grazie a questo forum
      Ho installato tutti i Kext necessari da Nvidia a quelli per l'audio HDMI,ethernet ecc..
      L'unico problema che  Mouse e tastiera USB collegati ad un hub FUNZIONANO, mentre senza hub usb non funzionano nelle altre porte, NELLE ALTRE PORTE PERO' FUNZIONANO PEN DRIVE USB,ho provato vari kext in rete mentre il Forum era in manutenzione
      Ma non riesco a farli funzionare su altre porte,vi allego La mia EFI( http://www.mediafire.com/file/mimomvp1on4ys58/EFI-MikixIT 12%3A03%3A2018.zip) E vari screen del mio OSX con info varie

    • By haegar33
      I have browsed thru all forums and all threads for this card but apparently my system is still something special. With some cumbersome effort (none of the simple one-click ##### and other USB-Installers methods ever worked for me) I managed to install Sierra 10.12.5. However when booting is nearly finsihed I get the famous black screen which can be recovered by quickly unplug/plug the DP monitor cable leading finally to a proper initialisation of my 290X. 

      1.) RadeoDeInit is on, without this patch the screens stays dark forever
      2.) Booting with iGFX never works for me, I always get memory allocation errors during boot until I disable the Intel graphics completely.
      3.) I am on Clover 4318, newer version do not make any differences.
      4.) I am using a System Configuration for an Imac 14,2. Most other configs do not make difference either.

      I have not started again the nightmare of Framebuffer patching (as I remember from Yosemite) and I think it will not help as the card is recognised by Sierra but just not initialised.