Jump to content

iAtkos L2 on HP p6230it post-installation: GRUB2, npci=0x2000 and sleep problem


2 posts in this topic

Recommended Posts

Sometimes ago I tried to install Snow Leopard (by Hazard) on my PC, and I had it updated to 10.6.2. Something wasn't working fine, but its boot was perfect, no need for boot flags, and, most of all, GRUB2 was able to boot.

I explain: my hackintosh partition is a logical one, so Chameleon/Chimera aren't able to get loaded from there. I have Ubuntu on the PC, so I booted a Live CD, chroot'ed into it and ran update-grub and grub-install /dev/sda, at least to be able to boot the other OS's. Unexpectedly, GRUB2 had also recognized Snow Leopard and added an entry for it in the menu, and selecting it the system would boot just fine.

And also, the sleep/wake worked like a charm.


Now that I have installed iAtkos L2 in the same partition I have GRUB2 recognizing it, but when I try to boot it reboots without a word (that means, no error messages, no lines, it seems to me that grub doesn't reach OS X but it did with Snow Leopard), so I have to boot from the installation DVD, that is a pain. And, if I try to make OS X go to sleep, it shuts down the screen, but doesn't go to sleep: when my PC goes to sleep (or when I put it in standby, on other OS's) the LED in the power button turns yellow, as it did on Snow Leopard, but now it stays blue, and the video card fan gets at full speed (it always does when the video driver is not on, that means, booting and shutting down, on every OS). Once not-sleeping, the mouse has no power (laser is off), and the keyboard powers if I press a key, but nothing else happens. I've thought I could find the kexts involved in going to sleep and downgrading them to the Snow Leopard versions, but I don't know which ones to downgrade.

Plus, I have that annoying [PCI configuration begin] if I boot without npci=0x2000, that seems much a workaround to me. Is there a way to fix this problem at its root?

Link to comment
Share on other sites


  • Create New...