Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
Craig Pettigrove

App store and facetime not working on my Lion Hackintosh Build!

7 posts in this topic

Recommended Posts

I realize this is a very common occurrence and there is lots of posts regarding this issue, however I just can't get this fixed. I have spent hrs reading about this issue and numerous tweaks to get this done, but nothing has worked.

 

Here is what I know: I can log into Itunes. My network interfaces file does say true. Is the facetime server error and not being able to log into the App store the same type of problem.

I am running Lion 10.7.4. Everything is working great except these two problems. I would really appreciate it if someone could give me some suggestions from the beginning. Let me know what other information you need. I hope the below info is helpful.

 

 

NetworkInterfaces.plist

<key>Active</key>

<true/>

<key>BSD Name</key>

<string>en0</string>

<key>IOBuiltin</key>

<true/>

<key>IOInterfaceType</key>

<integer>6</integer>

<key>IOInterfaceUnit</key>

<integer>0</integer>

<key>IOMACAddress</key>

<data>

UOVJyVqz

</data>

<key>IOPathMatch</key>

 

org.chameleon.Boot.plist

 

 

<key>Kernel</key>

<string>mach_kernel</string>

<key>Kernel Flags</key>

<string>npci=0x2000 darkwake=0</string>

<key>GraphicsEnabler</key>

<string>Yes</string>

<key>Timeout</key>

<string>2</string>

<key>Legacy Logo</key>

<string>Yes</string>

<key>EthernetBuiltIn</key>

<string>Yes</string>

 

/Library/Preferences/SystemConfiguration

 

.com.apple.plist

 

 

<key>Kernel Flags</key>

<string></string>

<key>device-properties</key>

Share this post


Link to post
Share on other sites

I'm experiencing the same problem. Which bootloader along with version are you using? I've read that this may be solved with updating or reinstalling the bootloader. In addition, you can try to remove NetworkInterfaces.plist from //Library/Preferences/SystemConfiguration and reboot. Need to also confirm the Ethernet is (en0). Though this did not work for me, it did solve the problem for many others.

 

Much like you I have found numerous tweaks or suggested solutions, but have yet solve this issue. Currently I can only connect via Wifi, since I don't have Ethernet, which is making it much more difficult to isolate the problem or test suggested solutions.

 

Hope to hear additional recommendations.

Share this post


Link to post
Share on other sites

Currently I can only connect via Wifi, since I don't have Ethernet, which is making it much more difficult to isolate the problem or test suggested solutions.

Sorry to tell you this but there are no solutions to test and nothing to isolate, it is widely documented that EN0 must be a wired ethernet device, if you only have Wi-Fi it will never work for you.

 

/EDIT

Word has it that this will work with a wi-fi device if it's recognized as an airport. I haven't seen anything conclusive, but it seems to work for some people. There are not enough details available (that I've seen) in order to determine why it doesn't work for everybody..

Share this post


Link to post
Share on other sites

Thank you Gringo! That's not the best news, but appreciate the definite answer thus I can end my search.

 

Craig: It may benefit you to view the following thread:

 

http://www.insanelymac.com/forum/index.php?showtopic=271917&st=0&p=1770590&hl=facetime%20error&fromsearch=1entry1770590

 

And review the attachments to view the changes made and hopefully it will provide you with the solution to this problem.

 

Thanks again, Gringo. I'll look into purchasing a new compatible NIC.

Share this post


Link to post
Share on other sites

I know about the en0 problem since i had it on my last install. I remember finding a rather long workaround to reassign the numbers so ethernet was en0. This time I avoided the problem by being sure to install my ethernet before my wifi.

 

But my question is this: What about real macs that have no ethernet port like the new MBA? There must be some way that they connect to FaceTime, iCloud, etc. Is there a reason this is a hackintosh specific problem?

Share this post


Link to post
Share on other sites

I was stuck also on this, and nearly to give up ... until I tried again with Champlist (the current latest version: 2.4) to generate a new smbios.plist .

 

Supposedly my Dell XPS 8300 was being detected as a MacPro 3,1 (altough the processor was not the same I have). On previous installs I was generating smbios.plist for this Mac model, on this last install I decided to select the most similar features to my Dell from Champlist , then generated the new smbios.plist and after doing this, rebooted and then I could log-in to the AppStore.

 

Hope this helps someone

 

In my case I went to buy a TP-Link TL-WDN4800 wireless adapter for having a wireless connection detected as Airport (which was) hoping to solve the problem with accessing the app store (it didn't). Then found the driver for my on board ethernet; it was also detected.

 

Don't know if the combination of the above had something to do. I did try first solving network-related issues with no luck on fixing the AppStore issue. The smbios.plist thing was the last resource to try.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×