Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

Inspiration and ideas to continue G5 mod

1 post in this topic

Recommended Posts

Hi guys,


I've been lurking on the forums for a while and started slowly building my own g5 mod since the beginning of the year. I didn't want to spend a huge amount of time on it but still wanted it to be neat and functional and look good.


I've reached the point where the pc is completely operational, however there are some issues I would like to address, and I would like to still improve on it.


Just some back ground and thoughts. Here are some picks of the case once I got it:






I initially wanted to mount a mATX mobo inside the case not touching the sides so that I could keep the external ports, but soon realised it would be better to mount it right on the extension card slots, since the back ports wouldn't be functional anyway.


I did want to take out the internals of the PSU and replace it with my PSU internals, but I thought I would rather keep the PSU together for when I would ever need to replace or upgrade it in future. I play around a lot with hardware so I want everything to be replaceable.


For the life of me I couldn't figure out how to remove the drive bays at the top, or the mounting pins on the back of the case, so I've left them in there. I created my own mounting plate which then goes on the existing mounting pins and then lines up to the extension port openings.


I rewired the front panel and have everything working correctly except the firewire port.


I bought a 4-port usb extension which is enough for me, and I will be using a wireless ethernet card to connect to the network.


I broke my beloved ATI 4870 while moving hardware to and fro between my old case and the new one which was depressing, but it did give me incentive to upgrade. I got a budget 6850, which is suitable to my needs.


Here is the mod as it is at the moment:

















The things I would like to improve upon are:


- Would like the back sound ports working (currently using the front panel), though not entirely sure how to go about it. It would be nice to match them to the existing ports, but it doesn't seem possible without rewiring stuff to the old mobo (which might need to be the way to go)


- The case gets very hot just below the cdrom, probably from the 3d card and lack of fans. I need fans at the front and the back of the case. Unfortunately due to the way the mobo is mounted I can't fit the existing back fans to the back of the case. I was thinking of using smaller fans? For the front fans I might just fit one of the old fans to a modified middle seperator.


- Neaten up the wiring by fitting a cover over the old PSU case, however cutting a hole so that the existing PSU pops out. Unfortunately the 6850's power port points towards the outside which is a bit silly and I can't place the plastic air cover over everything.


Otherwise the PC is completely functional at the moment. What do you guys think?



Extra info about me and my pc:

I'm from Cape Town, South Africa and I'm a software developer. My PC is a i5 2500, 8gb ram and 6850. It's not currently running OSX (My downstairs pc is running osx and I have a macbook air) but I plan to dual install OSX and windows 7 once I can afford a large SSD. (I play a lot of games, but do all my development on OSX, so I want to be able to switch between the two quickly, I may just leave it using only windows 7 and just do all my dev on my laptop, like I am currently)

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Mr.Darkwraith
      Is it possible to install/run Android TV/x86 on the 1st generation Apple TV?
    • By Angelo_
      Hi guys, i'm trying to help a friend of mine trying to install osx(possibly high sierra) on his pc with the following specs: 
      Amd fx8350 
      Asrock 990fx extreme 3
      8gb of fury Kingston ddr3 ram(2x4)
      Radeon hd 7950
      128gb ssd( crucial m550)
      A couple of hdds I don't remember the brand(maybe a seagate barracuda and a dumb old disk for data)
      We tried to install it using the regular clover+high showers installer but we couldn't get it to reach the installer, then we tried osx-amd(don't know if i can talk about it there, sorry if i can't) and we still couldn't get to the installer.
      Is there a guide i can use to install osx in that machin, i tried to search in the forum but i couldn't find it.
    • By lucasrm654
      Eu instalei o Hackintosh, porem uso um Cougar 200k, meu teclado, e a tecla shift, windows e alt não funcionam, não executam função nenhuma, já o Ctrl funciona como Shift, gostaria de saber como eu posso atribuir funções a essas teclas que não fazem nada e mudar a função do Ctrl.
    • By Dallastyle
      Hello Insanelymac,
      I've successfully installed Mac OS X Sierra on 2 32gb flash drives with them as a JBOD Raid. I can only get into the hackintosh if I use another USB flash drive with Clover installed on it. I've tried using a clover installer however that just installs on my Raid Disk. I've also noticed that when I open clover configurator, there are 2 EFI partitions but both of them were empty. I've tried moving the contents of the EFI on my Raid disk that clover installed but my BIOS does not detect it. Also when I use the other flash drive to boot into clover, there is another volume called "BOOT OS X" right next to my Raid Disk Volume that I use to boot from. I just want to install and boot off of my Raid usb flash drives. Really running out of options, Thanks guys.
    • By Zsparrow0
      NOT WORKING   SD Card Reader (Use USB adapter ) Hibernation Nvidia Graphic Cards Fingerprint Reader Thunderbolt HotPlug REQUIREMENTS   Fresh installation One working OSX environment Whole disk available (No partitions) Knowledge in PLIST edition Backup Made (EVERYTHING WILL BE ERASED) Latest BIOS version 4k sector patch NVME WIFI CARD DW1560 (EFI FOLDER CONTAIN PATCH FOR THIS CARD ONLY)     1 - CREATE USB     Download High Sierra from AppStore Plug in your USB Key (16GB or More) Format it with Disk Utility and name it « MyVolume » Launch Terminal and type : sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/MyVolume Mount the EFI partition /MyVolume/EFI/ with Clover Configurator (See in the EFI Folder) Copy the entire EFI folder linked to the post to /MyVolume/ 2 - BIOS SETTINGS   MAKE SURE EVERYTHING IS CORRECT BEFORE CONTINUE OR IT WILL FAIL ON BOOT !     System Information          Check that Video Memory is already 64MB       Advanced Boot Options (all off)        System Configuration      SATA Operation (AHCI)      Drives (all on)      SMART Reporting (on)      USB Configuration (all on)      Dell Type-C Dock Configuration (on)      Thunderbolt Adapter Configuration (all on, no security)      USB PowerShare (on)      Audio (all on)      Touchscreen (on)      Miscellaneous Devices (all on except SD Card Reader)      CPU XD (on)      Secure Boot        Secure Boot Enable (disabled)      Intel Software Guard Extensions        Intel SGX Enable (Software-Controlled)      Performance        (Everything on/enabled)        Power Management        (USB Wake Support = off)      (Wake on Dell USB-C Dock = on)       Wake on WLAN (off)      Block Sleep (off)        Virtualization Support        (Everything on)    3 - BOOT PROCESS
        Start your computer and press F12 to open the boot menu Boot from your USB Key Select the "Installer from (Your usb key)" (Verbose mode is enable by default to see what's going on if it fail)   -----------------------------------------------------------------------------------------------------------------------------------------     WAIT ! EVEN IF YOU THINK THAT THE LOADING BAR IS STUCKED IT COULD TAKE 5MIN TO LOAD ENTIRELY     IF IT FAIL SEE THE REHABMAN GUIDE BEFORE ASKING QUESTION     IF YOU CAN'T BOOT YOU CAN TRY TO USE A FAKE IG-PLATFORM GO TO THE CLOVER OPTION IN THE GRAPHIC PARTS AND USE A FAKE IG-PLATFORM SUCH AS 34567898764   ----------------------------------------------------------------------------------------------------------     4 - INSTALLATION   - Once arrived on the installation screen - Open Disk Utility and Erase your Main Hard Drive and format to : MacOS AFPS (not encrypted) - Go back to the installer continue and choose your Formated Hard Drive to install MacOS. - The computer will reboot after about 2 min - Press F12 to choose your usb key and hit ENTER   (YOU COULD HAVE 2 CHOICE DURING THE REBOOT : INSTALLER ON "YOUR DRIVE NAME" OR PRELOADER "YOUR DRIVE NAME". You have to use "Installer on your "drive name" in case it FAIL select the OTHER OPTION. You will have to do this twice if I remember correctly.   BE CAREFUL YOU HAVE TO ALWAYS BOOT ON YOUR USB KEY BECAUSE CLOVER IS NOT YET INSTALLED ON THE SYSTEM, SO PRESS F12 ON EVERY REBOOT AND CHOOSE YOUR USB KEY UNTIL CLOVER PROPERLY INSTALLED     5 - POST INSTALLATION   - Open Kext Wizard in My EFI folder - Click on installation tabs browse kext and select ALL THE KEXT IN USB/EFI/CLOVER/KEXT/OTHER - Make sure that the destination drive is your MAIN HARD DRIVE and press INSTALL - Once done go to MAINTENANCE TAB and select the radio button for System/Library/Extensions and press EXECUTE.   6 - RESTART WITHOUT USB   - Disconnect your usb and reboot normally, everything should work properly now.     !!! CONGRATULATION YOU DID IT !!!               if not...       Give us enough clear information in the comments section so we can help you to have this laptop working.   A BIG         TO     Dell for making this laptop Apple for Mac OS RehabMan for so many detailed posts, enormous collection of SSDT files, kext development, and being overall incredibly helpful throughout this whole process KNNSpeed for this amazing guide Pike R. Alpha for his in-depth blog and the 0xE2 patch (among being the source of many other developments and patches) The Clover team for the Clover bootloader netkas, kozlek, and Slice for FakeSMC wmchris for his initial XPS 9550 write-up Jonny4911 for posting his 9560 setup and his version of the AudioFix folder syscl for a lot of work into the XPS 9360 and his build of VoodooPS2Controller darkhandz for his XPS 9550 repo toleda and goodwin_c for audio, ALCPlugFix goodwin_c for HWP dpassmor for the Thunderbolt/USB-C ExpressCard trick vit9696 for Lilu and AppleALC PMHeart for CoreDisplayFixup lvs1974 for NvidiaGraphicsFixup darkvoid for Wi-Fi patches filequit for the 5GHz global channel bonding patch denskop for the "Boot Graphics Glitch" patch netkas, kid2010, and syscl for the Thunderbolt 3 blacklist bypass patch Blazinsmokey for all his good advice and knowledge   AND ALL THE OTHER THAT I DIDN'T QUOTE BUT WHO CONTRIBUTED TO MAKE THIS DREAM HAPPENED !     MORE CUSTOMIZATION   Improve battery life and CPU temperature :   Check the @abn6x Guide : http://www.insanelymac.com/forum/topic/331775-guide-how-to-undervolt-your-haswell-and-above-cpu/     EFI.7z