Jump to content

Reboot at "Starting Darwin x86"


3 posts in this topic

Recommended Posts

Hey all,


With the recent release of the experimental Lion Kernel for AMD Processors. I decided to give it a go, so I booted up Windows, opened Disk Manager and created a 230GB Partition for my OS X Lion install, and then a 30GB Partition for my Mac OS X Snow Leopard install(Required to install OS X Lion). Once that job was completed I then downloaded Hazard OSX(10.6.2) for AMD Machines. Then I downloaded iAtkos L2. Once they were finished downloading I then burned Hazard OSX to a 4.7GB DVD+R Disk at 2.4x While it burned I also transferred iAtkos L2 onto one of the two 8GB USB Flash drives I have. Then once they were both done burning/copying I decided to download the Kexts I needed for Snow Leopard, since I had Snow Leopard Installed previously I knew exactly which Kexts were required. But for Lion I had to do a bit of "Kext Hunting", if you will. After that, I finally took a deep breath and rebooted. The Hazard install went perfect. Very smooth. I installed my Kexts and what not, Rebooted and I had a running Snow Leopard Partition.


From this point I then followed this Guide: [AMD] 10.7.3 Guide - Experimental (Written by Devout)


I opened the OSInstall Package, and proceeded through the install, I selected my OS X Lion Partition and was very careful to not over-write my Snow Leopard partition. The install took from around 10-20 Minutes. I can't remember. Once the install was done...


I replaced the mach_kernel in my OS X Lion root with this AMD Lion Kernel: [AMD] Lion Kernel (V4)


Once done, I rebooted I was presented with Chameleon and I then did a regular boot. This is where my problems began because almost instantly after I booted my OS X Lion partition my Computer Rebooted, and then this just led to a constant reboot loop if I selected my Lion Partition. This peaked my interest as I have never been presented with such a situation. So I booted -v (Verbose Mode) to see what was going on. But I couldn't, the kexts were being loaded way to fast for any human-being to comprehend what was being out-putted onto my screen. I then assumed that this was a Graphics Problem. So I first tried switching video outputs from DVI to VGA. And still, the same thing. Then I decided to switch to my onboard graphics. This time, the kexts were being loaded much slower to the point I was actually able to read them. But what really surprised me was the fact that Lion loaded all the way up to...


"Starting Darwin x86"


I was baffled at this point, and out of ideas. I tried many different boot flags and to no avail. So InsanelyMac Community, I look to you for the answer to this!


My Hardware:

HP P6610F

AMD Athlon II X4 635

Onboard-Graphics: AMD RadeonHD 4200

Dedicated Graphics Card: Zotac 8400GS 512mb

Motherboard Chipset: AMD 785g

Motherboard Brand: Foxconn

Motherboard Model: N/A(Unknown)

Audio: ALC888s-VD(Onboard)

Ethernet: Realtek RTL8105E

4gb DDR3 Ram


Thank you very much, InsanelyMac. Any help is much appreciated!

Link to comment
Share on other sites

Update: When I try booting with the iATKOS L2 Temporary Boot Loader I am able to boot up untill BSD root: disk0s5, major 14, minor 3


Update #2: Booting with -v -x or -v -x -f will allow me to get one line further but then it freezes at USBMSC: (non-unique) Identifier

Link to comment
Share on other sites


  • Create New...