Jump to content
InsanelyMac Forum
naton

A Hackintosh project on an HP/Compaq 610...No QE/CI

Recommended Posts

I've read over a hundred of posts mainly in this forum and to be honest I'm getting nowhere. My laptop specs are on my signature. I used iAtkos L2 (10.7.2). The keyboard and touchpad work perfectly. The webcam and the USBs work too.

 

The sound works but the volume is set to high even when I turn it down using the sound icon. Also the VoodooHDA preference panel is missing. I tired with VoodooHDA 2.6.2, 2.7.2, and 2.7.3.

 

Aside from getting the kexts for the graphics cards to load, I'm not yet concerned about the other devices. I mean let's face it, there is no much point having a hackintosh if QE/CI don't work.

 

I've tried every trick suggested to make my Intel x3100 (2A12) work and I failed. I tried a/ll of the following:

 

1. Not knowing that there are two types of Intel x3100, the 2A02 and the 2A12, I tried these kexts which I've tested on another laptop and they work well on the 2A02.

http://www.osx86.net/view/1673-x3100_gma965_lion_10.7.0.1.2.3.html

 

Basically all the kexts in the above link are from Lion 10.7.0 except for 'AppleIntelGMAX3100FB.kext' which is from Snow Leopard 10.6.8. This didn't work with the HP 610.

 

2. I used an 'AppleIntelGMAX3100FB.kext' from Snow 10.5.8 that was patched to support 2A12. I found it in this forum. This kext loaded. The screen was much brighter than before but it was split into 12 sections. Each section represents an instance of a desktop.

 

3. I used the 2A12patcher. Mac didn't give me a kernel panic but It froze before reaching the desktop. Amongst the displayed text I noticed that Mac was complained about the fact that the AppleIntelFrameBuffer class was already loaded and thus it could not be loaded again from the AppleIntelFramBuffer.kext file.

 

4. After 3 days of reading about what other have done, I decided to patch the kexts, install them and see how it goes. I used the kext from Lion 10.7.0 as a starting point. I patched the info.plist files inside AppleIntelGMAX3100.kext and AppleIntelGMAX3100FB.kext. I also used a HEX editor and patched the binary files inside these kexts. Basically I replaced every instance of 2A02 with 2A12.

Nothing happened when I installed these patched kexts.

 

5. After doing the above I went ahead and patched AppleIntelGMAX3100FB.kext for Snow Leopard 10.6.8 and install it. This time the screen was split into 4 with every section containing an instance of the desktop.

Rebooting with the flag "GraphicsEnabler=No" fixed the split on the screen but I still do not have QE/CI.

 

 

 

What else I can try to get the Intel X3100 (2A12) to work properly?

 

 

Thanks

Share this post


Link to post
Share on other sites
Advertisement
Guest sincro77

Hackintoshed !!! Laptop .--Compaqintosh

 

Anyone who needs help with cheapo hp/compaq with nforce chipset/nvidia graphics/ Amd Turion x2 64.. ]I had trouble ,, every distro would reboot.. tried so many chameleon" boot files until i landed on 'APIC version error '' KP.

 

After scratching my head for a few weeks and installling ubuntu without any problems..Somehow i found a working Cham RC5 boot file!! (working via usb) not ata "yet"...

(tried to patch nforceata with ID-- but error ""says not compatible 10de... at verbose..... ))

 

OMG!! i might be the first.,. nobody seems to have got this one working... Im going for audio and qe/ci now..

will update soon.

 

Anyone who needs help: PM me for now , until i make a guide/how to.. and i will upload a "boot file, etc soon.

 

Hoooray!!!!!! PERSEVERANCE.!!

 

sincro77

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • For me the forum seems quite quick, except whenever I see the word 'LOADING' - like when clicking another page of a thread - when it just stops completely and never returns.   I use an adblocker, so adverts aren't slowing me down.  Browsing the forum indexes is OK, as is clicking to view any thread.  Ditto clicking a link in an email notification to go to a particular post in a thread.   But then whenever I click on any other thread page, which tries to do the in-page content load (without a full page refresh), I see LOADING and then nothing further happens, even after minutes.   It's definitely not related to which content is loaded, but rather how it is loaded.  For example if I go to the index for this forum, then click directly to page 10 of this thread, it loads in a second or two.  But if I click page 10 while in the thread, it never comes back.  I just see this, forever:     To me this strongly suggests something is broken (code or configuration?) rather than a general slowdown of the server.
    • This is as far as I can get with the AMD kexts and the device ID added. They load but the frame buffer isn't loaded. I've tried loading all 7 frame buffers included in the X1000 kext with no luck. From the tests Gigamaxx did there seems to be more luck spoofing as Intel graphics there. More support may come from integrated Vega though, hard to tell.    
    • as documented here it is a sample rate standard and i have also tested it and i can confirm that it works with my audigy rx at least, i have to test it with other cards   https://github.com/audiojs/sample-rate
    • Yes, if i use the EFI folder that I uploaded to the google drive then i do have Intel working properly with QE/CI.
    • ubuntu@ubuntu:~$ sudo -s
      root@ubuntu:~#  superiotool -d
      superiotool r6637
      Found SMSC FDC37N972 (id=0x0b, rev=0x00) at 0x2e
      Register dump:
      idx 02 20 21 22 23 24 25 26  27 28 29 2a 2b 2c 2d 2e  2f
      val 00 0b 00 00 00 00 00 2e  00 00 00 00 00 00 00 00  00
      def 00 0b 00 00 00 04 04 NA  NA 00 00 00 00 00 00 00  00
      LDN 0x00 (Floppy)
      idx 30 60 61 70 74 f0 f1 f2  f3 f4 f5
      val 00 00 00 00 00 00 d1 15  0b 00 10
      def 00 03 f0 06 02 0e 00 ff  RR 00 00
      LDN 0x01 (Power management (PM1))
      idx 30 60 61
      val 00 00 00
      def 00 00 00
      LDN 0x03 (Parallel port)
      idx 30 60 61 70 74 f0 f1
      val 00 00 00 00 00 00 d1
      def 00 00 00 00 04 3c 00
      LDN 0x04 (COM1)
      idx 30 60 61 70 f0
      val 00 00 00 00 00
      def 00 00 00 00 00
      LDN 0x05 (COM2)
      idx 30 60 61 62 63 70 74 f0  f1 f2 f7 f8
      val 00 00 00 00 00 00 00 00  d1 15 00 00
      def 00 00 00 00 00 00 04 00  02 03 00 00
      LDN 0x06 (Real-time clock (RTC))
      idx 30 60 61 62 63 70 f0 f1
      val 00 00 00 00 00 00 00 d1
      def 00 00 70 00 74 00 00 NA
      LDN 0x07 (Keyboard)
      idx 30 60 61 70 72 f0
      val 00 00 00 00 00 00
      def 00 00 00 00 00 00
      LDN 0x08 (Embedded controller (EC))
      idx 30 60 61
      val 00 00 00
      def 00 00 62
      LDN 0x09 (Mailbox)
      idx 30 60 61
      val 00 00 00
      def 00 00 00
      Found SMSC SCH5027 (id=0x89, rev=0x03) at 0x4e
      No dump available for this Super I/O   i was some kind of lucky to dump some information but i am still not able  to dump the sensor chip Ubuntu Dumps.zip


×