Jump to content
InsanelyMac Forum
mastroeny

[Aiuto] Post installazione Lion Retail da USB su Toshiba Satellite A100

Recommended Posts

Ciao a tutti.

Sono riuscito ad installare Lion 1.7 retail sul mio portatile in firma.

La buona riuscita e dovuta anche (e soprattutto!) a Khris801822 che mi ha dato ( e mi sta dando ancora ;-)) una grossa mano.

Ho seguito la guida (http://www.insanelym...pic=258485&st=0) presente nel forum.

Tutto è andato a buon fine. Appena sono riuscito ad accedere alla scrivania ho aggiornato in safe mode (-x) alla versione 10.7.3 con la combo.

 

Ora vorrei ottimizzare l'hack.

 

Nella cartella Extra della penna usb ho sistemato i seguenti kext: fakesmc.kext, evoreboot.kext e NullCPUPowerManagement.kext. In realtà non so se gli ultimi due fossero necessari, ma io li ho messi per non perdere tempo e riuscire ad avviare. Proverò successivamente a toglierli uno alla volta per vedere cosa succede. Alle brutte li reinserisco. (Grazie Khris)

 

Ho installato il kext per la scheda wifi bcm4311 (preso da snow leopard) ed ora è perfettamente funzionante.

 

La scheda video (geforce Go 7300) è riconosciuta nativamente. Non ho dovuto applicare nessun kext, ho solo Graphics Enabler=Yes al boot (il boot lo faccio partire a 32 bit, altrimenti la scheda video mi causa il kernel panic.

Qe/ci sono abilitati, risco a vedere trasparente la barra del menu in alto.

 

Per il touchpad e la tastiera ho usato due kext trovati sul web per lion. Installati successivamente il s/l/e. Per l'installazione del sistema operativo ho usato una tastiera ed un mouse usb.

 

Cose ancora da abilitare:

Sleepenabler (anche se disattivo la sospensione dei dische e del pc, lasciando solo attivo lo spegnimento del video, quando tocco il pad o premo un tasto lo schermo si retroillumina ma non mi mostra la scrivania rimane nero. Succedeva anche in iatkos). Non me lo spego, chiedo aiuto.

 

Lettore Card

 

Etherneth (la mia scheda è la intel pro/100 ve)

 

Audio ALC862 (Per quando riguarda quest'ultimo su iatkos mi andava con voodooHDA v.2.2 (se non erro) ma quando alzavo al massimo screcciava leggermente.)

 

Non ho DSDT. Non so come procurarmelo. Ora studierò un pò l'argomento partendo dalla base, anche se credo che mi servirà comunque l'aiuto di qualcuno veramente preparato.

Share this post


Link to post
Share on other sites
Advertisement

Allora togli sleepenabler perchè se non ricordo male a qualcuno dava dei problemi su lion. Per i due kext ethernet e audio fai una ricerca su google es. alc862.kext e lo stesso fai per la lan. Ora poi mi passi il tuo dsdt in questo modo : apri il terminale e digiti il comando perl -e 'open(CMD, "ioreg -lw0 \| grep DSDT|") or die; while(<CMD>) { chomp; if($_ =~ /\"DSDT\.?\d?\"=<([^>]*)>/) { $buff = $1; open(PIP, "|xxd -r -p > ~/Desktop/dsdt.aml") or die; print PIP "$1"; } }' . Ora dovrebbe essere comparso sul desktop un file dsdt , comprimilo e postamelo qui che gli do uno sguardo e sistemo le cose principali. Poi pro

Share this post


Link to post
Share on other sites

Ok, entro stasera ti inoltro il dsdt. Grazie.

Per quanto riguarda lo sleepenabler io non l'ho ancora installato, immagino tu ti riferisca a quello che lion retail installa in automatico...

Share this post


Link to post
Share on other sites

Lion non installa nessuno sleepenabler, se non l' hai messo non lo mettere sennò sporchiamo la retail. Non installare alcun kext oltre che per l' audio e la lan. Evoreboot non so se ti serva o meno, bisogna vedere dopo l' edit del dsdt. Se il pc già così ti si spegneva e si riavviava correttamente leva pure quello. Poi installi fakesmc anche in S/L/E e ripari la cache... Se hai i kext per audio e lan metti pure quelli... Ora ripari la cache magari sempre da terminale con questo comando

sudo kextcache -v 1 -a i386 -a x86_64 -m /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext /System/Library/Extensions .

Togli anche nullcpu.... cosi vediamo se ti da kernel panic ma non credo. (se va storto qualcosa puoi rimetterlo da iatkos) Ora che abbiamo fatto tutto riavvi e dai il comando per il dsdt e poi me lo mandi... Dopo che hai fatto tutto questo metti il file che ti allego e sostituisci quello che hai già in extra , ti velocizzerà il boot.

org.chameleon.Boot.plist.zip

Share this post


Link to post
Share on other sites

ok allora lo sleep non ce l'ho. Per quanto riguarda l'evoreboot ed il nullcpu li tolgo e vediamo.

ti aggiorno

 

Ancora una cosa. Ho installato in mbr, prendendo i file presenti nella guida. Questo perche ho cercato di formattare la partizione in GUID, ma non mi dava abilitata la possibilità di farlo. Me lo permetteva solo se cliccavo sull'hard disk intero (non sulle singole partizioni), ma questo avrebbe significato piallare tutto....... anche win 7 e iatkos (che comunque era fondamentale) allora ho optato per mbr.

Share this post


Link to post
Share on other sites

Si ma infatti ti avevo detto che probabilmente per formattare guid andava piallato tutto, in mbr non ti garantisco che non dia problemi... A me al tempo in cui iniziai mi consigliarono di piallare tutto in guid e poi fare le varie partizioni di cui quella destinata a windows con fat invece che journaled esteso...Io ti ho rigirato il consiglio perchè sicuramente qualche vantaggio c'è ad avere guid. Comunque poi passami il dsdt

Ti si spegne il pc, si riavvia? Se si togli evoreboot... Nullcpu lo togli x prova, se al riavvio boota senza kernel panic non ti serve a nulla... Tieni poi presente che con il org.c.b.plist che ti ho postato prima i kext te li caricherà solo da S/L/E

Share this post


Link to post
Share on other sites

Ciao Khris,

ho fatto come mi hai detto.

Inserito fakesmc anche il S/L/E.

Ho tolto Nullcpu e evoreboot. Riparato permessi e chace. Tutto ok, si riavvia bene e nessun KP. (Avevi ragione ;-))

L'audio non l'ho ancora messo, ma lo faro al più presto. TI ho inviato il DSDT generato sulla scrivania da terminale.

Ora sono nelle tue affidabili mani! :-)

Buona serata

Share this post


Link to post
Share on other sites

Ciao khriss. Ho in problema, relativo alla retail. All'accensione del pc il bios mi da errore. Devo premere F1, poi si riavvia e parte regolarmente facendomi scegliere il sistema operativo. Con iatkos nn accadeva, come posso ovviare al problema?

Edit: succede solo al riavvio dopo che ho chiuso lion. Se invece avvio windows piu volte di seguito non incontro problemi. Ma appena lancio lion e riavvio... Ancora Errore

Stavo leggendo sul web, pare si risolva con modifica dsdt o con ElliotForceLegacyRTC, giusto?

Share this post


Link to post
Share on other sites

Ciao khriss. Ho in problema, relativo alla retail. All'accensione del pc il bios mi da errore. Devo premere F1, poi si riavvia e parte regolarmente facendomi scegliere il sistema operativo. Con iatkos nn accadeva, come posso ovviare al problema?

Edit: succede solo al riavvio dopo che ho chiuso lion. Se invece avvio windows piu volte di seguito non incontro problemi. Ma appena lancio lion e riavvio... Ancora Errore

Stavo leggendo sul web, pare si risolva con modifica dsdt o con ElliotForceLegacyRTC, giusto?

Si quello è il problema del reset del bios. Te lo risolvo con il dsdt non mettere nessun altro kext... Dammi il tempo di sistemare il dsdt poi te lo passo... Ti avevo anche chiesto se il pc si spegne e riavvia correttamente... Poi domani ti sistemo il dsdt che oggi non sono in casa..

Share this post


Link to post
Share on other sites

Si scusami, non avevo considerato che l'errore de bios potesse derivare dal lion. Consideravo le due cose separate.Pensavo di aver avviato il mouse da USB :-)

Ok, nn ho messo nessun kext, la lascio così fino a nuovo odine ;-)

Share this post


Link to post
Share on other sites

Bene dai ci sentiamo domani...

 

Ho fatto a tempo a editarlo prima di partire...Provalo e fammi sapere se va tutto bene, ovvero voglio sapere se il pc si spegne, si riavvia, va in sleep, se ha risolto il problema dello schermo che non si riattiva e quello del reset del bios...Lo devi mettere all' interno della cartella extra lo sai :wink2:

dsdtmastroeny.aml.zip

Share this post


Link to post
Share on other sites

Buona sera khris,

ho applicato il dsdt. Il sistema operativo si spegne e si riavvia senza problemi. L'errore del cmos del bios è sparito! Grande!

Pero lo sleepenabler non va. Ho provato a attiavare solo lo spegnimento dello schermo, ma niente, si retro illumina come prima, ma rimane nero. Stesso discorso per la sospensione. La imposto, ma niente da fare, si disattiva lo schermo (che rimane nero anche in questo caso) ma il pc rimane attivo, la ventola gira, hard disk pure.

 

Share this post


Link to post
Share on other sites

Buona sera khris,

ho applicato il dsdt. Il sistema operativo si spegne e si riavvia senza problemi. L'errore del cmos del bios è sparito! Grande!

Pero lo sleepenabler non va. Ho provato a attiavare solo lo spegnimento dello schermo, ma niente, si retro illumina come prima, ma rimane nero. Stesso discorso per la sospensione. La imposto, ma niente da fare, si disattiva lo schermo (che rimane nero anche in questo caso) ma il pc rimane attivo, la ventola gira, hard disk pure.

Lo sleep non va nemmeno a me ovvero si spegne ma non si riattiva più lo schermo... Ciò che mi sembra strano è il fatto che se imposti lo spegnimento dello schermo poi non si riaccende.... Sinceramente non mi viene in mente nulla ma fai una cosa, postami la parte di kernel log che intercorre da prima che il problema si verifichi al momento successivo in cui si è verificato, voglio vedere se lascia qualche messaggio che può aiutarci a capire il problema... Avviando in verbose noti niente di strano?

Share this post


Link to post
Share on other sites

No semplicemente vai in applicazioni/utility/consolle ora vai su kernel log e mi fai una semplice copia selezionando la parte di kernel log relativa alla data di oggi e la incolli su un nuovo documento con text edit... Ovviamente faim in modo che accada il problema... Il comando - v si da al boot per fare una diagnosi , vedi se compare qualche errore strano

Share this post


Link to post
Share on other sites

Ciao Khris,

ti ho girato i log del kernel.

Fammi sapere se noti qualcosa riguardo allo spegnimento dello schermo.

Grazie

Buona giornata

 

Edit: ho installato iMessage ma nn va. iCloud, app Mac store e iTunes invece si. Come potrei risolvere?

Share this post


Link to post
Share on other sites

Prova questo dsdt e dimmi se trovi differenze e se risolve qualcosa... Prova a mettere sleepenabler.kext nel caso non lo avessi già provato o ancora con questo dsdt non ti si riaccende lo schermo... Per iMessage non so aiutarti.

dsdtmas2.aml.zip

Share this post


Link to post
Share on other sites

Siccome anche io ho il portatile con lo sleep e il riavvio non funzionante sto ancora cercando soluzioni ma serve tempo e ora ne ho poco... Mi sembra strano sto fatto che non ti si riattiva lo schermo dopo che il monitor va in stop... Non stai usando la funzione stop giusto? E' solo lo stop del monitor ho capito bene? Mi faccio sentire qui se trovo soluzioni... Se hai tempo dai uno sguardo in altre discussioni anche del forum in inglese magari troviamo la soluzione...

Share this post


Link to post
Share on other sites

Si sto usando solo lo stop del monitor.

Ok, grazie di tutto. Se trovo qualcosa ti dico. Buona serata

 

 

 

Khris ho un problema. Per installare il sp1 di win 7 ho dovuto impostare l'avvio di Windows come primario. Ora pero non riesco piu ad avviare con charmeleon. Mi parte sempre Windows o se deselezione la partizione come primaria mi da boot mancante. Riesco ad entrare con la penna boot che ho usato per installazione e ho re installato charmeleon sulla partizione di lion, ma nn cambia nulla. Come posso reimpostare charmeleon come boot principale?

Share this post


Link to post
Share on other sites

Esattamente dove hai impostato windows come primario? Se non ricordo male devi usare chameleon wizard e sovrascrivere il bootloader nella partizione efi ... Cerca una discussione tipo dual boot con windows, se non sbaglio lo avevo letto li...

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×