Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sandro Melia

Help with chinese Intel Atom MBA Clone - DSMOS Has arrived

52 posts in this topic

Recommended Posts

It's an atom N2800 with Intel GMA 3600

2GB ram

32GB SSD

 

39_213_5.jpg

 

39_210_3.jpg

 

------------ HARDWARE IDS ------------

00:00.0 Host Bridge [0600]: Intel Corporation Cedarview DRAM Controller [8086:0bf2] (rev 03)

00:02.0 VGA compatible controller [0300]: Intel Corporation Cedarview Integrated Graphics Controller [8086:0be2] (rev 09)

00:1b.0 Audio Device [0403]: Intel Corporation N10/ICH 7 Family High Definition Audio Controller [8086:27d8] (rev 02)

00:1c.0 PCI bridge [0604]: Intel Corporation N10/ICH 7 Family PCI Express Port 1 [8086:27d0] (rev 02)

00:1c.1 PCI bridge [0604]: Intel Corporation N10/ICH 7 Family PCI Express Port 1 [8086:27d2] (rev 02)

00:1c.2 PCI bridge [0604]: Intel Corporation N10/ICH 7 Family PCI Express Port 1 [8086:27d4] (rev 02)

00:1c.3 PCI bridge [0604]: Intel Corporation N10/ICH 7 Family PCI Express Port 1 [8086:27d6] (rev 02)

00:1d.0 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 [8086:27c8] (rev 02)

00:1d.1 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 [8086:27c9] (rev 02)

00:1d.2 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 [8086:27ca] (rev 02)

00:1d.3 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 [8086:27cb] (rev 02)

00:1d.7 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller [8086:27cc] (rev 02)

00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev 02)

00:1f.0 ISA bridge [0601]: Intel Corporation NM10 Family LPC Controller [8086:27bc] (rev 02)

00:1f.2 SATA controller [0106]: Intel Corporatin N10/ICH7 Family SATA AHCI Controller [8086:27c1] (rev 02)

00:1f.3 SMBus [0c05]: Intel Corporation N10/ICH7 Family SMBus Controller [8086:27da] (rev 02)

 

 

So far I have tried retail 10.6.3 SL DVD with MODUSB, MyHack, Nebookinstaller, no luck hangs at DSMOS has arrived, with some boot flags(PCIRoot, GraphicEnabler, arch,cpus, bus ratio, -x, -v, -F etc.) and messing around I got it to an ACPI time out and it gets stuck there... I also tried iATKOS L2 with that I get a reboot loop when it goes to start darwin.. and I also tried the Retail lion from appstore witch does the same as iAtkos. I googled around about DSMOS but nothing helped. I've managed to install os x many times on other PC-s and Laptops. But this is a first time with netbook + intel atom. I've tried some bootflags and tried some kexts, not sure if I tried them all.

So any help with be greatly appreciated

 

p.c. for Snow I used snowleopard_10a432_userdvd.dmg and Intel Atom 10.2.0 kernel. As far as I know 10a432 is SL 10.6.0 so maybe I need some other kernel? or maybe I need GMA 3600 kext?

 

p.p.s. I tried a tons of FakeSMC-s an Disabler-s so that's not the case.

 

Thank you very much,

 

Sandro

Share this post


Link to post
Share on other sites

try

Iportable Snow Osx86 Mac Os 10.6.2

it boots even your toaster!!

 

please do not forget ,DSMOS take a long time at the first boot

be patient

Share this post


Link to post
Share on other sites

Ok I fixed dsmos error like this:

Restored retail Snow on USB. Insalled Chameleon without extras. Replaced original kernel with atom kernel. Placed FakeSMC.kext, NullCPUPowerManagement, ACPIBattery.kext, IOAHCIBlockStorageInjector.kext, IOAHCIFamily.kext, AppleRTC.kext in S/L/E. Rebuilt kextcache with:

 

sudo -s
cd <path_to_S/L_folder>
chmod -R 755 Extensions
chown -R root:wheel Extensions
kextcache -v 1 -a i386 -a x86_64 -m /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext /System/Library/Extensions

 

Booting in verbose, stuck on Boot. it says:

 

BootCache: hit rate below threshold (212 hits on 1701 lookups)
Warning - com.apple.driver.InternalModemSupport declares no kernel dependencies; using com.apple.kernel.6.0




 

by the way, My solid state drive works when I try to install the windows. so It's not the SSD problem.

Should I repartition it?

 

****UPDATE****

Reformated to Fat32. Got this error:

 

BootCache: hit rate below threshold (212 hits on 1701 lookups)
BootCache: Could not terminate cache on bad hitrate)

 

Dunno what does this mean.

 

naah here's the screen

 

34rukw6.jpg

 

 

****UPDATE****

 

iPortable snow Gives me the same Bootcache error, but then passes it an stops at

ACPI_SMC_PlatformPlugin::Start - waitForService...

 

FakeSMC does not fake it? :)

Share this post


Link to post
Share on other sites

Thanks for reply :)

 

its MacPro

 


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
       <key>SMbiosversion</key>
       <string>MP31.88Z.00C1.B00.0802091544</string>
       <key>SMmanufacter</key>
       <string>Apple Inc.</string>
       <key>SMproductname</key>
       <string>MacPro3,1</string>
       <key>SMsystemversion</key>
       <string>1.0</string>
       <key>SMserial</key>
       <string>W87234JHYA4</string>
       <key>SMexternalclock</key>
       <string>333</string>
       <key>SMmaximalclock</key>
       <string>3000</string>
       <key>SMmemtype</key>
       <string>19</string>
       <key>SMmemspeed</key>
       <string>800</string>
       <key>SMmemmanufacter_1</key>
       <string>0xAD00000000000000</string>
       <key>SMmemserial_1</key>
       <string>0x00001020</string>
       <key>SMmempart_1</key>
       <string>0x48594D503131325336344350362D59352020</string>
       <key>SMmemmanufacter_2</key>
       <string>0xAD00000000000000</string>
       <key>SMmemserial_2</key>
       <string>0x00003021</string>
       <key>SMmempart_2</key>
       <string>0x48594D503131325336344350362D59352020</string>
       <key>SMmemmanufacter_3</key>
       <string>0xAD00000000000000</string>
       <key>SMmemserial_3</key>
       <string>0x00003021</string>
       <key>SMmempart_3</key>
       <string>0x48594D503131325336344350362D59352020</string>
       <key>SMmemmanufacter_4</key>
       <string>0xAD00000000000000</string>
       <key>SMmemserial_4</key>
       <string>0x00003021</string>
       <key>SMmempart_4</key>
       <string>0x48594D503131325336344350362D59352020</string>
</dict>
</plist>

 

Should I remove it?

 

 

p.s. Just for note. This notebook doesn't boot from GUID partition, so I'm using MBR is that ok?

Share this post


Link to post
Share on other sites

seems like youre totaly lost.

it will boot from GUID if its osx only .. and u install chameleon 2.1.

(hybrid gpt guid and MBR is tricky and has issues)

 

 

that smbios is flawed majorly.. need a real one. try macbookair2,1 smbios.plist or macbook5,1

 

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>SMbiosdate</key>
<string>10/29/08</string>
<key>SMbiosvendor</key>
<string>Apple Inc.</string>
<key>SMbiosversion</key>
<string>MB51.88Z.0073.B06.0810291326</string>
<key>SMboardproduct</key>
<string>Mac-F42D89C8</string>
<key>SMfamily</key>
<string>MacBook</string>
<key>SMmanufacter</key>
<string>Apple Inc.</string>
<key>SMmanufacturer</key>
<string>Apple Inc.</string>
<key>SMproductname</key>
<string>MacBook5,1</string>
<key>SMserial</key>
<string>FC80742L1AQ</string>
<key>SMsystemversion</key>
<string>1.0</string>
</dict>
</plist>

{change letter L for something else to make serial random}

 

the mbair2,1 info that u can edit on the above 5,1.smbios to make MacBookAir2,1 smbios

dmi.bios.date: 11/14/08

dmi.bios.version: MBA21.88Z.0075.B03.0811141325

dmi.board.name: Mac-F42D88C8

dmi.product.name: MacBookAir2,1

dmi.sys.vendor: Apple Inc.

Share this post


Link to post
Share on other sites
seems like youre totaly lost.

it will boot from GUID if its osx only .. and u install chameleon 2.1.

(hybrid gpt guid and MBR is tricky and has issues)

 

That's ok :) What I mean is that it doesn't boot from GUID USB Stick. dunno what u mean under hybrid pgt guid :) anyway I tried both MBA and MB Smbios's - both gave me this:

 

Waiting for DSMOS....
System ShutDown False
Previous ShutDown caused 0
DSMOS Has Arrived..

 

booted with -v only.

 

Uploaded my extras here: http://www.mediafire.com/?p72b4k6xw7fbnx6

Share this post


Link to post
Share on other sites

I am sorry if Iportable is not working, usually it works very well on Atom .

did you finally fix the boot or not? could be a gma 3600 problem ?

 

I am interested cause I ordered the same from china and I am curious to know

about install MACOSX and the machine feedback,

 

thanks

Share this post


Link to post
Share on other sites

did you try safe mode

-s -v -x ?

 

try

 

-force64

 

your machine is 64bit

 

 

 

Nope still no luck.

 

Yeah maybe it's a gma 3600 problem. Cuz DSMOS Arrives just before it enters the GUI mode.

 

Or maybe not... can't say for sure.

Share this post


Link to post
Share on other sites

did you try safe mode

-s -v -x ?

 

try

 

-force64

 

your machine is 64bit

 

Same DSMOS error with force64

 

**Update**

same single user with safe mode. Gives me the root prompt. I type exit to boot the system and then this:

 

Waiting for DSMOS....
System ShutDown False
Previous ShutDown caused 0
DSMOS Has Arrived..

 

 

I'm gonna blow up now )))

 

Pretty sure it's a GMA problem. maybe I should fill in the device properties string.. but I don't know how to do it ))

Share this post


Link to post
Share on other sites

did you check the bios options , are there something usefull?

for example SATA, AHCI ?

 

 

Same DSMOS error with force64

 

**Update**

same single user with safe mode. Gives me the root prompt. I type exit to boot the system and then this:

 

Waiting for DSMOS....
System ShutDown False
Previous ShutDown caused 0
DSMOS Has Arrived..

 

 

I'm gonna blow up now )))

 

Pretty sure it's a GMA problem. maybe I should fill in the device properties string.. but I don't know how to do it ))

 

or try install iportable on usb or SD card and boot it.

by the way , the MBA clone is capable to boot from SD Card?

this to exclude a disk SSD problem.

 

 

did you check the bios options , are there something usefull?

for example SATA, AHCI ?

Share this post


Link to post
Share on other sites
did you check the bios options , are there something usefull?

for example SATA, AHCI ?

 

Yap bios is pretty flexible. There's IDE/AHCI, Deep Standby, HPET, Intel HT Tech, XD, Fast Strings, machine check... very good C state config. Basically it's Phoenix SecureCore Tiano. But settings differ a lot from the ones that are mentioned in guides and tutorials. So I'm not really sure that my config is correct.

 

or try install iportable on usb or SD card and boot it.

by the way , the MBA clone is capable to boot from SD Card?

this to exclude a disk SSD problem.

 

All of the install attempts were made from bootable USB. I don't have any external combo drive. I'm using iPortable Snow since you suggested it 3 or 4 days ago.

 

By the way when are u expecting your notebook to arrive? So we could work with this issue together.

Share this post


Link to post
Share on other sites

I sent to another country for taxes, here are absurd rates,

so I can have my MBA clone only at the end of june when I will travel .

sorry, but I am sure it is possible to install on it and boot.

I am trying to understand the bios option now, let me see on internet.

 

http://xpcboot.weebly.com/index.html

check this,

 

 

I had an idea, you said is UEFI like MAC

so why we need a bootloader if the bios is the same of a real MAC

Share this post


Link to post
Share on other sites

Yap I've seen XPC Before, but I know nothing about DSDT patching etc.

I don't even understand were can I get my original dsdt.aml file so I could modify it later. )))

Plus XPC is too hard to install and is a real pain in the @ss.

Share this post


Link to post
Share on other sites

to get dsdt boot ubuntu and

 

To compile your DSDT and SSDTs information, install if you haven't already the acpidump and iasl tools:

 

sudo apt-get install acpidump iasl

### or

sudo yum install pmtools iasl

 

Then run the following commands on a bash terminal:

 

mkdir ~/acpiinfo ; cd ~/acpiinfo

sudo acpidump > acpidump.txt

sudo acpixtract acpidump.txt

ls *.dat | while read i; do iasl -d "${i}"; done

name=`sudo dmidecode -s system-product-name`

 

mkdir "${name}" && cp *.dsl "${name}"/

now u can zip and upload the folder made in /home with pcname to mediafire or some site.

 

 

however i never seem gma 3600 .. might work.. dunno for sure.

Share this post


Link to post
Share on other sites

Ok I'm really tired of this {censored}. I failed to install acpidump. Cuz my wifi drivers (witch I had to compile manually for linux) don't work under latest ubuntu. So I can't get any updates via apt-get. I'm really pissed. Not going to install older version of ubuntu. There should be other way of installing osx without DSDT!!!

Share this post


Link to post
Share on other sites

ahh u have broadcom 43xx .. b43 firmware installer would work if u had ethernet..then no need for wifi.

if u have another mac u can enable ethernet internet sharing and use that to dload update.

Share this post


Link to post
Share on other sites

Yes I have another mac but this time I used http://www.osx86.es/?p=883 this windows port to extract the DSDT file. Don't know why this tool isn't suggested anywhere else )

 

Heres my DSDT.aml https://skydrive.liv...BEF79630668!820

 

whats next? ) Can't really remember how to add this to boot.plist. and what do I have to patch exactly?

 

P.S. Lunux - you can use this file too we have exactly the same config. So you won't have to bother of getting it next time. My skydrive will remain till the end of the time :) This goes to other MBA clone owners ) they're all same.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×