Jump to content
Save

Help with chinese Intel Atom MBA Clone - DSMOS Has arrived

52 posts in this topic

Recommended Posts

Thanks :)

 

Can u please verify that I extracted my DSDT file correctly? Extract button does that right? : ))) Or maybe it's some sort of sample of that file? ) It's a Noobish question I know.

Share this post


Link to post
Share on other sites
Advertisement

thanks Sandro,

I downloaded the DSDT file, I hope this could be a real solution and fix for our machines.

In my opinion , I ahve a feeling that the bios has some limitations for different OS, did you try a live usb linux edition, like

pclinuxos?? I think we have to check it before , if linux works, also MAc has to work.

regards

Share this post


Link to post
Share on other sites

TONYMAC said i n a post:

 

Anyone who get stuck at "DSMOS has arrived" need to replace graphics kexts (in your installer) with the working SL's kexts.

replace 3 AppleIntelHD* kexts in S/L of the installer. Then go on installation.

 

set your BIOS to ACHI mode

 

try ######

 

 

another try from Prays Blog

I installed Snow on my Asus P5W DH Deluxe with ATI HD 3870 system recently and tried many of the suggestions to get the system to boot without success. It would always hang soon after “DSMOS has arrived”. The
solution
I finally found was to remove ATIRadeonX2000.kext and

ATI3800Controller.kext
from /S/L/E and then the system booted to the GUI correctly and allowed me to fine tune from there. Other ATI video cards that are currently unsupported should benefit from the same process by removing the appropriate kexts from /S/L/E. I haven’t tested this but the ATI1xxx series should remove
ATIRadeonX1000.kext
and the corresponding ATI1xxxController.kext and ATI2xxx and ATI3xxx series remove
ATIRadeonX2000.kext and ATI2xxxController.kext
to achieve the same results. I hope you can use this info in your blog.

I currently boot the system from a USB stick with Chameleon-2-1.0-r431 with the following kexts in /E/E folder and they have so far provided me with a very stable system. I also added this line “-x32 boot-uuid=BCA03D4B-F4A5-387A-
B80F-B793D2115741″ to the “Kernel Flags” section of com.apple.Boot.plist to boot by default in 32 bit mode as I have heard it may improve stability until 64 bit options are improved. If you have any suggestions please send a reply.

AHCIPortInjector.kext

AppleRTC.kext

ATAPortInjector.kext

fakesmc.kext

IOAHCIBlockStorageInjector.
kext

IOAudioFamily.kext

NullCPUPowerManagement.kext

OpenHaltRestart.kext

OSvKernDSPLib.kext

PlatformUUID.kext

Sleepenabler.kext

VoodooHDA.kext

 

a friend suggest me this

 

PCIRootUID=0

Share this post


Link to post
Share on other sites

I tried removing almost all Graphic kexts including ati ones. Didn't help.

 

Linux works. I've installed several distress. Like ubuntu, joli, gos etc. Sata is set to ACHI. Otherwise It won't even boot. PCIRootUID=0 Doesn't fix it also.. ))

Share this post


Link to post
Share on other sites

[url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]?

Share this post


Link to post
Share on other sites

DELETE ALL THE GRAPHIC KEXT FROM THE SYSTEM/INSTALLATION/EXTENSIONS

and from extra AND AT THE BOOT JUST TYPE

 

GraphicsEnabler=No

 

by the way

[url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] is not only post,

if you have amac ohackintosh machine

you can install on usb live mac

 

try booting with "PCIRootUID=1 apci=0x2000 -v" (Without quotes obvs)

 

 

or

under a differente mac pc

 

1. right click on the usb volume and click on 'get info...'

2. scroll down, unlock

3. uncheck the 'ignore ownership on this volume'

 

post-5400-1310075134_thumb.png

Share this post


Link to post
Share on other sites

[url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] is not only post,

if you have amac ohackintosh machine

you can install on usb live mac

No reason to use [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], it is a simple compilation of drivers that any non-programmer (like myself) could put together. Don't know why it's received so much attention...

 

In any case, I would look up "GMA 3600 QE/CI" (w/out quotes) to see if graphics is supported at all. If it's not there's no point in installing OS X.

Share this post


Link to post
Share on other sites

Then honestly this won't work well. Even if you get OS X installed, the performance will not be good.

Share this post


Link to post
Share on other sites

Well I doubt that cuz 3600 is pretty much the same as other atom based GMA-s so it should work anyway.

Share this post


Link to post
Share on other sites

Yeah, it'll work...but what kind of functionality do you want?

 

You won't be able to use DVD Player, most screensavers, games, Preview (there may be a hack), and basically the machine has about as much graphics functionality as a 2000 iMac G3 (with an ATi Rage 128). In other words, unless you do very basic tasks (even Pages and also Word I believe require QE/CI), then probably going back to Windows or migrating to Linux might be a better idea.

Share this post


Link to post
Share on other sites

lunux, all the links you posted are not relevant at this point. The problem at this point is the GMA 3600.

Share this post


Link to post
Share on other sites

If you look carefully the resolution is supported but QE/CI (acceleration) is not. Meaning that the computer is basically useless as a hackintosh. :)

Share this post


Link to post
Share on other sites

Ummm ) Lunux. That's my post on OSX86 ))

 

 

About GMA500. Obviously it didn't work. By the way dunno wtf is wrong with 3600 but there are no drivers either for linux ) So the only option is Win 7 )))

Share this post


Link to post
Share on other sites

Sorry to hear from you only win 7 is feaseble ,

gma 3600 is becoming very popular on new laptop,

I am sure the community will work on it in short time, wait and see!

 

by the way I ll' do my job when I received my MBA clone at the end of june,

see you later

Share this post


Link to post
Share on other sites

BTW, so far no graphics driver has been written for OS X. Only enablers. GMA 3600 is only on Atom machines, and I don't see Apple putting an Atom into their computers any time soon. :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×