Jump to content
  • ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By heiza
      Ryzen 7 2700X
      ASUS Prime X470 Pro
      32GB G.Skill Ripjaws V DDR4-3200
      ASRock Phantom Gaming Vega 56
       
      My motherboard doesn’t have an option for 4G encoding. And boot modes are listed as ”Windows UEFI Mode” and “Other OS”.
       
    • By Gunzar
      Hello there!
       
      TL:DR; I built a Hackintosh system using the OpenCore Vanilla Desktop Guide (running Catalina 10.15.4) and I use an AMD Ryzen 1600 CPU and Radeon RX 5700 XT GPU. All works well except my displays are very blurry and it feels like I’ll get a headache if I try to look at the screen for very long. The picture quality is noticeably worse than Windows or Linux. What can I do to fix it?
       
      --
       
      Let me start off by saying that this is my first hackintosh build. I based my build on the Opencore Vanilla Desktop Guide at https://khronokernel-2.gitbook.io/opencore-vanilla-desktop-guide/. I’m running macOS Catalina 10.15.4.
       
      So I finished installing macOS after slowly and carefully taking about 8-10 hours to go through the guide yesterday and make sure I did everything properly. It paid off - it has been solid as a rock. However, there is one problem that is currently bugging me to no end - my displays are very blurry. This seems to be independent of any application or display resolution. My dock icons are blurry, the system text is blurry, app text is blurry (like in Slack, Safari, Notes, etc). This does not occur in Linux or Windows when using the same screens. 
       
      Also, as a test, I hooked up my girlfriend’s MacBook Pro to the same two screens, and the monitors are crystal clear again, just like they usually are in Windows. This leads me to think that my EFI may be configured improperly or my system may be missing some software or a kext that enables the displays to show a sharp image. I attached my EFI folder and my config.plist file for reference. 
       
      EFI setup:
      ACPI: SSDT-EC-USBX-AMD.aml Drivers: ApfsDriverLoader.efi OpenRuntime.efi VBoxHfs.efi Kexts: AppleALC.kext AppleMCEReporterDisabler.kext Lilu.kext RealtekRTL8111.kext VirtualSMC.kext WhateverGreen.kext (version 1.3.8) My boot args are: "npci=0x2000 agdpmod=pikera keepsyms=1 debug=0x100 alcid=1"  
      System specs:
      Ryzen 5 1600, no overclock or anything special Corsair Vengeance Pro RGB RAM, 32GB total (2x16GB DDR4 dimms running at 2400MHz) XFX Radeon RX 5700 XT RAW II 8GB GPU (this is listed as a PCIe 4.0 GPU, could that cause issues since my motherboard is PCIe 3.0 only? Works great in Windows/Linux) ASUS Prime B350M-A motherboard Samsung PM961 256GB NVMe SSD  
      My monitors:
      Samsung U32J59x (32” @ 3840x2160) ASUS MX279 (27” @ 1920x1080) The blurry issue also occurs when I plug directly into my 58" Samsung 4K TV.  
      I’ve already tried these steps:
      Adjusting monitor “sharpness” settings, totally unbearable at “0” but still looks pretty bad even at “100” Trying a bunch of different resolutions in the “Display” preferences. On the 4k monitor, the only one that looks any better is the 1920x1080p option, but then I have far too little screen space left. Using SwitchResX, no different than using different resolutions in the regular Display preferences Using subpixel antialiasing in the terminal with no noticeable difference, even through reboots Turning on/off AMD FreeSync on my 4K monitor — if I turn on FreeSync, the display lags and stutters, and quality is not any better. Also tried turning on/off “game mode” but that had no difference. Tried switching DisplayPort version between 1.1 and 1.2 in monitor settings (on 4K monitor) Checking my BIOS settings, such as making sure CSM is off, against the OpenCore guide that I used to make sure everything was correct  
      Does anyone else have some other ideas that could help to correct this issue? Any ideas would be greatly appreciated. Thanks in advance!!
      -Gunzar
      EFI.zip
      config.plist
    • By viktr
      A few days ago I faced a problem - installed ocquirks and it somehow broke my prelinked kernel. System won't boot then, and I spent more than a day restoring from the netatalk  backup to copy working prelinked kernel directory from the backup to the s/l
      So, my question is - how to relink prelinked kernel without that? I found boot args -f UseKernelCache=No but it didn't work. I was able to boot to the recovery, if that can help.
    • By anokic
      I have been using clover to install and configuration my Hackintosh High Sierra 10.13.6. It's been a struggle and a pain. Can't restart/shutdown/wake from sleep. Random freezes. When freeze happens mouse works but in loading state. UI and open apps freeze not the mouse. I can make the apps smaller and move them.

      I haven't used any DSDT nor SSDT. Tried 5 or 6 of them from others but sometimes i end up not booting. Could someone explain me do i even need them and why? Do i need DSDT or SSDT or both?

      I'm going to try to install everything OpenCore. The first thing is i can't use a method that needs an internet while installing MacOS cause my ethernet/internet only works when i install MacOS. So i can't use the images i need full installation. Okay i have the full installation for 10.13.6. I need to use a version 10.13.4-6 versions cause application Sketch needs the newer one High Sierra 10.13.4++ version.

      Can you tell me? Can i use same kexts from Clover on OpenCore? Secondly how can i install full USB MacOS installer? (High Sierra 10.13.6 version i have is 7gb i think thats it)
      Is there a version of AMDHigh Sierra version made from the community for 10.13.4++ version?
      If i use the normal 10.13.6 High Sierra should i use this AMD 10.13.6 Kernel when i have installed the MacOS or some other kernel that's better for my system? https://github.com/Shaneee/AMD-High-Sierra-XNU/releases
      Whats the best version of High Sierra to use for Ryzen and Nvidia system?

      Will it be better to use OpenCore?

      Specs:
      Mortar Max B450M
      Ryzen 2600x
      Nvidia GTX 1060
      16gb DDR4 2400mhz
    • By Andy Vandijck
      I decided to extract the immutablekernel for Catalina 10.15.3.
      I had to add a FAT header but it extracts just fine.
      Thanks to this we have the kernel and kexts for the immutablekernel.
      The info dictionary and lists are also included.
      Needs further study if it contains extras compared to the prelinkedkernel.
      Maybe we can find out what those .im4m files (for example immutablekernel.x589iclydev.im4m) are thanks to this.
       
      Enjoy
      immutablekernel.zip
×