Jump to content
InsanelyMac Forum
ammar555

[Help] iatkos l2 on Intel HD 3000 Graphics [Acer 5750 with Customization Section ]

Recommended Posts

See my update above.

 

Just give me the 3 pieces of info I asked for the 3 devices. No need for more pix.

 

Sorry for given you a picture, but this way I don't make any mistakes writing anything down.

 

vg5ttu.jpg

 

 

 

NOTE: I won't be able to follow you up at this moment, for emergency purposes I have to leave. I will get back to you in probably 4 hours. I will follow the rest of steps when I come back. I sure thank you for the great help you made, this is by far the biggest achievement I ever made in a month.

Share this post


Link to post
Share on other sites
Advertisement

Well, things are not going well. There is no driver for the wireless. The solution is to buy a Broadcom 4321 card and replace the one that is in the computer. You have to make sure you get the right size of card because some come in half-height size. Also, does your computer have a wireless power switch - one that turns it on and off? These can be a problem because they default to off and when OSX boots and there is no power on the card, it won't initialize it and it won't work. One hack is to place a piece of tape on one of the pads so the power always stays on.

 

There is a Snow Leopard driver for ethernet but it causes problems when used with Lion.

 

Sound - the only solution so far is VoodooHDA but that causes you to have kernel panic and loud sounds. There may be older versions or tweaks that will make it work. I may need you to get me a piece of information from Windows - I assume you have Windows on this machine? Also, in OSX, look at a program called System Information (a different one than what you downloaded). Go to the Go menu and select Utilities. Find System Information and open it. On the left side, click on Audio. What does it say on the upper right side and on the lower right side?

 

I'm going to think about this overnight and see if I can come up with anything else.

 

 

 

Question: what is the model number of your Acer?

Share this post


Link to post
Share on other sites

I just got my desktop going with iatkos l2. The Installed voodooHDA gave a loud hissing sound from my center spk. So I rollback to voodooHDA 0.2.1, which gave much better sound and no more hissing noise when there is no sound playing. Not sure if this info will help.

Share this post


Link to post
Share on other sites

Go to the Go menu and select Utilities. Find System Information and open it. On the left side, click on Audio. What does it say on the upper right side and on the lower right side?

Question: what is the model number of your Acer?

 

just came back!

 

Here is a picture for the Audio Info

 

rrp6hx.jpg

 

 

I have Acer 5750-9292 and yes I have a wireless power switch to turn it on and off.

Share this post


Link to post
Share on other sites

Let's try IwanttoHackintosh's suggestion to install an old version of VoodooHDA.kext. This one doesn't have an installer package so we have to install the kext ourselves. Maintaining permissions on the kext is very important,, so we will use the program Kext Helper b7. We also need to remove AppleHDA.kext or it will conflict.

 

1. Drag the following file to the Trash. It will ask for your password. /System/Library/Extensions/AppleHDA.kext

2. Download VoodooHDA.kext: http://code.google.c...dooHDA.kext.zip

3. Place it on your Desktop. Double-click it to unzip it.

4. Download Kext Helper b7: http://cheetha.net/

5. Place it on your Desktop. Double-click it to unzip it. Double-click it to open it.

6. Drag the VoodooHDA.kext to the big window in Kext Helper. Type in your password. Click "Easy Install"

7. Reboot -f

 

I know you have to boot into Windows to download the above files. I would like a piece of information from Windows. There is a small chance it might help with the sound situation.

1. Go to Device Manager.

2. The quickest way I know to get there is to click on the Start button, find Computer, right-click and select Properties. Device Manager will be the first item on the left.

3. Clck on Sound, video and game controllers.

4. Right-click on High Definition Audio Device and select Properties. Click on the Details tab

5. In the pop-up menu, select Hardware IDs

6. I'm looking for the 4-digit numbers beside VEN_ and DEV_

 

Even though it might not work, we should try the driver for the Ethernet. To get that driver, you will need to open an account at http://www.osx86.net/. Go there and register for an account.

 

Have you ever opened the memory compartment of your computer? If so, can you see the wireless card in there?

Share this post


Link to post
Share on other sites

Let's try IwanttoHackintosh's suggestion to install an old version of VoodooHDA.kext. This one doesn't have an installer package so we have to install the kext ourselves. Maintaining permissions on the kext is very important,, so we will use the program Kext Helper b7. We also need to remove AppleHDA.kext or it will conflict.

 

6. I'm looking for the 4-digit numbers beside VEN_ and DEV_

 

Even though it might not work, we should try the driver for the Ethernet. To get that driver, you will need to open an account at http://www.osx86.net/. Go there and register for an account.

 

Have you ever opened the memory compartment of your computer? If so, can you see the wireless card in there?

 

 

 

I followed the first part, I installed VoodooHDA.kext, then rebooted with -f, but the Apple logo kept spinning forever.

Then I rebooted in normal mode, logged in, but there is no sound.

 

As for the second part, here is a picture for what you need.

 

f387cm.jpg

 

 

And yes I upgraded my laptop to 8 GB RAM sometime ago, but I really don't remember if I saw a wireless card. If it's essential to know, I will open it again.

I do also have an account at osx86.net

 

 

Update: According to this website, it should be easy to access the wireless card, its right next to the two memory sticks.

http://www.hardwares...750-Laptop/1359

Share this post


Link to post
Share on other sites

OK, access to the wireless card is necessary if you want wireless internet under OSX. You need a different card.

 

To try the ethernet kext, we first need to do something with the existing kext and then install a replacement kext just like you did with VoodooHDA.kext and Kext Helper. If I remember correctly, you created a folder called IntelBack for the video kexts. That will be a good home for the old ethernet kext.

 

Open Terminal

 

Type:  cd /System/Library/Extensions
Type:  sudo mv IONetworkingFamily.kext IntelBack/
(type your password when requested and then press <Enter>)

 

Download the new kext: http://www.osx86.net...m_bcm57785.html

Double-click to unzip and install using Kext Helper

Reboot -f

 

 

Update:

 

Let's also try another sound kext.

 

Drag the following kext to the Trash and give your password: /System/Library/Extensions/VoodooHDA.kext

 

Download,, unzip and install using Kext Helper: http://www.osx86.net/downloads.php?do=file&id=1959

 

Reboot -f

Share this post


Link to post
Share on other sites

OK, access to the wireless card is necessary if you want wireless internet under OSX. You need a different card.

 

To try the ethernet kext, we first need to do something with the existing kext and then install a replacement kext just like you did with VoodooHDA.kext and Kext Helper. If I remember correctly, you created a folder called IntelBack for the video kexts. That will be a good home for the old ethernet kext.

 

Open Terminal

 

Type:  cd /System/Library/Extensions
Type:  sudo mv IONetworkingFamily.kext IntelBack/
(type your password when requested and then press <Enter>)

 

Download the new kext: http://www.osx86.net...m_bcm57785.html

Double-click to unzip and install using Kext Helper

Reboot -f

 

The operation was successful!

 

I was able to get it internet by plugging a wire to my laptop, but the wireless seems not to be working. Much better progress!

Share this post


Link to post
Share on other sites

Excellent!

 

The wireless will not work without buying a new card.

 

In posting 32, I added an Update to try another sound kext.

Share this post


Link to post
Share on other sites

Excellent!

 

The wireless will not work without buying a new card.

 

In posting 32, I added an Update to try another sound kext.

 

 

I will try it, I just have to switch to windows to download files. My USB doesn't show up in the finder for some reason. I will be back!

Share this post


Link to post
Share on other sites

USB doesn't show up in the finder for some reason.

 

Try this:

 

Go to the Finder menu and select Preferences. Click on General. The top item defines what shows up on the Desktop. Click on those boxes until the USB shows up.

Share this post


Link to post
Share on other sites

Try this:

 

Go to the Finder menu and select Preferences. Click on General. The top item defines what shows up on the Desktop. Click on those boxes until the USB shows up.

 

 

The sound operation was also successful!

 

 

The USB is still not showing.

 

The display resolution is only 1024 X 768, is there a way to get the standard resolution .

 

How do I know which wireless card I should buy?

 

I really hate to put too much load on you, forgive me.

Share this post


Link to post
Share on other sites

Great for sound!

 

USB, I'll think about. If you click on the Finder icon in the Dock (the left-most icon), a Finder window opens. There is a sidebar on the left with your drives and favorites and things. Scroll the left sidebar to see if you can find the USB there.

 

Wireless - the best thing would be a picture - I need to know the size of it - there are two sizes

 

Display - we can try, but a lot of people have problems with it.

Share this post


Link to post
Share on other sites

Great for sound!

 

USB, I'll think about. If you click on the Finder icon in the Dock (the left-most icon), a Finder window opens. There is a sidebar on the left with your drives and favorites and things. Scroll the left sidebar to see if you can find the USB there.

 

Wireless - the best thing would be a picture - I need to know the size of it - there are two sizes

 

Display - we can try, but a lot of people have problems with it.

 

 

The USB doesn't show up, but I might not need it. I have access to my Windows 7 files, they show up under Acer.

The Display is not a big problem, I am happy with the current resolution, I just thought it's good to have all the options.

 

The wireless I can try to take a picture of it later, but I know I won't need the wireless this week.

 

I am completely happy with what I have right now, if I think I should optimazing the laptop a little more, I will update this thread. For now everything is great.

 

I need to know one more important thing, How do I make a donation to you? You can send me a private message.

Share this post


Link to post
Share on other sites

I have set a new goal, which is to install xcode 4.2 on iatkos L2.

 

My brother gave me the .dmg file which is around 1.68 GB, but when I try to install it, I get to the very last step, then the installation fails. Here is a picture of what I see [google].

 

screen-shot-2009-...30.12-pm-16499c8.png

 

 

Is there a specific method that I need to know in order to install Xcode 4.2 ?

Share this post


Link to post
Share on other sites

Verify that you haven't run out of space on your Lion partition. Right-click on Lion and select Get Info. Look at space used and available.

 

During installation, the installer keeps a log. It is available under the Window menu. Install again and see what it says for the last several lines of the log when the installation fails.

 

I read where it took one guy seven attempts before the installation was successful.

Share this post


Link to post
Share on other sites

Verify that you haven't run out of space on your Lion partition. Right-click on Lion and select Get Info. Look at space used and available.

 

During installation, the installer keeps a log. It is available under the Window menu. Install again and see what it says for the last several lines of the log when the installation fails.

 

I read where it took one guy seven attempts before the installation was successful.

 

 

I did try to install it multiple times, but my attempts were unsuccessful.

 

I do have the error log in the attachments.

Installer Log 15-Apr-2012.txt

Share this post


Link to post
Share on other sites

Attachment wasn't there but is now.

 

It is a certificate error. There is a certificate that has expired. This is a problem that has happened before. Temporarily set your date back a couple of years.

 

System Preferences -> Date and Time

 

Make sure you uncheck the automatic updating from the internet, then turn back the year above the calendar. You can undo it when you are done.

Share this post


Link to post
Share on other sites

Attachment wasn't there but is now.

 

It is a certificate error. There is a certificate that has expired. This is a problem that has happened before. Temporarily set your date back a couple of years.

 

System Preferences -> Date and Time

 

Make sure you uncheck the automatic updating from the internet, then turn back the year above the calendar. You can undo it when you are done.

 

 

You are one of a kind, absolutely amazing. It's installing now.

 

I fail words to express my gratitude to you for all you have done.

Share this post


Link to post
Share on other sites

I would like to thank you as well. I just finished installing iAktos L2 on a Lenovo X220. If you are still available maybe you can help me to get the graphics working better.

 

I would like to add that I am unable to use an external USB post installation. It's not being recognized by the OS. I am using a ScanDisk Cruzer 8GB thumb drive that I formatted as FAT32. I need to get this working to begin using [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] or DSDT. I installed the USB drivers when I installed iAktos L2 thinking that it would solve the problem.

 

I do have a working Ethernet connection though so I am able to download files if needed. Great work guys. This really helped me out.

 

I was also wondering if I should just install Lion from the retail version instead. Would this solve some of my issues and allow the system to update as well?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Similar Content

    • By dcd_
      Hola,
       
      he logrado instalar en mi PC iAtkos L2 con éxito y después actualizado a 10.7.5. 
       
      El sistema es:

      Placa base Gigabyte EX-38 DS5
      La gráfica es una ASUS 210 Silent de 1GB de RAM
      8 GB de Memoria RAM

      Para la instalación en la personalización usé configuración en BIOS AHCI aunque también marqué IDE porque tengo un disco IDE aunque actualmente no lo tengo conectado.

      Para el audio utilicé el chip 889A que es el que corresponde al Realtek que tiene la placa. El inconveniente que tiene es que no consigo que funcione el micrófono.

      En cuanto a la tarjeta de red, también la detecta perfectamente, es la Realtek Gigabit. 

      Para actualizar de 10.7.2 a 10.7.3, de 10.7.3 a 10.7.4 y de 10.7.4. a 10.7.5., siempre me daba error descargando las actualizaciones de 'actualización de software', por lo que opté por bajarlas manualmente e instalarlas. Antes de reiniciar, lo que hice, fue restauras los premisos utilizando Kext Utility.

      Se puede resumir que los únicos problemas que tengo por el momento son que no funciona el micrófono con Skype (con otros programas sí me funciona bien) y no consigo que funcione Teamviewer.

      También estoy a ver si puedo hacer funcionar una tarjeta de tv/sat/radio Hauppauge HVR4000. Ya contaré si lo consigo. 
    • By vhj1995
      Installing Apple Mac OS X 10.7.2 Lion (iATKOS L2)
       
      ON Lenovo G570
       
       
      For Installing Apple Mac OS X OS 10.7.2 Lion ported by iATKOS Team. Codename for This Distro : iATKOS L2. Now I experiment that on my Lenovo G570 and it works 99% expect Wifi and AMD Readon 6370M GFX.
       
       
      Working:
      -Almost Everyting.
       
      Not Working:
      -Wifi
      -AMD Readon 6370M [Although you don’t need to be work it cuz you ain’t gonna gaming on OSX]
       
      Procedure:
      1. Get iATKOS L2 from iatkos.me
      2.Make Bootable USB for Installing OSX Lion [iATKOS L2]
       
       
       
      Here your VM’s Mac work is done. Now you don’t need it.
       
      3. Boot Up from USB.
      4. Select iATKOS L2
      5. Go through process. [DON’T CUSTOMISE SETUP] for partitioning use Disk Utility to format [Erase] to HFS+
      6. After Installation. Again bootup from USB and Start Setup. Then go to Utility > Terminal.
       
      Now ,  Perform Following Operations.
       
      7. Now boot from USB and Select iATKOS L2 from HDD [NOT THE SETUP]
      8. Plugin USB Keyboard and USB Mouse.
      9. Go through process you will get to desktop.
      10. Get kexts and install particular drivers for Network, PS/2 Support, Voodoo HD Sound and bootloader. System Specification MacBook Pro 8,1.
      11. Install Intel 3000’s Kexts via Kext beast. [zip attached]
      12. Now it’s done, boot using command “-v GraphicsEnabler=No”
       
      Enjoy!
      Guide By vhj1995.
      my intel hd3000.zip
    • By AbsoZed
      I've been trying to boot to Lion for a couple hours now, and get through the installation with [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url]/[url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] and all that mess, however, after the installation, I get stuck at "DSMOS" has arrived. I've tried pretty much every bootflag I can think of, and it all ends at the same thing. My specs are as follows, as far as I see them being relevant:
       
      Asus U43F Laptop
      Intel Core i5 Sandy Bridge
      Intel HD 3000 Graphics
       
      Any ideas? I've tried -x -f -v PCIRootUID=0 cpus=1 
    • By Mac-Ingegno
      Gentile comunità
      ho installato iAtkos L2 su questo Notebook:
       
      ASUS F502CA
      -CPU Intel Pentium ULV 987 1.50Ghz DualCore
      -4GB ram DDR3
      -HD sata 500GB (AHCI)
      -Scheda video Intel HD integrata (credo sia la 4000 o 3000)
      -Audio Intel HDA
      -Reti Atheros AR8161(Ethernet) e AR9485(wireless)
       
      tuttavia dopo aver finito l'istallazione, al primo Boot compare sempre il seguente messaggio:
       
      "DRMStatus: iTunes/Apple Store Content Access Problem. Content playback may be disabled on this computer. You can continue to use the machine, but you should contact an Apple support representative. ErrorCode: 8877652"
       
      Ho fatto varie ricerche in merito, ma ognuno suggerisce la propria "cura" ma tutte con esito negativo.
       
      Sono stati provati tutti i vari comandi suggeriti al Boot: 
      -v -x
      -v -x -f GraphicsEnabler=Yes
      -v -x -f GraphicsEnabler=Yes PCIRootUID=1
      -v -x -f GraphicsEnabler=Yes PCIRootUID=0
      -v -x -f GraphicsEnabler=No PCIRootUID=1
      -v -x -f GraphicsEnabler=No PCIRootUID=0
      -v -x GraphicsEnabler=No PCIRootUID=1  IGPEnabler=Yes
       
      in Single User (-s)
       
      seguendo il post di xcrash a questo link:
      http://www.insanelymac.com/forum/topic/282667-resolved-snb-and-drmstatus-error/
      dove lui ammette di aver risolto, io ho replicato a lui nel suo post, ma non è giunta risposta.
      sono stati provati questi comandi:
       
      cd System/Library/Extensions
      mkdir IntelBack
      mv AppleIntelHD* IntelBack/
      mv AppleIntelSNB* IntelBack/
      reboot
       
      e anche questi trovati in rete:
       
       
      mkdir /GeriOSX/
      mv /System/Library/Extensions/AppleIntelSNBGraphicsFB.kext/ /GeriOSX/
       
      Ma nessun risultato, il messaggio di errore è sempre li che blocca il First Boot di iAtkos L2.
       
      Potrebbe dirvi qualcosa questo errore di accesso causato da iTunes che ne impedisce l'avvio corretto della distro da me utilizzata?
      oppure conviene intraprendere un altro tipo di installazione per questo Hardware?
      Qualcuno di voi ha un notebook con caratteristiche simili?
      Grazie per il vostro tempo che vogliate dedicarmi alla risoluzione di questa insormontabile barriera.
    • By upendra
      I am having problem with initial boot of iatkos l2 and iatkos ml2.
      I have burned both disks using TransMac inside windows 7
      My computer configuration is 
       
      Intel i3 3110m 2.4GHz
      Intel HD4000
      WD 500GB SATA III
      Ram 2Gb 1600mhz
      InsydeH2O bios with latest update 
       
      I have enabled AHCI and Legacy boot 
       
      iatkos l2 freezes screen after start and do not boot
      and iatkos ml2 gives me error of Ebios read error error 0x01
       
      i tried different boot flags but no use
      Please help.
×