Jump to content

NVIDIA GeForce 9300M GS fails in Snow Leopard 10.6.8


2 posts in this topic

Recommended Posts

Hello guys,


I've got a laptop with a Clevo M7X0SU motherboard and a NVIDIA GeForce 9300M GS graphics card.


Well I'm trying to update my Snow Leopard from 10.6 to 10.6.8. I am using 32 bit mode. Updates until 10.6.4 went fine, then when updating to 10.6.5 I had to remove the NVEnabler.kext (because of a black screen), then updates until 10.6.7 went fine too.

Now I'm updating to 10.6.8.


I replaced the IOUSBFamily.kext with the one from 10.6.7 to get my USB functionality back.

Now I can only boot with "GraphicsEnabler=no" flag into VGA mode (1024 x 768).

Until 10.6.7 the graphics worked fine. But now when I try to boot with graphics enabler I get a green screen.


When I try the following flags:

PCIRootUID=0 + GraphicsEnabler=yes -> Green screen

PCIRootUID=1 + GraphicsEnabler=yes -> VGA mode (like no graphics enabler)


I tried to use NVEnabler kext, but there I get either this or the same green screen.


Do you have any idea?


Thank you in advance! :)

Greetings, Max

Link to comment
Share on other sites


  • Create New...