Jump to content
lipinho170

Wifi device showing up as USB device ("port") and not working

11 posts in this topic

Recommended Posts

Hi guys,

Today I tried to install iAtkos L2 on my Vaio Vpc-f226fm machine and managed to get every single thing working fine nearly out of the box, except the WiFi. BUT, something REALLY strange happens with it. Mac actually recognizes my Intel Centrino Wireless-n (wimax) 6150 board as an USB device (or port) and not as a network device. Even stranger: I checked my hardware info before installing (by the link on the Utilities menu on the OS X installer) and the board shows up a USB port, which means that no additional custom kext's were loaded or installed by the installer.

As far as I can think, having the OS X to recognize my wifi board (even though it doesn't recognizes as a wifi board, and so, I can't use it to connect) is a good thing, since there must be a tweak or something I can do to make it work as it was supposed to.

Any ideas of what can I do to have it working?

 

Also, at osx86project.org I found a guy which reported that his laptop had the exactly same problem with pretty much the same specs as mine.

 

 

Sony Vaio VPC-F236FM

QE

 

Install Method: iatkos l2

 

Audio: work hdmi,microphone,s/pdif all perfect

Battery: Voodoo Battery kext

Bluetooth work

DVD-RW: Reads haven't try burning.

Ethernet: work

Keyboard & TrackPad: VoodooPS2, tapping works.

Input device won't respond at startup until 9 minutes later, don't know why?

Magic Gate: Not working,

Motion Eye: Works OOB facetime & skype video and mic works almost flawless.

USB Mouse: Scroller is in reverse; down = up, up = down ( this is feature of lion. )

USB Slots: working fine

Shut Down/ReBoot: works fine

Video:main display YES gt 540m full hd 1920x1080 but it shows gt 450

WiFi: it shows under usb intel centuriono wireless n wimax 615

camera :work

HCL 10.7.2/Portables - OSx86

 

As you can see, this guy had the same problem, but didn't specified if it's fixed.

Share this post


Link to post
Share on other sites
Advertisement

you can dream.. its probably detecting a generic device.. not wireless.

 

or u can change the wireless to a working model like AR5B91 or BCM94321MC

Share this post


Link to post
Share on other sites
you can dream.. its probably detecting a generic device.. not wireless. or u can change the wireless to a working model like AR5B91 or BCM94321MC

I really don't think that my Mac recognized a generic device. Check this out:

 

screenshot20120404at625.png

 

As you can see, Mac recognized the device (at least I think it did, since there's too much information to be just generic), but as an USB device, not a network device.

Share this post


Link to post
Share on other sites

In some laptop mini-pci a connected via USB. Intel network chips dosen work with os x. All USB devices are shown with name in System Profiler which doesn't mean that they are supported.

Share this post


Link to post
Share on other sites

In some laptop mini-pci a connected via USB.

 

Didn't understand, could you rephrase?

 

Intel network chips dosen work with os x. All USB devices are shown with name in System Profiler which doesn't mean that they are supported.

Sure it doesn't mean it's supported, but, since it's listed over there, it means that, at least, the device is being recognized, which is a start, right? Isn't it anything I can do to get it working? DSDT or anything? For me, OS X is kind of useless without Wi-fi.

Share this post


Link to post
Share on other sites

no wont work. as n odrivers made for intel wireless.

mini pci-e connected to usb with an adapter chipset inside laptop ?

seems its straight internal usb.. does it have minipci-e slot ? (take picture of wireless card if it has access door)

 

change wireless card.

Share this post


Link to post
Share on other sites

Electrical interface

 

PCI Express Mini Card edge connector provide multiple connections and buses:

  • PCIe ×1
  • USB 2.0
  • SMBus
  • Wires to diagnostics LEDs for wireless network (i.e., Wi-Fi) status on computer's chassis
  • SIM card for GSM and WCDMA applications. (UIM signals on spec)
  • Future extension for another PCIe lane
  • 1.5 and 3.3 volt power

 

Source http://en.wikipedia.org/wiki/PCI_Express#PCI_Express_Mini_Card

Share this post


Link to post
Share on other sites

The WIMAX is running over usb and therefore recognized in the USB Device list.

 

Connector interface PCIe electrical interface for Wi-Fi, USB 2.0 for WiMAX
found in the specification of a similar intel WIfi device.

Share this post


Link to post
Share on other sites

The WIMAX is running over usb and therefore recognized in the USB Device list.

 

found in the specification of a similar intel WIfi device.

 

If it's running over usb, that'd mean that it's actually working, isn't it?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By murobro
      Hi. My notebook Acer Aspire E1-571 and my mac version High Sierra 10.13.4. My wifi card Qualcomm Atheros AR9485WB-EG. How to install this card is my Hackintosh. I am trying several methods and no luck. I find this post and do not want how to install this kext. I am a newbie. Please help me. I need a full tutorial.
       
    • By superq
      Hello everyone,
      My hack(HP Elitebook 2570p) works perfectly exept for one thing:Wifi.
      It has a BCM943142 Combo card,is there any way to get that card working?
      I'm running HS.
      Thanks in advance!
    • By bojarek8
      Hi! 
       
      I'm Kris!  I hope my topic is in a good section.
      I am asking you guys for help in this difficult hackintosh problem. 
      For a very long time I tried to solve it myself but I have no idea how I can solve this problem.
       
       
      Description of the problem
       
       
      My problem is that I do not have access to any apple service. I am unable to log into the App Store using my Apple ID. I am unable to log into iCloud account in system preferences. iMessage and Facetime also do not work.  Messages that I get when I try to log in: "An error occurred during activation. Try again" 
       
      in iMessage: "An error occurred during activation. Try again" 
      in App Store: "This device or computer can not be verified. Contact the support department for help"
      in Face Time: "There was an error during activation. Try again"
       
      In summary, I am unable to log in to any apple network service. 
       
      My Specification 
       
      Motherboard:  Acer MG43M
       
      Processor: Intel(R) Core(TM)2 Duo CPU  E7600  3.06GHz
       
      Graphic card: Gigabyte GeForce 9600GT 515MB 
       
      Wi-fi: TP-LINK  TL-WN881ND
       
      Ethernet: (not supported) 
       
      Audio: (rather, it is not needed here)
       
      Files: 
       
      My config.plist: https://drive.google.com/drive/folders/1vlYJC329sz6yuTwFr-k0fOs3rfhKeI6l
       
       
       
       
       



    • By Angelo_
      Ciao ho acquistato questo adattatore wifi in quanto sembrava essere compatibile fino a sierra e mi serve per un altro hackintosh in casa non raggiungibile da ethernet e per il prezzo(circa 20€) era meglio degli edimax da 300mbps solo che sto riscontrando dei problemi nel farlo funzionare, ho installato il kext per l'mtk 7610u da qui 
      e installato con kext wizard(manualmente non dava risultati) per poi installare il software di asus solo che quest ultimo non riesco a farlo funzionare dato che si avvia e compare per poco l'iconcina in alto a destra per poi scomparire e non si apre mai l'utility come su windows, qualcuno ha questa o usb simili e sa come sistemare questo problema? osx mi vede l'esistenza di un wifi ma non mi sembra mi dia modo di connettermici in alcun modo. 
      Grazie


×