Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
3square

dlink dwa-556 won't get detected

9 posts in this topic

Recommended Posts

hello everyone,

 

i'm trying to get my dwa-556 to get detected by my dell xps 420. i'm on lion 10.7.3. i've isolated all of my non-vanilla kext, but it still won't get detected.

the verbose boot shows this error

applesmbuspci start failed to get acpi path for provider

error: offset_0x100=0xfffffff

start [/sourcecache/airportdriveratheros9380/airportdriveratheros9380-430.14.9src/common/lmac/ath_dev/darwin/atheroscontroller.cpp:962] load failed

 

i've put the card in a gateway gm5626 with a fresh lion install (10.7.0), and the card was detected OOB as it should be. the thing that i notice is when i boot from my usb installer, the card was still loaded fine on the gateway. but on my dell it won't load either way, from usb boot or within the os. so i'm thinking it's the xps 420 itself that doesn't work with the dwa-556? since the usb boot doesn't have anything conflicting. i've also tried different atherosfix.kext, but it still doesn't work.

 

some kext i'm using right now are [ intel82566mm, voodoohda, elliottforcelegacyRTC]

 

please help me isolate this problem.

Share this post


Link to post
Share on other sites

Hi. Just install/replace the big vanilla extension IO80211Family.kext (extracted from 10.7.3 COMBO UPDATE or from your gateway laptop) into /S/L/E, then repair permissions and rebuild caché... finally restart the system. That should be enough for any native WiFi card to work, without those things like atherosfix or any type of injector, nothing more. Good Luck.

Share this post


Link to post
Share on other sites

so i tried that, didn't work.

 

i think as i mentioned in the first post, the card doesn't show up on booting from my usb installer on my dell 420. but it does when i boot from the usb installer on my gateway. since i'm booting straight from my usb installer, that isolate any conflicting kext or anything else on my dell osx. so therefore, there is something else that isn't working on my dell hardware.

Share this post


Link to post
Share on other sites

i recognize the error.. its dell specific too.

on my inspiron i had same with ar5bxb62 and ar5bxb72(apple real branded). but never with ar928x.

might have to use dsdt fake of device id 2A and subsystem 8F.. (atheros Ar9285 fix) but first u have to find the location of it in ioregistry explorer.

 

only way i made ar5bxb62 work was rebranding it to device id 1014 and subsystem 58a (ibm wireless card)

then add atherosfix or device id 1014 to the atheros kext. (worked great in 10.5 but rarely in 10.6)

 

cant rebrand anything newer that ar5bxb6 ,.. the 72 didnt let me cause linux tools not avail.

 

what i have recomended was mini pci-e to pici-e adapter and atheros ar5b91 in it (ebay)

 

juanerson 10.7.4 got someone working in atheros with issues in 107.3 so u might be onto something.

Share this post


Link to post
Share on other sites

u can optionally try rebranding the card if its device 1C but if its 2x .. x being any number .. cant rebrand

best bets are atheros dsdt fake for ar9285 .. or replace the card with one i use AR5B91 with adapter for desktop.

 

also the DSDT Device (PCI0) ... does it have _UID, 0x04 ? should be 0x00

 

some people have fixed other atheros issues with older 10.7 io80211 kext replacement.. and others with 10.6.7 or .8

 

but offset 0x100 fffff seems to be pci-e issue with an older pci not express cards driver. seems its reading wrong spot or right spot and finding blank = fffff. even with a real apple ar5bxb72. but didnt happen to me with AR5B91 .. the appples use AR5B92,but i had issues with AW-NE772..

while AW-NE771 works being AR5B91

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×