Jump to content
Sign in to follow this  
Followers 0

I have problem with my wifi and enthernet...I need help 10x

13 posts in this topic

Recommended Posts

Hi, all!

I instaled Mac OS - Snow Leopard 10.6.3 on my laptop - Packard Bell Eastnote NJ65.

Everything is OK, but Wi-Fi and Ethernet:

My original Wi-FI card was Intel 5100 , but I saw there have not kext for it and I changed it with Broadcom BCM 4312. I tryed every kext what i found but after reboot everytime I have problem to boot OS. I have kernel panic or message to restart laptop.

In the install disk I have fix for my card which I installed, but when I start Mac I haven't WiFi. When I try to make new connections in Network - there have not option for wireless, just 6 to 4; PPoe and VPN.


The same problem with my Ethernet connection - I can not start it. It's Broadcom 5784M.


Can somebody help me? May be I do something wrong, but I don't know what.


Thank you very much!



T. Lapkov

Share this post

Link to post
Share on other sites

Thank you, rlf!

I tryed before with this Magnat2's script, but I haven't success,now I will try to install the script, but everytime when I install something after that i can't boot Mac Os.

When I instal some kext I using Kext Helper B7, but may be somewhere I doing something wrong.

If I have kext in the install CD why I can not use the wireless conections? - in the Extra/Extensions folder I have Broadcom fix and there I found my card ID and vendor ID.

Is Kext helper enough for repair permisions, I tryed to repair permisions and with Disk utility?

Share this post

Link to post
Share on other sites

What install DVD did you use?


From what I can tell, 10.6.3 is already set up to work with a standard BCM 4312 card. It shouldn't need any fixes or different kexts.

Share this post

Link to post
Share on other sites


I installed iAtkos s3 v2. And I thing there have everything for this Wi-Fi card and shoul work without any different kext, but I have not option in Network settings for wireless. I don't know why.

Share this post

Link to post
Share on other sites

I have used iAtkos s3 v2 for the connection of the wifi and enthernet,But I can't do that. I have above error in that. How this problem solve?

Share this post

Link to post
Share on other sites

Thank you for the rlf's help.

With his help we added in <string>14e4,4315</string> in AppleAirPortBrcm4311.kext's info.plist but still have no wireless.

Does anyone have any idea what else can be done?

Share this post

Link to post
Share on other sites

Try KextWizard for your kext installs. Very user friendly GUI and can also repair permissions and rebuild kernel caches on S/L/E and E/E. Try http://www.osx86.net...do=file&id=1538 in E/E, OR http://www.osx86.net...?do=file&id=892 in S/L/E and use option in KextWizard to back up any replaced kexts. If you get a kernel panic reboot with -x and run the kextwizard utilities again. If needed, boot -s for safe mode(command line only) and with some basic command line skills, you can remove an kext that is causing kernel panic and preventing booting to desktop. Also always boot with -v (verbose when first setting thins up (or always) so if you get a kernel panic you can see why, and also see what is/isn't loading properly. It won't look just like a bunch of text after a while and if not now, down the road you'll be able to spot possible problems easily. But if you always just watch a spinning wheel and apple logo, you'll never see a thing. And if that doesn't help, at least we tried:)


Or, monoprice has usb wifi adapters for like 5$, just make sure you check compatibility b4 you buy

Share this post

Link to post
Share on other sites

Does your computer have a WiFi button? This is what the manual for your computer says:


Turning On/Off a WiFi Network Connection

Most computers feature a ‘WiFi’ button that turns the network connection on or off. If your computer does not feature a ‘WiFi’ button, you may turn your wireless network on or off, or control what is shared over the network with the network management options.

Share this post

Link to post
Share on other sites

I have touch button on the top bar and it's on. When I boot Mac OS I tryed off and on and the button lights on and off but nothing on the monitor is displayed.

Share this post

Link to post
Share on other sites

Just to b sure, did u try adding manualy to network preferences? go to system preferences and to network tab, then hit the + button in the network list and see if it shows in the list of connections to add.

Share this post

Link to post
Share on other sites

Hi, eep357! When I go there I have nothing now, because I reinstaled Iatkos soon. But when i try to add - I make location and after tha on "+" i have to choose 3 type connection PPoE, 6 to 4 and VPN- I have not airport or wireless. I try with that Broadcom.fix also, but nothing. I put Airport.script on the top bar but it says airport card is not detected.

For the ethernet I also try some kexts but nothing.

May be somhere I do something wrong, but I really don't know what.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Discount_Mac
      I have done a semi-successful install of macOS Sierra 10.12.6 on my Dell OptiPlex 3010. When I mean semi-successful, I mean I have some issues left, one of them is Networking.
      Networking, meaning Ethernet, does not seem to work on this machine after installing Mac OS. I've tried installing kext files, reinstalling Sierra, and so on but nothing seems to work, I have an Ethernet cable plugged and it's lights flashing and whatever but the connection does not show up in Sierra.
      My PC Specs are:
      Dell OptiPlex 3010 MT
      Intel Core i3-3240 @ 3.40GHz
      AMD Radeon HD 7470
      4GB of RAM
      Realtek RTL8111E
      So, Any Help?
    • By anantprakash92
      Hey guys! i just needed some help with my bluetooth. i have ar9462, i know its not compatible, but bluetooth should work out of the box. I know theres a way to load firmware with windows, and I've tried rebooting from windows into OS X, which doesn't seem to load it. 
      I have an HP-M6-1045dx running MacOS Sierra with everything else pretty much working. 
      Also, I found this dsdt patch, unfortunately i haven't figured out how to install it. 
      Any help would be appreciated, thank you.


      Here's the dsdt patch it tells me to apply
    • By gaieges
      Hi there,
      I've been struggling for a while now with getting my Asus z270g motherboard's onboard lan to work with Sierra.  I've been able to get most of the other components working thanks to the generous efforts of this forum, but this last problem has been causing me quite the level of stress!  
      The z270g apparently has a i219-v chip, however it appears to be a bit different than the device's supported by IntelMausiEthernet (Which I've heard works very well with that chipset).  It's using deviceID 8086:15d6  After looking through the source of the driver it appears that the particular device id isnt being searched for:
      00:1f.6 Ethernet controller [0200]: Intel Corporation Ethernet Connection (5) I219-V [8086:15d6] Subsystem: ASUSTeK Computer Inc. Ethernet Connection (5) I219-V [1043:8672] Flags: bus master, fast devsel, latency 0, IRQ 123 Memory at df100000 (32-bit, non-prefetchable) [size=128K] Capabilities: <access denied> Kernel driver in use: e1000e Kernel modules: e1000e Here's what I've tried so far:
      With IntelMausiEthernet kext: Installed driver in /S/L/E and /L/E in addition to the Clover bootloader kext directory.  By itself, none of these caused kextstat to load the driver automatically (Aside from the clover directory) Spoofing the Lan ID to something that the driver did support (ie one of the ones that was also using the i219v chipset), caused the driver to load (via kextstat), but no devices in system information or the network pref panel Followed a number of steps in the troubleshooting steps that Mieze listed with the same result (driver loaded but no devices) Didn't see any useful logging info in the debug info steps but happy to get that info if it would help With AppleIntelE1000e kext (from insanely mac)Very similar results to above With AppleIGB kextNo luck across the board (although I haven't tried spoofing the id with this drive)  
      Happy to provide more information that would be relevant to the situation but not sure exactly what would help.
    • By shrivaas73
      I have macOS Sierra 10.12 running on my Acer Aspire V5-573G notebook right now. Everything is fine apart from the wireless. Currently, I have access to the following network cards:
      1. Dell DW 1530 - Broadcom 43228HM4L
      2. Qualcomm Atheros QCA9377
      Is it possible to use one of these two cards, or do I need to buy a new card? I'm looking at the Dell DW 1520 BCM94322HM8L and the Azure Wave AZ-NB290 BCM943225HMB at the moment.
    • By pmdcoleslaw
      I just did a clean install of Sierra and set everything up. All is working well, but I noticed something very strange. I am dual booting a Dell OptiPlex 7010 with Windows 10 on an SSD and Sierra on a separate HDD. While in windows my network is proper. I am behind a firewall and use the firewall DNS server settings and have the proper IP scheme. However when I boot into Sierra, I get a completely different IP scheme from the router DNS server that is on the outside of the firewall. I'm connected via a single ethernet line behind the firewall, so I cannot for the life of me figure out how my hackintosh is bypassing/skipping/passing through the firewall and going to the main router for DNS. This obviously causes problems, because I can't get to anything on my network from the Sierra build. 


      This was not an issue on El Capitan before I wiped the drive and fresh started with Sierra.


      Any help or insight would be much appreciated.