Jump to content

HardwareUUID changes! System preferences reset!

33 posts in this topic

Recommended Posts

Hello everyone!

I'm running Lion10.7.3 in my notebook- Dell inspiron N4010


gpu-ATI HD5650m


ram-4G kingston,4G samsung


I don't know whether you have this problem or not

Sometimes, when I reboot, my system preferences may reset

For instances, I removed timemachine's icon in toolbar however after reboot it shows up again in toolbar

The input methods I already added have to be added again manually

Icons in launchpad which I have made serveral into a folder come out of the folder


When I look into system report, HardwareUUID has changed to another value

I don't know if it has anything to do with the Chameleon's systemid generator

It's rather annoying since I have to set all my preferences back



Below are my HardwareUUID changes list:

Hardware UUID: E37497B9-86CD-56F6-A322-3F2817F85D67
Hardware UUID: 17D695BE-18FB-506B-8822-537910E093C2
Hardware UUID: A8BA310A-3FFD-5E0A-A02C-2D8C80A58FC2
Hardware UUID: 08D4626F-CED7-5C02-9881-1A3B5048F324
Hardware UUID: 0A9B31EF-114C-520E-B979-6E17453F35EC
Hardware UUID: 56F4B9E5-74B3-512F-AF74-26B3C6DD5246

Here in ~/Library/Preferences/Byhost , you can find that many HaredwareUUID preference were kept here






Seeking for help ~

Best regards.



Share this post

Link to post
Share on other sites

That's a new one. I see you've submitted a bug report, that's good.


Try manually overriding it. Chameleon has been able to do this for years, look - old "what's new" from late RC4 days:


"Platform UUID is setup by injecting /efi/platform/system-id property. The UUID value from SMBIOS table 1 is used as system-id. If your BIOS does not provide an UUID, then you can configure the UUID with SMUUID in smbios.plist." (SMUUID is now SMsystemid)


It's a bit confusing, basically Chameleon automatically pulls the number that becomes your hardware UUID from your PCs SMBIOS.

These two UUIDs are not identical. The good news is that you can override this manually, I think you should try it because Chameleon seems to be having trouble with the way its coded in your PCs SMBIOS.


Manually set a SMsystemidXXX-XXXblablbala in your smbios.plist and see if it stays on the same ID then.


Note that, as I mentioned earlier, SMsystemid is correct for Chameleon 2.1 - you might find other, conflicting info, please discard that.

See here why: http://forge.voodooprojects.org/p/chameleon/source/commit/28/


Just pick any of the ones up there in your first post - and I hope you understand what I said, this caused a lot of confusion when it was first implemented - the UUID you set in smbios.plist will not be the same as the resulting Hardware/Platform UUID. This is normal, don't worry about it - the only thing that's important is that the resulting hardware/platform UUID doesn't change between reboots, as it has been doing for you.


If this works, and it stays fixed, I guess you could pick out and rename those preference files in your screenshot that have the settings you want to keep, so that they are named after your new hardware/platform UUID. Not sure if that'll work, try it and see what happens.

Share this post

Link to post
Share on other sites

thanks, I will give it a shot asap

plus, I used to try using "SystemID" in boot.plist file and "SMUUID" in SMbios.plist file

but it turned out in vain

It's my first time to ever hear about the "SMsystemid"

I didn't even find it in Chameleon's help doc.


I'll report back if it works fine~


Thanks again~

maybe I can update this post in chameleon issue

Share this post

Link to post
Share on other sites

One funny thing I found is that after I place a new string ( SMsystemid ) in smbios, No NEW hardwareUUID is born

It's still 0A9B31EF-114C-520E-B979-6E17453F35EC as before

However, after I reboot to Windows (almost did nothing) , I reboot back to Mac

this time, HardwareUUID changes !

I did same test several times! And it changes again.

So strange.


plus, the doc you've provided is related to rc5, I'm using Chameleon 2.1svn (svn-r1905) [2012-03-24 12:43:14]

what's the relationship between rc5 and svn ?

Share this post

Link to post
Share on other sites

The text in the link i posted above refers to a certain version of RC5 and up. So, "SMsystemid" is in effect from that version onwards.


RC5 was "Release Candidate 5" of Chameleon 2.0. Then 2.0 final was released, and now we're at 2.1.

As of 2.1 the developers have dropped the "RC" moniker and Chameleon is now referred to by svn revision number:


As of right now (12:18 Brasila time..which is my lunch break...I need to go get lunch instead of sitting here), the latest version of Chameleon is 2.1 svn revision 1908, which I have compiled and attached below.


If nothing changes after placing SMsystemid in smbios.plist, it's possible that your version of Chameleon is too old.

In fact you shouldn't even be posting bug reports if you're using RC5. Please update and let me know what happens.


/EDIT - sorry, I failed to read your post properly, that's what happens when you should be eating instead of sitting at the computer.

Well here it is anyway, I'm sure someone will find it useful.


Chameleon 2.1 svn r1908.zip



Share this post

Link to post
Share on other sites

First of all, thanks for your time :)

Currently, I'm using the latest 1910 which I've compiled myself

I've deleted all plist-files in Byhost except those related to UUID-0A9B31EF-114C-520E-B979-6E17453F35EC

Since I;ve added the "SMsystemid" string in my SMbios.plist file, up till now , there've been only one new UUID-related files in Byhost

That's UUID-08D4626F-CED7-5C02-9881-1A3B5048F324

Everytime when I boot from Win back to Mac, hardwareUUID is set to 08D4626F-CED7-5C02-9881-1A3B5048F324

I've set my SMsystemid to 0A9B31EF-114C-520E-B979-6E17453F35EC just for convenience (I know what I set here isn't exactly the same with HardwareUUID )


plus, I'm curious why the SMsystemid isn't listed in doc

wish RC6 come out ASAP and fix this problem perfectly :D

Edited by Gringo Vermelho
Please don't quote entire posts when replying directly below them.

Share this post

Link to post
Share on other sites

Does that mean that it's working now?


You misunderstood what I wrote, I'll try to word it differently.


RC5 was a "Release Candidate" for version 2.0.


Definition of the word "candidate": http://en.wikipedia.org/wiki/Candidate


Back in August 2010 (if memory serves me right) the final version of Chameleon 2.0 was released.

Therefore there will never be an RC6. The final version was released, so of course there are no more "release candidates".


We are now at Chameleon 2.1 and the "RC" terminology is no longer in use.

Share this post

Link to post
Share on other sites

I know.....but that was written in January 2010, more than two years ago. Later, it was decided to release the final version of Chameleon 2.0 and move on to 2.1.


I hope that you can understand that there cannot be a release candidate after the final version has been released!

Share this post

Link to post
Share on other sites

Yep, I know this

But is Chameleon's developers working on this ?

It seems they forget this issue which I think is of great importance ?

Share this post

Link to post
Share on other sites

Working on what? The code has been in there for more than two years.

As you can see from your own screenshot, it was implemented by Rekursor back in January 2010.


You're the first person that I know of to report a problem with it.


By the way, your filesystem error..


"ntfs_fixup : magic doesn't match :

00557fff != 454c4946"


...has nothing to do with Chameleon and can be fixed by running chkdsk /r in Windows.


If that doesn't fix it, then you need clean out corrupt data in your NTFS "ADS" (alternate data stream).


You can use the "ADS spy" tool in Trend Micro's "Hijack This". Be careful.

There are other tools out there as well, I know of one called "lads" that works from the command line.

Share this post

Link to post
Share on other sites

My God 0-0

I'm the first man ?


Now the situation is like this :

First, I'm in Win. Then I restart my pc and boot into Mac. UUID changes from 0A9B31EF-114C-520E-B979-6E17453F35EC to 08D4626F-CED7-5C02-9881-1A3B5048F324

Then I restart Mac and boot into Mac again, UUID changes from 08D4626F-CED7-5C02-9881-1A3B5048F324 back to 0A9B31EF-114C-520E-B979-6E17453F35EC


Puzzled :(


Thanks for you solution for NTFS problem.

I've used disk check in windows but turned out in vain.

Maybe I can use you tip chkdsk /r in command line ?

Edited by p.H

Share this post

Link to post
Share on other sites

Yeah it's really weird that it does that, from what I understand this data is OS independent, it's located in hardware and Windows should not be messing with it.

It's also interesting that Chameleon is not able to override it.


Let's cover what we can - the easy stuff!


Make sure you use the proper capitalization in smbios.plist.




Sometimes a corrupted or malformatted plist can cause it to not be read properly or not at all by Chameleon.

zip and attach your smbios.plist and I'll check it for you.




Yes, run chkdsk /r on each of your NTFS partitions from an elevated command prompt. (type cmd.exe in the start menu search, right click cmd.exe, run as administrator).

Share this post

Link to post
Share on other sites

Thanks for your time and patience

After you Stressed the Capital I , I check my smbios.plist myself

Notice I was using SMsystemid not Id , I'll change it right away.


Anyway, I've also upload my zip file.(before I changed i to I)

:( I can't find the upload button so I'll show you the code in smbios.plist


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">

Share this post

Link to post
Share on other sites

Are you sure of Id not id ?

I've take some from http://forge.voodooprojects.org/p/chameleon/source/commit/28/

Notice the word is id not Id as you told

SystemId=<UUID>    [DEPRECATED since RC5] Set manually the system id UUID,
  Please use SMBIOS config option "[b][color=#ff0000]SMsystemid[/color][/b]" instead.
   SMUUID in smbios config is also DEPRECATED
   and won't be supported in next releases.


Look at the source:

const char * sysId = getStringForKey("SMsystemid", &bootInfo->smbiosConfig);

It seems it's reading id not Id from smbios file

Share this post

Link to post
Share on other sites

I've checked my disk .

But it seems it's in vain

Due to the ntfs problem , every time i boot my mac, there will be showing

errors encountered please wait 5 seconds...

so annoying.

Share this post

Link to post
Share on other sites

And the "Alternate Data Streams"?


It's true, it's not something I'm making up...I had the same problem myself, and then I found that I had a ton of corrupted "ADS", mainly in files that had at one point been copied, moved or modified by OS X at a time when i had NTFS writing enabled.


OS X cannot fix these problems because Disk Utility cannot work with NTFS partitions. It can only tell you if there's a problem.

Share this post

Link to post
Share on other sites

How to fix

Alternate Data Streams then ?

I have no idea for it though I've googled it


It's my first time to hear of ADS.

Share this post

Link to post
Share on other sites

Using windows7 , I don't find any version which support win7

but I'm still using it. What should I do? Simply find them and delete ?




Edit 1:

Though I tried removing these files, the problem still exist :(

Edited by p.H

Share this post

Link to post
Share on other sites

Strange. I had the same error and deleting the ADS fixed it for me. Since then I have never let OS X write to NTFS drives, and I never saw the NTFS fixup error message again. My shared partitions use the exFAT filesystem...which has its own set of issues..

Share this post

Link to post
Share on other sites

Yep, I've considered using exFat. But it's said that exfat is not good for harddisk

it's used for usb and so on


Do you hear of the software "MacDrive" ? It can empower you to write files to Mac in windows

Maybe I will uninstall this software and check if it's ok then



After I uninstall the software, the problem still exists.

Don't know what to do :(

Edited by p.H

Share this post

Link to post
Share on other sites

p.H, the correct key for changing the system id is "SystemId" (case sensitive) I see you've tried SystemID, however that won't work. SMSystemId (or any variation of that) is not in the chameleon code base any more, and will not work. If the SystemId flag is not passed, chameleon will attempt to read from the smbios. Finally, in the event that that does not exist, it'll use a fixed value of "0123456789ABCDEF".


The only reason you'd have a system id that is changing every time, is if for some reason the id is being changed by the bios. Please post a copy of the bdmesg output and I'll see if anything stands out as begin wrong. actually, post two copies if you would, make sure that each copy comes form a separate boot w/ separate uuids.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By nyolc8
      Sorry if I posted this on wrong section, but I trying to change my system-id to get imessage working, and I found out that there is an option called "SystemId" for org.chameleon.boot.plist, to change the system id manually.
      My system id now: 0000000000000000000000XXXXXXXXXX (XXXXXXXXX = my MAC address)
      This looks odd with the many zeros, I thought that maybe this is the problem and this is the reason why imessage doesn't working for me.
      I tried to make a "SystemId" key into my org.chameleon.boot.plist file and generated an own uuid and set that up, but my system-id stays the same with the zeros. It just ignores this setting...
      I also tried "SMsystemid" in smbios.plist, but it's ignored too.
      Anyone knows how to change the system-id value? Is it possible?
      (I'm using chameleon 2181)
      Edit: I changed the org.chameleon.boot.plist > "SystemId" from Windows (macdrive), and since then, I can change my systemid to anything. (from osx too)