Jump to content
p.H

HardwareUUID changes! System preferences reset!

33 posts in this topic

Recommended Posts

thanks for your reply

If you have followed the posts before, you will notice that ever since I put the SMsystemid string in my smbios file I only have two UUIDs

Before SMsystemid was written to smbios, there are more than 10 different UUIDs

 

I'll post my bdmesg below everytime I boot my mac

Last not the least , thanks

 

Edit 1:

I choose restart in windows and boot into mac

UUID: 08D4626F-CED7-5C02-9881-1A3B5048F324 (almost every time I boot from win to mac, UUID changed to this value )

Here is the bdmesg1 : bdmesg1.rtf

Edit 2:

Funny thing : When I restart my mac and boot in mac again, UUID changed to 0A9B31EF-114C-520E-B979-6E17453F35EC (also ,almost every time restart mac and boot in mac)

bdmesg2:bdmesg2.rtf

Edited by p.H

Share this post


Link to post
Share on other sites
Advertisement

Thanks Meklort for clearing up the confusion, and p.H., sorry about the mess!

 

I guess SystemId goes in org.chameleon.Boot.plist then?

 

Can you post a link to the diff or revision or whatever in the Trunk source where this went in? I'll correct my posts on the first page.

Share this post


Link to post
Share on other sites

Even if it's SystemId that really matters, I've tried this before!

But you know , the problem still exists. :(

Share this post


Link to post
Share on other sites

p.H, how did you try to use SystemId (do note that not only is it case sensitive, but what follows must be in a very specific format (such as 5A180000-0000-0000-0200-000C02021001).

 

I don't know what revision it was changed in, but it's been that way for a while. Check http://forge.voodoop...saio/fake_efi.c, line 493. It states that the kSystemID define is used, which is defined as "SystemId" in boot.h. Actually, looks like in the diff posted on the first page is when it was changed, commit 29.

Share this post


Link to post
Share on other sites

Yep, I have followed the format.

Maybe I should try SystemId again

Share this post


Link to post
Share on other sites

Anybody has idea for this UUID down in SystemPreferences-Users&Groups ?

 

8044f218jw1drjuywrjeej.jpg

Share this post


Link to post
Share on other sites

This is UUID for the User account, not related to Hardware UUID.

Thanks for answering. I've already solved this issue long ago :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By nyolc8
      Sorry if I posted this on wrong section, but I trying to change my system-id to get imessage working, and I found out that there is an option called "SystemId" for org.chameleon.boot.plist, to change the system id manually.
       
      My system id now: 0000000000000000000000XXXXXXXXXX (XXXXXXXXX = my MAC address)
       
      This looks odd with the many zeros, I thought that maybe this is the problem and this is the reason why imessage doesn't working for me.
       
      I tried to make a "SystemId" key into my org.chameleon.boot.plist file and generated an own uuid and set that up, but my system-id stays the same with the zeros. It just ignores this setting...
       
      I also tried "SMsystemid" in smbios.plist, but it's ignored too.
       
      Anyone knows how to change the system-id value? Is it possible?
      (I'm using chameleon 2181)
       
      Edit: I changed the org.chameleon.boot.plist > "SystemId" from Windows (macdrive), and since then, I can change my systemid to anything. (from osx too)
×