Jump to content
dj_reno

BlackScreen - ATI HD 5650 - Acer Aspire 7741G - Lion 10.7.2

2 posts in this topic

Recommended Posts

Hello all,

 

I'm having problems to configure the graphics card "ATI Mobility Radeon HD 5650" in my laptop Acer Aspire 7741G.

 

Laptop Components:

 

- Core i3 370M

- RAM 6 GB (Pending up to 8GB)

- Mobility Radeon HD 5650

- 17.3" LED CineCrystal TFT

 

I performed the installation with DVD iAtkos L2 Hackintosh Lion 10.7.2 (Mac OSX). The installation was successful. This is the hardware that I detect:

 

1) Sound -> RealTek ALC272 -> is OK (By kext)

post-980345-0-34918700-1332193187_thumb.png

2) Ethernet -> BroadCom BCM57780 --> is OK (By kext)

post-980345-0-26621600-1332193186_thumb.png

3) Wifi -> BroadCom BCM43225 --> Non Ok (I tried several options without results)

post-980345-0-33693000-1332193188_thumb.pngpost-980345-0-38608500-1332193189_thumb.png

4) VERY IMPORTANT!! Graphics Card -> ATI Mobility Radeon HD 5650 --> Non Ok (I tried several options without results)

post-980345-0-71769200-1332193183_thumb.pngpost-980345-0-10582900-1332193185_thumb.png

 

Although the wireless does not work, does not worry me much, since I have Ethernet. My problem comes when I want to change the resolution to the laptop's internal display. Only I can choose 1024x768. I have been reading several forums and have followed the steps in this forum -> http://www.osx86.net...do=file&id=1502,

 

Using AtiConfig=Hoolock and GraphicsEnabler=Yes, This does not work, only lets me access by GraphicsEnabler = No.

 

I used ELDIM - EDIDViewer to get the EDID. Exhibits 3 monitors to choose:

 

1) AUO139E (Active 1600x900):

 

* RAW Data:

 

0x00 00 FF FF FF FF FF FF 00 06 AF 9E 13 00 00 00 00

0x10 01 13 01 03 80 26 15 78 0A C4 95 9E 57 53 92 26

0x20 0F 50 54 00 00 00 01 01 01 01 01 01 01 01 01 01

0x30 01 01 01 01 01 01 F8 2A 40 90 61 84 0C 30 30 20

0x40 36 00 7E D6 10 00 00 18 00 00 00 0F 00 00 00 00

0x50 00 00 00 00 00 00 00 00 00 20 00 00 00 FE 00 41

0x60 55 4F 0A 20 20 20 20 20 20 20 20 20 00 00 00 FE

0x70 00 42 31 37 33 52 57 30 31 20 56 33 20 0A 00 26

 

* Convert to Base64=>

 

AP///////wAGr54TAAAAAAETAQOAJhV4CsSVnldTkiYPUFQAAAABAQEBAQEBAQEBAQEBAQEB+CpAkGGEDDAwIDYAftYQAAAYAAAADwAAAAAAAAAAAAAAAAAgAAAA/gBBVU8KICAgICAgICAgAAAA/gBCMTczUlcwMSBWMyAKACY=

 

2) SNY0801:

 

* RAW Data:

 

0x00 00 FF FF FF FF FF FF 00 4D D9 01 08 01 01 01 01

0x10 01 11 01 03 80 A0 5A 78 0A 0D C9 A0 57 47 98 27

0x20 12 48 4C 21 08 00 01 01 01 01 01 01 01 01 01 01

0x30 01 01 01 01 01 01 66 21 50 B0 51 00 1B 30 40 70

0x40 36 00 40 84 63 00 00 1E 01 1D 00 72 51 D0 1E 20

0x50 6E 28 55 00 40 84 63 00 00 18 00 00 00 FC 00 53

0x60 4F 4E 59 20 54 56 0A 20 20 20 20 20 00 00 00 FD

0x70 00 30 3E 0E 30 09 00 0A 20 20 20 20 20 20 01 72

 

* Convert to Base64=>

 

AP///////wBN2QEIAQEBAQERAQOAoFp4Cg3JoFdHmCcSSEwhCAABAQEBAQEBAQEBAQEBAQEBZiFQsFEAGzBAcDYAQIRjAAAeAR0AclHQHiBuKFUAQIRjAAAYAAAA/ABTT05ZIFRWCiAgICAgAAAA/QAwPg4wCQAKICAgICAgAXI=

 

3) TCL0000:

 

* RAW Data:

 

0x00 00 FF FF FF FF FF FF 00 50 6C 00 00 01 01 01 01

0x10 01 15 01 03 80 3A 20 78 0A 0D C9 A0 57 47 98 27

0x20 12 48 4C 21 4B 00 01 01 01 01 01 01 01 01 01 01

0x30 01 01 01 01 01 01 66 21 50 B0 51 00 1B 30 40 70

0x40 36 00 44 40 21 00 00 18 01 1D 00 72 51 D0 1E 20

0x50 6E 28 55 00 44 40 21 00 00 1E 00 00 00 FC 00 20

0x60 20 20 20 20 44 54 56 20 20 20 20 20 00 00 00 FD

0x70 00 32 55 0E 46 10 00 0A 20 20 20 20 20 20 01 9B

 

* Convert to Base64=>

 

AP///////wBQbAAAAQEBAQEVAQOAOiB4Cg3JoFdHmCcSSEwhSwABAQEBAQEBAQEBAQEBAQEBZiFQsFEAGzBAcDYAREAhAAAYAR0AclHQHiBuKFUAREAhAAAeAAAA/AAgICAgIERUViAgICAgAAAA/QAyVQ5GEAAKICAgICAgAZs=

 

----

 

I tested with 3 monitors, but the screen always shows wrong (Multiple screens with horrible resolution) Attached image of the error:

 

Example DisplayProductID-717:

 

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>DisplayProductID</key>
<integer>1815</integer>
<key>DisplayProductName</key>
<string>Internal LCD Forced EDID</string>
<key>DisplayVendorID</key>
<integer>1970170734</integer>
<key>IODisplayEDID</key>
<data>
AP///////wAGr54TAAAAAAETAQOAJhV4CsSVnldTkiYPUFQAAAABAQEBAQEBAQEBAQEBAQEB+CpAkGGEDDAwIDYAftYQAAAYAAAADwAAAAAAAAAAAAAAAAAgAAAA/gBBVU8KICAgICAgICAgAAAA/gBCMTczUlcwMSBWMyAKACY=
</data>
</dict>
</plist>

 

Thanks!

 

--------------------------------------------------------------------------------------------------------------------------------------------------------------

 

Second testing:

 

I made the modification to the start of many AtiConfig=<option> and EDID AUO139E.

 

Graphics Card detected in all AtiConfig is ATI 5000, except Orangutan, showing ATI Mobility Radeon 5650 HD.

 

Alouatta	  -   Same screen error (multiple screens) and horrible resolution.
Baboon	   -   Same screen error (multiple screens) and horrible resolution.
Cardinal	  -   Black Screen, access with VNC is perfect, HDMI OK.
Caretta		-   Not start, panic Error.
Colobus	   -   Same screen error (multiple screens), horrible resolution , VNC is perfect.
Douc		   -   Same screen error (multiple screens) and horrible resolution.
Eulemur	  -   Same screen error (multiple screens) and horrible resolution.
Flicker		 -   Same screen error (multiple screens), horrible resolution , HDMi is perfect.
Galago		-   Same screen error (multiple screens) and horrible resolution.
Gliff			 -   Black Screen, access with VNC is perfect, HDMI OK.
Hoolock	   -   Same screen error (multiple screens) and horrible resolution.
Hypoprion	-   Black Screen, access with VNC is perfect, HDMI OK.
Iago			 -   Same screen error (multiple screens) and horrible resolution.
Kakapo		-   Black Screen, access with VNC is perfect.
Kipunji		   -   Same screen error (multiple screens) and horrible resolution.
Lamna		  -   Black Screen, access with VNC is perfect, HDMI OK.
Langur		  -   Same screen error (multiple screens) and horrible resolution.
Megalodon	-   Black Screen, access with VNC is perfect, HDMI OK.
Motmot		  -   Not start, panic Error.
Nomascus	 -   Not start, panic Error.
Orangutan  -   Black Screen, access with VNC is perfect, HDMI OK. Graphics Card -> ATI Mobility Radeon 5650 HD
Peregrine	 -   Black Screen, access with VNC is perfect, HDMI OK.
Quail			-   Not start, panic Error.
Raven		  -   Black Screen, access with VNC is perfect, HDMI OK.
Shrike		  -   Not start, panic Error.
Sphyrna	   -   Not start. System HALTED!!!
Triakis		 - Without Testing.
Uakari		 - Without Testing.
Vervet		  - Without Testing.
Zonalis		- Without Testing.

 

Conclusion: Lion does not detect my laptop's internal monitor so the screen does not show well with GraphicsEnabler = Yes. The only configuration that detects the graphics card correctly is Orangutan, but I get black screen on laptop screen.

 

Examples Orangutan ScreenShots by VNC:

post-980345-0-71769200-1332193183_thumb.pngpost-980345-0-10582900-1332193185_thumb.png

 

What should I do?

 

Thanks!

 

------------------------------------------------------------------------------------------------------------------------------------------------------

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Michael93
      Salve a tutti,
      Sto cercando di installare High Sierra sul mio Acer Aspire 7741G i3 ma qualcosa non va...adesso vi spiego cosa ho provato:
       
      Per prima cosa ho scaricato VMware e ho installato High Sierra fin qui tutto bene,poi ho scaricato il file di installazione dall'app store,fatto ciò ho preparato la mia usb tramite disk utilty ho selezionato "mac os x extended (journaled)" però ho notato che a differenza di altri non mi appare l'opzione "schema" però ho tentato di procedere anche senza. (Non trovando soluzioni)
      Apro il terminale setto tutto tramite guide che sono in giro per la rete (le stringhe sono tutte uguale) e tutto va a buon fine,poi setto clover e il gioco sembrava fatto.Una volta riavviato ho visto che altri (guide e video in giro per la rete) cambiano impostazioni nel bios ma nel mio caso non è molto modificabile quindi ho proceduto settando la usb come primo avvio.Però purtroppo al riavvio ricevo il messaggio "error loading operating system..."
      Cosi ho provato con UniBeat ma stessa cosa.
      Ho pensato che i componenti non sono adatti oppure ho sbagliato a settare qualcosa,non so.
      Spero che sono stato più o meno chiaro nel spiegare la situazione,Grazie in anticipo.
       
      Se vi è di aiuto ho come scheda madre: MB.PT401.001
      Non so se avete bisogno di altre info,chiedete pure.
    • By Nikita123
      Hello everyone,
       
      I got OSX Yosemite 10.10.3 running on the Acer Aspire 7741G with a few slight problems.
       
      I used the cim method from terminal to create the installer, then added clover to the usb, I extracted EDID with EDID viewer in windows and I am using custom EDID in config.plist and I am using Flicker as frame buffer atm, I did not fill in the number of ports.
       
      When I boot the laptop without or with HDMI connected everything is fine. I have QE/CI, without HDMI connect only on internal display, and with HDMI connected on both screens.
       
      The problems occurs when I connected the HDMI while the system is booted, or when I disconnect en replug the HDMI the same problem occurs, the colors on my laptop screen get screwed up, like a yellow colors and very difficult to read the screen.
       
      This problem also occurs when I enter sleep en wake up the laptop. sleep itself works, but also the yellow color problem is happening here.
       
      I think this got to do when waking from sleep the wrong frame buffer is applied. I am injecting the graphics from clover now, but I am thinking about going to try injection from DSDT since I also made a DSDT and patched it with the patch file found on www.olarila.com.
       
      I used this tutorial to get the videocard working.
       

       
      I hope someone can help me out.
       
       
       
       
    • By liamd99
      Hello everybody,
       
      I am trying to hackintosh my laptop using Clover, installing OS X 10.10.1 and Windows 8.1. I am using this guide to do so (http://www.insanelymac.com/forum/topic/303615-guide-install-windows-8-uefi-on-legacy-bios-with-clover-and-dual-boot-with-yosemite/). But the Windows installation wont boot, not using Rufus, nor using the copy-paste method in the guide. I just dont get it. Can someone please help me?
       
      Thanks.
      Liam
       
      (Attachment: Rufus settings: )
    • By innokentiy.dailymsg
      Всем привет .

      Hardware: 
      Ноутбук:        Acer Aspire TimelineX 5820TG-484G64Miks
      LCD:              1366x768 Матрица: LP156WH3-TLA2
      CPU:              i5-480M 2.66Ghz - 2.93Ghz (with TurboBoost)
      GPU1:            Intel GMA HD 5700mhd (without HDMI)             0x80860046
      GPU2:            AMD Radeon HD 6550M                                    0х100268с1
      Audio chip:    Realtek ALC271x (ALC269)                                 0x80863b56
      WLAN:           Atheros AR9285 (AR5B95)                                  0x168c002b
      LAN:              Atheros AR8151                                                  0x19691073
      Bluetooth:     Atheros AR3011 (AR5B95)
      USB:             4xUSB2.0

      ______________________________________________________________________________________
      БИОС 1.25 (modded by mask89)
      Преимущества модифицированного БИОСа:
          •    Переключение GPU в 3 режимах (Integrated/Discrete/Switchable);
          •    Поддержка UEFI загрузки;
          •    Разлоченные меню "Advanced" and "Power";
          •     и др

      Внимание!!!: Не меняйте опции, которые не знаете, особенно в меню "Power" - можете угробить, либо проц, либо чип биоса (см. Стр. 7,8 по ссылке).

      Подробнее о прошивке читаем здесь: Modded BIOS (Insyde) by mask89.

      Я прошивал в Windows 7 x64
      ______________________________________________________________________________________
      Работу в OS X условно разобьём на 3 режима работы с GPU (переключение в БИОСе):
          1.    Только GPU Intel;
          2.    GPU Intel + AMD HD (хоть Макось и определяет 2 видеокарты, но фактически работает только на Intel GMA);
          3.    Только AMD HD.
      Зелённый - работает;
      Желтый - работает некорректно;
      Бордовый - не работает;
      ______________________________________________________________________________________
      CPU (SpeedStep/TurboBoost)*
      1.Intel GMA:      OK (Температура в простое - 44С) - самый холодный режим
      2.Intel + AMD:   OK (Температура в простое - 52С) - самый горячий режим
      3.AMD HD:        OK (Температура в простое - 49С)
      * (Работает из коробки (OOB). С помощью DSDT патчей немного уменьшил температурный режим)
      ______________________________________________________________________________________
      GPU QE/CI*
      1.Intel GMA:      OK (kexts, framebuffer с LW 1 Alternate или LW 1 Alternatе 2)
      Подробнее по ссылке ([GUIDE] 1st Generation Intel HD Graphics QE/CI):
      2. Intel + AMD:  OK (аналогично 1-му режиму)
      3. AMD HD:       OK (Работает из коробки при AtiConfig: Orangutan, но при этом немного подглючивает экран. Нужно заменить EDID (DisplayProductID-717) на свой . После замены EDID можно грузиться с AtiConfig: Orangutan, Eulemur, Hoolock и др. Подбирайте под себя).
      Подробнее по ссылкам:
      Ati Mobility Radeon HD 5650 - Mavericks
      How to Get ATI 5650m Working With QE/CI on OSX Mavericks
      How to make own EDID
      AMD/ATI Graphic Card Injection (LIST of AtiConfigs)
      ______________________________________________________________________________________
      VGA
      1.Intel GMA:     OK (Работает при замене framebuffer с LW 1 на LW 2 (Alternatе или Alternatе 2). Проблема: но при этом не работает внутренний LCD).
      Подробнее по ссылке: [GUIDE] 1st Generation Intel HD Graphics QE/CI.
      2.Intel + AMD:  OK (Аналогично 1-му режиму).
      3.AMD HD:       OK (Нужно подбирать AtiConfig, например Eulemur или Hoolock).
      ______________________________________________________________________________________
      HDMI
      1.Intel GMA:     None (Intel GMA не поддерживает HDMI).
      2.Intel + AMD:  None (См. выше, режим работы. Intel GMA не поддерживает HDMI).
      3.AMD HD:       OK (Нужно подбирать AtiConfig, например Orangutan).
      ______________________________________________________________________________________
      Brightness "Fn + <- ->"
      1.Intel GMA:     OK (kext + DSDT патч*)
      *После  DSDT патча заработали кнопки "Fn + <- ->", но и лишние "Fn + F12"(уменьшение яркости), "Pause/Break" (увеличение яркости).
      Подробнее по ссылкам:
      [Guide] Backlight + Brightness
      [GUIDE] 1st Generation Intel HD Graphics QE/CI
      2. Intel + AMD:  OK (Аналогично 1-му режиму).
      3. AMD HD:       OK (Работает из коробки (OOB). Правда нет ползунка яркости в "System Preference -> Display").
      ______________________________________________________________________________________
      Sound VoodooHDA 2.8.4
      1.Intel GMA:      OK (Работает некорректно)
      Проблема:
          •    Трещит;
          •    Периодичные глюки: Через каждые 5-10минут вырубается или начинает хрипеть.
      Костыли:
          •    Смена формата на 44100 Hz в Applications - Utilities - Audio MIDI Setup;
          •    Смена битности формата 16/24 bits в Applications - Utilities - Audio MIDI Setup, помогает опят таки только на 5-10 минут, надо снова делать.
      2.Intel + AMD:  OK (Аналогично).
      3.AMD HD:       OK (Аналогично).
      Подробнее о решении проблем с VoodooHDA здесь:
      VoodooHDA common problelms 1
      VoodooHDA common problelms 2
          Звук по HDMI пока не работает (хотя само "HDMI audio output" в системных настройках определяется). Возможно поможет эти гиды (пока не пробовал):
      GUIDE: HDMI Audio with unsupported on-board audio: VoodooHDA and AppleHDA at the same time.
      Mavericks: HDMI Audio - AppleHDA
       
      Sound AppleHDA
      См. ниже (в процессе).
      ______________________________________________________________________________________
      WLAN (Fn + F3)*
      1.Intel GMA:    OK (kext)
      2.Intel + AMD: OK (kext)
      3.AMD HD:      OK (kext)
      * Планируется сделать через DSDT патч
      ______________________________________________________________________________________
      LAN
      1.Intel GMA:    OK (kext)
      2.Intel + AMD: OK (kext)
      3.AMD HD:      OK (kext)
      ______________________________________________________________________________________
      Bluetooth (Fn + F3)
      1.Intel GMA:    OK (kext)
      2.Intel + AMD: OK (kext)
      3.AMD HD:      OK (kext)
      ______________________________________________________________________________________
      WebCamera
      1.Intel GMA:   OK (Работает некорректно. Нет изображения в программах)
      Костыли:
          •    Через программу CamTwist (у меня заработал только FaceTime и PhotoBooth).
          •    Говорят,что помогает программа WebCam Settings (Платная, не пробовал).
      2.Intel + AMD: OK (Аналогично)
      3.AMD HD:      OK (Аналогично)
      ______________________________________________________________________________________
      PS2 Keyboard/Touchpad (multitouch 2 fingers)
      1.Intel GMA:    OK (kext)
      2.Intel + AMD: OK (kext)
      3.AMD HD:      OK (kext)
      ______________________________________________________________________________________
      CardReader*
      1.Intel GMA:    OK
      2.Intel + AMD: OK
      3.AMD HD:      OK
      * Работает из коробки (OOB)
      ______________________________________________________________________________________
      Battery %
      1.Intel GMA:    OK (kext)
      2.Intel + AMD: OK (kext)
      3.AMD HD:      OK (kext)
      * Планируется сделать через DSDT патч
      ______________________________________________________________________________________
      Sleep
      1.Intel GMA:    OK (Работает некорректно)
      Компьютер стал засыпать после EHCI  патча DSDT. После просыпания включается экран, через 1 мин включаются USB, но больше ни на что не реагирует. Помогает перезагрузка.
      2.Intel + AMD: OK (Аналогично)
      3.AMD HD:      OK (Аналогично, но при этом режиме даже экран не включается)
      ______________________________________________________________________________________

      Итак, нерешённые вопросы:
      1. Не работает звук/Работает некорректно.
      2. Не работает камера/Работает некорректно.
      3. Не работает сон/Работает некорректно.
       
          Уважаемые гуру и мастеры Йоды , помогите, пожалуйста, разобраться со звуком, пропатчить  AppleHDA. Неделю уже борюсь, всё никак .
          Патчил по этим мануалам:
      AppleHDA for M.Lion & Mavericks
      Complete AppleHDA Patching Guide
      AppleHDA Binary Patching
      AppleHDA.kext (rampagedev)
           Даже просил многоуважаемого Mirone пропатчить AppleHDA  (AppleHDA Patch Requests 27,28стр).
           Что самое интересное, полученные данные мной и Mirone расходятся:
      PinConfig (Без SPDIF)
      Mirone:
      Node 0х12(18) - 1000a090
      Node 0х14(20) - 20001390
      Node 0х18(24) - 30908100
      Node 0х21(33) - 40102100
      Мой:
      Node 0х12(18) - 3000a090
      Node 0х14(20) - 10001390
      Node 0х18(24) - 40908103
      Node 0х21(33) - 20102103

           Но факт, что ни тот ни другой вариант не заработали, пробовал другие варианты, вот что получилось (В скобках показаны возможные варианты двойки):


      Node 0х12(18) -   10      (00,01)         a0          90            - [Fixed] Mic at Int ATAPI - OK
      Node 0х14(20) -   20   (00,01,10)   (10,13)    (90,99)        - [Fixed] Speaker at Int ATAPI, EAPD: 0x02 - OK
      
Node 0х18(24) -   30         90             81     (00,01,03)     - [Jack] Mic at Ext Left
 - OK
      Node 0х21(33) -   40         10             21     (00,01,03)     - [Jack] HP Out at Ext Left - OK
      Первая двойка просто должна быть уникальная. ?

       
      РАБОЧИЙ PinConfig:
      01271C10 01271D00 01271EA0 01271F90
      01471C20 01471D00 01471E13 01471F90
      01871C30 01871D90 01871E81 01871F00
      02171C40 02171D10 02171E21 02171F00 01470C02
       
      PathNode:
      08 -> 35 -> 24
      09 -> 34 -> 18
      20 -> 13 -> 3
      33 -> 12 -> 2
       
      LayoutID = 1
           Какой всё-таки должен быть PinConfig? Голову уже сломал. Если несложно, помогите, пожалуйста.
       
      Итак, с PinConfig'ом разобрались. Решаем следующие вопросы:
      Как только делаю LayoutID inject (неважно каким способом: или через DSDT, или через HDAEnabler, или через Bootloader и т.д) Mac OSX грузиться очень долго: минуты 3 висит на сообщении "missing bluetooth controller transport", затем 2 минуты на сером экране, затем минуты 3 на экране приветствия, жду пока заработает клава с тачпадом, ввожу пароль, затем минут 10 жду пока система определит аудиоустройства в "System Information" и ещё минут 10 жду пока заработает звук, т.е появиться в "System Preference" и в "Audio MIDI Setup"; Такой же косяк , как и с VoodooHDA, каждые 10 минут пропадает звук или начинает хрипеть. Помогает изменение битности в "Audio MIDI Setup" на следующие 10 минут; При изменение системной громкости (неважно где, или в трее, или в "System Preference", или в "Audio MIDI Setup") начинаются 30 секундные лаги, аудио задержка и т.д. Возможные решения:
      Изменение DSDT (патчи) - пока не знаю какие; Дополнение HDEF секции; Изменение SignalProcessing в Layoutid.xml; Удаление/дополнение Amp в Platforms.xml; Подборка SMBios; Изменение параметров BIOS.  
      Дампы с Линукса, вербы с Винды  тут:
      Кексты тут:
      DSDT тут (после HPET, RTC, TMR, EHCI, DGTP, LPCB, IGP, Brighness патчей):
      AppleHDA ver 2.6.0f1 (10.9.2), работает и в 10.9.1 + LayoutID1.xml, Platforms.xml тут
       
      Господа, кто-нибудь может написать скрипт (демон), чтобы каждые 5 минут в "Audio MIDI Setup" менялась битность "Speaker ATAPI"/"Headphone (Black jack)" c "2ch-24bit channel" на "2ch-16bit channel" и обратно???
×