Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 

Mac OS X Snow Leopard on ASRock A330ION

5 posts in this topic

Recommended Posts

I've installed Mac OS X 10.6.8 on ASRock A330ION.


Bootloader: Chameleon 2.0 RC3

E/E: Disabler, OpenHaltRestart

S/L/E: FakeSMC (with CPUi & FakeSMCIntelThermal plugins), VoodooHDA + VoodooHDA.prefPane

Boot setting (attachment)

BIOS version: 1.40

CPU: Intel Atom N330

Graphics: nVidia GeForce 9400M

Sound: VIA VT2020

RAM: 2GB Kingston DDR3 1066


WLan: Sitecom USB (RTL8192SU)

BIOS setting:

Onboard GPU Clock: Manual (550, 1300)

CPU No-Excute Memory Protection: Disabled

CPU Hyper Threading Technology: Enabled

Share Memory: 512MB

Suspend to RAM: Disabled

ACPI HPET Table: Enabled

SATA Operation Mode: AHCI

Serial Port Address: Disabled

Legacy USB Support: Auto

CPU Fan Setting: Full On


Graphics QE/CI: work

LAN: work

WLan: work with RTL driver

Sound: VoodooHDA work with VoodooHDA.prefPane to reduce noisy

Restart: work


No work:

Shutdown - the fan is still running

Sleep - never wake up


Help: Anyone can help me to fix the Shutdown and Sleep problem. (well, sleep is not very necessary). Thanks.

Attach DSDT file (within Extra.zip).


Share this post

Link to post
Share on other sites


Chameleon 2.0 RC4: must set Legacy USB Support = "BIOS Setup Only" or "Disable"

Chameleon 2.0 RC5: Legacy USB Support = Auto


E/E also = NullCPUPowerManagement, OpenHaltRestart


E/E with EvOreboot = KP


Still got Shutdown/Sleep problem.

Share this post

Link to post
Share on other sites

Now solved the Shutdown problem. :hammer: Seep is not very important for me.


Delete DSDT.aml

Install Disabler, EvOreboot*, FakeSMC**, HDAEnabler, IOACPIFamily, PlatformUUID to E/E

S/L/E: VoodooHDA



* OpenHaltRestart instead

** FakeSMC with plugins in S/L/E


You may try 10.7.x compatible Kexts for Lion installation. Good luck!


Atom mach kernel mach_kernel_atom.zip

Extra setting Extra.zip

Extensions files Asrock A330ION Extensions.zip

Share this post

Link to post
Share on other sites

Thank you for this package! Had a long day today setting up my Asrock 330 Pro with 10.6.8 v1.1


What finally worked for me:


kernel flags: arch=i386, npci=0x2000

GraphicsEnabler=Yes with latest Chameleon r1995 (2.0 RC5)

Kexts from you last post + DSDT.aml from you extra.zip --> gives me Audio support without VoodooHDA (which is {censored} for this chip, some versions even cause Kernel errors and freezes on my system).

Restart/shutdown works (OpenHaltRestart)

QE/CI works via Chameleon GraphicsEnabler, no EFI string needed

Sleep: not tested

BIOS: 1.2


USB settings:

for navigation in bootloader: USB 2.0 off / Legacy enabled

for normal use and fast USB: USB 2.0 on / Legacy setup only


realized with Digital Dreamers Hackinstaller Script V7.1 (great tool!)

Thank you Alexylee for your package!


Things left:

Sleep (not tested, not important for me)

Audio (works very good, but has less bass than before) Got a second DSDT.aml, which is perfect for audio, but causes random freezes and brakes shutdown.

Share this post

Link to post
Share on other sites

Hi Alexylee and "itdoesnotwork",


I still have mine Asrock ION 330 running on 10.6.4.

All seems to work with the exception of sleep but I do not use that.


Now I have connected my HD tv to the Asrock and like to play via plex movies.

720 p it does nice 1080p not so.

Does one of you has the hdmi audio to work?

The optical Audio does work for me but goes to my receiver and I dont want to switch that one on every time I watch something from the asrock.

For sure it is something in the DSDT,aml file that needs to be changed if I only knew what :wink2:


I look forward to get your intel.



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.