Jump to content
InsanelyMac Forum
Sign in to follow this  
Johanmartin

USB issues. Computer won't go to sleep.

Recommended Posts

Sleep worked with 10.7.1, but after updating to 10.7.2 computer does not go to sleep unless I unplug all my USB devices. Kernel.log shows:

 

 

Wake reason: USB0

Mar 17 20:28:30 Anders-Eklofs-Mac-Pro kernel[0]: Previous Sleep Cause: 0

Mar 17 20:28:30 Anders-Eklofs-Mac-Pro kernel[0]: USB (EHCI):Port 1 on bus 0xfd connected or disconnected: portSC(0x101823)

Mar 17 20:28:30 Anders-Eklofs-Mac-Pro kernel[0]: USB (EHCI):Port 2 on bus 0xfd connected or disconnected: portSC(0x101823)

Mar 17 20:28:30 Anders-Eklofs-Mac-Pro kernel[0]: The USB device Razer Lachesis (Port 1 of Hub at 0x1d000000) may have caused a wake by being disconnected

Mar 17 20:28:30 Anders-Eklofs-Mac-Pro kernel[0]: The USB device Razer Lycosa (Port 2 of Hub at 0x1d000000) may have caused a wake by being disconnected

Mar 17 20:28:33 Anders-Eklofs-Mac-Pro kernel[0]: 0 0 AppleUSBCDC: start - initDevice failed

 

Only display goes to sleep. Can somebody please help?

 

Motherboard: Asus P6T6 WS Revolution

 

Processor: COREi7 965 3.2 GHZ

 

Grapshics: Geforce GTX 280

 

Memory: 12 GB DDR3

 

Operating system: Mac OSX Lion 10.7.2

Share this post


Link to post
Share on other sites
Advertisement

Similar issue on GA-EP45-DS3 here:

 

17.03.12 23:41:14,000 kernel: USB (EHCI):Port 5 on bus 0xfa connected or disconnected: portSC(0x301002)
17.03.12 23:41:14,000 kernel: An Unknown USB Device (Port 5 of Hub at 0xfa000000), may have caused a wake by being connected

 

Strangely enough, sleep used to work perfectly at some point.

Probably a DSDT issue?

 

Have you tried the "restart automatically after a power failure" checkbox? Wake on LAN settings in BIOS? Energy Management Schedule? Turning off automount for ntfs volumes?

 

Does yours go to sleep for a second, then wake up immediately without the monitor waking up? Because this is what mine does.

Share this post


Link to post
Share on other sites

Thanks for your reply! I think it is a dsdt issue. However, that is also strange because USB-busses are shown as built-in. I have tried everything in the energy management schedule. I can however find no setting for wake on lag in bios. Where should it be?

 

Could you post your dsdt?

Share this post


Link to post
Share on other sites

Hey Johan, if you board supports WOL, it should be in a section called power/energy management/etc.

It is however possible that your board simply does not support wake on lan.

 

My DSDT (GA-EP45-DS3) is here, perhaps we can figure out the cause together.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×